Results 1 to 3 of 3

Thread: Howto: Kppp on Kubuntu problems.

  1. #1
    Join Date
    Apr 2005
    Location
    South Africa
    Beans
    Hidden!
    Distro
    Kubuntu 7.04 Feisty Fawn

    Howto: Kppp on Kubuntu problems.

    Hi,
    After finding it just about impossible to get Kppp to work properly. I have found that Gnome-ppp is very stable in Kubuntu. The suggestion is to set up wvdial properly and then install Gnome-ppp from the repositories, which is actually a front end for wvdial. It lacks all the bells and whistles that kppp has, but it works. Only use kppp to query the modem as this will always work.
    Here are the details for those new to this:
    Tried and tested good old wvdial:
    The most reliable way to get dialed up is via wvdial from the konsole, but this means you need to keep the konsole open while you are connected to make sure that you are able to disconnect the modem by typing CTRL+C to disconnect from the telecom line and get back to your normal prompt. If you happen to close the konsole before disconnecting, you may have to reboot your PC to get the modem to disconnect or you may not be aware that you are still connected and run up an account! This can be solved by installing a dial up dialer gui. Some problems may also be picked up when initially configuring wvdial, such as detection of modem.


    In the konsole type:
    sudo wvdialconf /etc/wvdial.conf
    If this fails due to not finding a modem, it means the modem drivers are not properly installed, but if you can query the modem successfully in Kppp, then it may mean that wvdial cannot see /dev/modem to set itself up properly. In all cases you may have to open up the file:
    In Konqueror navigate to /etc/wvdial.conf, Right click, Actions, Edit as root and change or add the following lines so that the file looks like this below and save:


    [Dialer Defaults]
    Init1 = ATZ
    Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    Modem Type = Analog Modem
    ISDN = 0
    Phone = xxxxxxxxxxx
    New PPPD = yes
    Modem = /dev/modem
    Username = yyyyyyyyyyyyy
    Password = zzzzzzzzz
    Baud = 115200
    Stupid mode = on
    # Carrier Check = no


    xxxxxxxxx = the number to dial up your ISP
    yyyyyyyyy = your username supplied by your ISP
    zzzzzzzzz = your ISP access password
    In the last line remove the comment # to enable Carrier Check = no if you are using a Smartlink internal modem.
    You can also add W2 to the Init2 line to show the connection speed if required


    Now go to the console and type:
    sudo wvdial
    Once connected see if you can open your browser
    Remember to keep the konsole open while you are connected, you can minimise it if it is in your way.


    To disconnect line while in konsole type:
    CTRL+C to end the connection


    Some hints:
    If you find that you lose the connection after 30 sec to 3 minutes, then edit pppd.
    Right click on /etc/ppp/options, actions, Edit as root
    Find lcp-echo-interval 30 and lcp-echo-failure 4 and comment both out by adding a # at the beginning of the lines.
    If you find that you connect successfully, but cannot open any webpages in Firefox then add line default route to /etc/ppp/peers/wvdial


    Adding a gui to wvdial:


    The good news is that there is a nice simple gui for wvdial called Gnome-ppp. This is normally only used in Ubuntu and the name Gnome tends to keep KDE die-hards from installing it on Kubuntu, but it installs straight from the repositories. So once you have wvdial working and you can connect to the internet, enable and update your repositories, use your package manager to download and install Gnome-ppp, right click on the menu icon and create an icon on your desktop. Now rename it so as not to embarrass you as Kubuntu user! to e.g. “Dial up ISP” and it should work very nicely and is definitely more bullet proof than Kppp, even on KDE.


    Configuring Gnome-ppp:


    Open Gnome-ppp and click on Setup
    Under Modem tab, Device, you can click detect to have Gnome-ppp detect your modem, but as under the wvdial setup this would maybe not work and you will have to type in your modem device. This could be /dev/modem or /dev/ttyS0 if you have and external modem connected to Com1 or /dev/ttyS1 if on Com2. Here I would suggest using Kppp (the only reliable function that will always work) to Query the modem if you are having problems.
    Under Type select Analogue modem
    Under Speed 115200
    Phone line Tone
    Volume Hi (speaker volume)
    Dial attempts 1
    Wait for Dial tone checked
    Initstrings and phone number to dial should be picked up from your wvdial configuration, but if not enter them. (see wvdial)
    Under Networking tab
    Leave Dynamic IP Address and Automatic DNS enabled
    Under Options tab
    Check the following items as on, Abort connecting if no dial tone, Check carrier line, Check default route, Ignore terminal strings(Stupid mode). Leave the rest disabled or change any of the settings as your preferences once all is working.
    Close and reopen Gnome-ppp
    Type in your ISP username
    Type in your ISP password
    Check remember password
    Select the number to dial up or type in.
    Now click connect and you should be on.

    Hope this makes life more bearable if you are a dialup user.
    Regards,
    Matchless

    Proudly kubuntu!

  2. #2
    Join Date
    Aug 2009
    Location
    Ireland / The Czech Repub
    Beans
    272
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: Howto: Kppp on Kubuntu problems.

    Does 8.10 already have wvdial? If not could we have some newbie information on how to get it? I think I have it but I'm not sure I have everything I need as on another thread they said to download several things along with it but those things aren't available any more.

    When I type in any command using wvdial what I get is

    dev/moden - directory not found

    I'm using a huawei E106G dongel

    And to get gnome ppp you said "go to your package manager", I don't know how do do that.

    I know that if I can get gnome ppp working I should be able to connect to the internet using this dongel because I can with Ubuntu but not Kubuntu.

  3. #3
    Join Date
    Jul 2009
    Beans
    2

    Re: Howto: Kppp on Kubuntu problems.

    sudo apt-get install wvdial
    sudo apt-get gnome-ppp
    sudo gnome-ppp
    in configure it detect automaticly your modem-
    but you have to change to usb modem ,
    I used stupid mode
    it worked for me.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •