Page 1 of 8 123 ... LastLast
Results 1 to 10 of 72

Thread: HOW-TO Configure the VFD to work with MythTV on a Antec Fusion case

  1. #1
    Join Date
    Nov 2006

    HOW-TO Configure the VFD to work with MythTV on a Antec Fusion case

    I have a Antec Fusion case and I have been working for a little while to get the VFD to work correctly without impacting the functionality of my remote.

    If you have a Antec Fusion case, this one is for you!

    First, let's start by saying that eventhough the VFD on the Fusion is the OEM version of the Soundgraph iMon, it does not have the infrared module. In fact, even the firmware on that VFD doesn't have the necessary code to read IR, which means there's no way to extend it to become a full iMon IR/VFD.

    Eventhough Antec says on their web site that the case allows for a "space for a user-mounted IR Receiver", that's not true. There would have been enough space in the case, but the designer simply forgot about it. Like several others, I dismantled the front bezel and VFD to figure that out.

    Of course you will need a IR receiver to work with you Fusion case. For me a Mircosoft MCE receiver does the job.

    So here are the steps to get the VFD to work. I did this on MythTV 0.20 and Ubuntu Edgy.

    Let's first thanks the appropriate people and sites from which this info was collated: Venky Raju ( and Garth Dahlstrom (
    These guys made it all possible !

    Use Synaptics to get lcdproc (or from command line apt-get install lcdproc).
    Now if that install was doing everything right we could jump to the next step, but there's a few problems with it which we must fix manually.

    Do the following:
    sudo vi /etc/LCDd.conf
    Search for the section [server] and comment out the Driver=CFontzPacket.
    Uncomment the line Driver=imon

    Search for DriverPath and change it to read
    Save the file.

    Now edit the following file:
    sudo vi /etc/init.d/LCDd
    Change the line DAEMON_OPTS to read:
    DAEMON_OPTS="-s true -f true -c /etc/LCDd.conf
    Yes, eventhough the MAN pages for LCDd don't mention this, it really needs the "true" arguments.

    Now download the file from Venky for the standalone Imon VFD Driver:

    Untar it:
    tar xvzf imon_vfd.tgz
    cd imon
    Donwload the following patch from Garth Dahlstrom's web site and put it in the imon directory:

    Then apply the patch and compile
    cat imon-2.6.patch | patch
    make -C /usr/src/linux SUBDIRS=$PWD modules
    sudo make install
    This will have created the /dev/lcd0 device that you need to talk to the LCD.

    Now let's do the final steps: loading the drivers and testing if everything works.
    modprobe imon_vfd
    # Run /usr/sbin/LCDd manually to check all is good.
    sudo /usr/sbin/LCDd
    If it worked without error you should see something on your VFD. We can now kill LCDd:
    sudo killall LCDd
    And start it like it should be started, in the background:
    sudo /etc/init.d/LCDd start
    Now we need to make sure all this gets loaded properly when rebooting:
    Edit /etc/modules and add the following line at the end:
    That's it! All you have to do is reboot.

    Now start MythTV front-end and go to the Setup/Appearance section.

    In there you will find the "Enable LCD device" option. By setting it ON, the mythlcdserver be started and it will communicate with LCDd and display info on the LCD during various MythTV operations.

    Enjoy !

    If you cannot find the module LCDd when you do a "ps ax | grep LCDd" then you may have to:
    sudo update-rc.d LCDd defaults
    If you want to figure out what is happening, you will find the LCDd error messages in /var/log/syslog

  2. #2

    Re: HOW-TO Configure the VFD to work with MythTV on a Antec Fusion case

    Nicely done. I'll move this into the Howto section, so it has a prominent place in history.
    Ubuntu user #7247 :: Linux user #409907

  3. #3
    Join Date
    Apr 2006

    Re: HOW-TO Configure the VFD to work with MythTV on a Antec Fusion case

    Thanks for the HOWTO, works nicely. 2 minor notes:

    DAEMON_OPTS="-s true -f true -c /etc/LCDd.conf
    missing closing quote, should be
    DAEMON_OPTS="-s true -f true -c /etc/LCDd.conf"

    I had to change the make command too:
    make -C /usr/src/linux SUBDIRS=$PWD modules
    The command that worked for me was:

    make -C /usr/src/linux-headers-2.6.17-10-generic/ SUBDIRS=$PWD modules

    Any idea how to get the big volume knob working?

  4. #4
    Join Date
    Nov 2006

    Re: HOW-TO Configure the VFD to work with MythTV on a Antec Fusion case

    Thanks for the notes vesok !

    I still haven't figured out the volume knob. The solution probably lies around the use of LIRC imon module, however if we activate it we must be careful not to lose our standard USB IR receiver functionality.

    I believe the LIRC iMon module was made to work with the standard iMon package which includes the VFD and the IR receiver all-in-one. With the Antec case since the IR Receiver is separate, we would need to somehow indicate to lirc_imon that we only want it to take control of the volume knob and leave alone the other IR functionality.

    Maybe it would work if we setup the lirc_imon as a second IR module? I haven't given this a try yet. If you do, let me know. If I get it working I'll post the how-to here.

    Please note this How-To was also copied to the How-to section, so I would post the reply to the How-to section as well.

  5. #5
    Join Date
    Dec 2006

    Re: HOW-TO Configure the VFD to work with MythTV on a Antec Fusion case


    First many thanks for the how to worked for my to get my fusion case display up and running.

    I have one issue I hope someone can shed light on, I am using mythTV on the system the antec houses all the menu items and media itms display OK but when I turn the clock on I am not getting complete charcaters formed. Is there some set up in LCDPorc or MythTV that could effect this behaviour?

    Thanks AK

  6. #6
    Join Date
    Nov 2006

    Re: HOW-TO Configure the VFD to work with MythTV on a Antec Fusion case

    Two things I would check:

    If your problem is only when the time is displayed (while all the rest works fine), then you problem is likely the setting for "Display Large Clock".
    In MythTV, in the Setup/Apperance menu, go to the "LCD device display" screen and make sure the "Display Large Clock" checkbox is NOT checked.
    There appears to be a bug with this and I'm not sure if it's in MythTV itself of LCDProc. Only the "one line" clock will work.

    If your problem is with any thing that is displayed on your VFD, then check out /etc/LCDd.conf and make sure that in your section " [imon]" the "Size=16x2".

  7. #7
    Join Date
    Sep 2005

    Re: HOW-TO Configure the VFD to work with MythTV on a Antec Fusion case

    Is it possible on the stand alone imon VDF to use simultaneously the VDF + Lirc + the Knob?
    Does the VDF works in lcd4linux?

  8. #8
    Join Date
    Nov 2006

    Re: HOW-TO Configure the VFD to work with MythTV on a Antec Fusion case

    As far as I know you will be able to use the VFD and the remote.
    I don't think the knob will work (at least not with Venky's patch).

  9. #9
    Join Date
    Feb 2006

    Re: HOW-TO Configure the VFD to work with MythTV on a Antec Fusion case

    I've got the knob to work. At least, I can get it to work once I've booted my computer. But I wasn't able to do it automatically during boot, but perhaps there's somebody here who can help me with that.
    Here's how I did it.

    I assume that you've got the VFD already working. I used the lirc_imon module for that. You can compile it from the lirc sources. During configuration choose the IMON Multimedian IR/VFD driver. (There's also a IMON Knob driver, but that did strange things to my sound).

    Next, add the following to your lird.conf file: (source)
    begin remote
      name  ClickWheel
      bits           24
      eps            30
      aeps          100
      one             0     0
      zero            0     0
      post_data_bits  8
      post_data      0xFF
      gap          131993
      toggle_bit      0
          begin codes
              WheelCC                  0x010000
              WheelCW                  0x000100
              WheelClick               0x000008
          end codes
    end remote
    The line "WheelClick 0x000008" isn't necessary for the Antec Fusion, since that knob isn't a clickwheel, but it doesn't hurt to leave in there.

    Now since we have two lirc devices (your remote and the Antec volume knob) we have to have two instances of lircd running. In my case, my PVR-350 remote is on /dev/lirc0 and my volume knob is on /dev/lirc1. You can determine which lirc device you have by doing:
    cd /dev
    ls | grep lirc
    You're output will look something like:
    To determine which lirc is which device type:
    ps ax | grep lirc
    You will now get (amongst others) a line like:
    4820 ?        Ss     0:00 /usr/sbin/lircd --device=/dev/lirc0
    This will be the device you've already got working, probably your remote.

    Now, stop lircd by doing:
    sudo killall lircd
    Or on not Debian-like distro's:
    killall lircd
    Now start the two lircd instances in the following way:
    # First use the lirc device for the volume knob, in my case /dev/lirc1
    lircd --driver=default --device=/dev/lirc1 --output=/dev/lircd1 --pidfile=/var/run/ --listen
    # Now use the lirc device for your remote
    lircd --driver=default --device=/dev/lirc0 --output=/dev/lircd --pidfile=/var/run/ --connect=localhost:8765
    If everything went well, you're volume knob is now working. You can test this by doing:
    Now turn the knob and press some buttons on your remote. You will see an output similar to the one below.
    #Output for the volume knob
    00000000000100ff 00 WheelCW ClickWheel
    00000000000100ff 01 WheelCW ClickWheel
    00000000000100ff 02 WheelCW ClickWheel
    00000000010000ff 00 WheelCC ClickWheel
    00000000010000ff 01 WheelCC ClickWheel
    #Output for the remote
    0000000000001790 00 Vol+ Hauppauge_350
    0000000000001790 00 Vol+ Hauppauge_350
    00000000000017a0 00 Ch+ Hauppauge_350
    00000000000017a0 01 Ch+ Hauppauge_350
    00000000000017a1 00 Ch- Hauppauge_350
    To make the knob actually do something you have to add entries to your .lircrc file.

    This is how far I got it to work. If anyone here knows how start lircd in this way during boot, I would really appriciate it if you could let me know.
    Last edited by broxtor; April 15th, 2007 at 06:53 PM. Reason: Changed thread notification type.

  10. #10
    Join Date
    Jun 2005
    Knaresborough, UK

    Re: HOW-TO Configure the VFD to work with MythTV on a Antec Fusion case

    Followed howto with cuurent feisty linux kernel 2.6.20-15 and I get these errors
    Any help appreciated

    mythtv@peter-desktop:~/imon$ make -C /usr/src/linux-headers-2.6.20-15-generic/ SUBDIRS=$PWD modules
    make: Entering directory `/usr/src/linux-headers-2.6.20-15-generic'
    CC [M] /home/mythtv/imon/imon_vfd.o
    /home/mythtv/imon/imon_vfd.c:34:26: error: linux/config.h: No such file or directory
    /home/mythtv/imon/imon_vfd.c:43:35: error: linux/devfs_fs_kernel.h: No such file or directory
    /home/mythtv/imon/imon_vfd.c: In function ‘send_packet’:
    /home/mythtv/imon/imon_vfd.c:328: warning: passing argument 6 of ‘usb_fill_int_urb’ from incompatible pointer type
    make[1]: *** [/home/mythtv/imon/imon_vfd.o] Error 1
    make: *** [_module_/home/mythtv/imon] Error 2
    make: Leaving directory `/usr/src/linux-headers-2.6.20-15-generic'

Page 1 of 8 123 ... LastLast


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts