Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 45

Thread: Alpha Centauri crashes?

  1. #11
    Join Date
    Dec 2004
    Location
    Vancouver, BC
    Beans
    228
    Distro
    Ubuntu

    Re: Alpha Centauri crashes?

    in the alpha centauri root directory, there should be a few shell scripts (at least there are on my box. I obtained the game through questionable sources, as I already had the Windows version, and couldn't find the linux version for sale anywhere anyway). Anyways, there should be "smac.dynamic", "smac", "smacx.dynamic" and "smacx". Just run smac for the statically linked version of the game, or smacx for the expansion. It works great on Feisty for me. I played 3 complete games over the weekend.

  2. #12
    Join Date
    Feb 2005
    Beans
    56

    Re: Alpha Centauri crashes?

    Quote Originally Posted by Pugwash View Post
    . . .You have to run "smackpack" as root or else it doesn't work. Dunno why.
    I don't really know why this works, but it does. And it's SO AWESOME.

  3. #13
    Join Date
    May 2007
    Beans
    24

    Re: Alpha Centauri crashes?

    Sorry I to dig up an old thread but I can't get this to work. I have followed the instructions posted and I still get the error message:

    X Error: BadMatch
    Request Major code 66 ()
    Error Serial #740
    Current Serial #743

    I'm running Ubuntu 7.04 and have installed the planetary pack using Pugwash's instructions. Though I installed the game originally without these instructions but uninstalled it using the uninstall package (seemed to clear it up fine). Would I need to follow the instructions at "how to run old loki games"? The instructions at the weblink seem very unclear.

  4. #14
    Join Date
    May 2007
    Beans
    24

    Re: Alpha Centauri crashes?

    I have downloaded the old glibc package and extract it to my home folder. I run the command in terminal:

    LD_LIBRARY_PATH=/home/ash/Loki_Compat/ /home/ash/Loki_Compat/ld-linux.so.2 /usr/local/games/smac/smac.dynamic

    and get the response:

    Creating Loki preferences directory: /home/ash/.loki/
    Creating smac preferences directory: /home/ash/.loki/smac
    Inconsistency detected by ld.so: dynamic-link.h: 62: elf_get_dynamic_info: Assertion `! "bad dynamic tag"' failed!

  5. #15
    Join Date
    Mar 2007
    Beans
    18
    Distro
    Ubuntu 6.10 Edgy

    Re: Alpha Centauri crashes?

    I get the inconsistency error too, anybody know how to fix that?

  6. #16
    Join Date
    Dec 2005
    Beans
    264
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Alpha Centauri crashes?

    I'm getting both of these errors. If I try to run the game using just "smac" or "smacpack" I get through the initial menus and then when my ship lands, it crashes out with the:
    Code:
      X Error:  BadMatch
      Request Major code 66 ()
      Error Serial #530
      Current Serial #533
    (The numbers in the last two lines change). Running as root does not change anything.
    If I run with the LD_LIBRARY_PATH... command, I get:
    Code:
    Creating smac preferences directory: /home/username/.loki/smac
    Inconsistency detected by ld.so: dynamic-link.h: 62: elf_get_dynamic_info: Assertion `! "bad dynamic tag"' failed!
    I have been following the instructions on the following sites: http://patrick.wagstrom.net/weblog/l...haCentauri.xml
    http://lordhedgehog.hedgie.com/smac/
    http://gentoo-wiki.com/HOWTO_Running_Old_Loki_Games

    I am running Xubuntu 7.04
    Last edited by BrendanM; July 1st, 2007 at 11:48 AM.

  7. #17
    Join Date
    Dec 2005
    Beans
    264
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Alpha Centauri crashes?

    Success!!! I finally got it working.
    After reading this thread: http://ubuntuforums.org/showthread.p...Alpha+Centauri
    I added
    Code:
    Section "Extensions"
    	Option "Composite" "Disable"
    EndSection
    to my xorg.conf, restarted X and now it magically works just starting with "smac".

    To summarize, I installed using the normal Loki installer, patched the install following instructions here: http://lordhedgehog.hedgie.com/smac/
    and then added the above section to xorg and that made it work. I do have the compatibility libraries installed, but they don't seem to be necessary since I'm not using any special commands to launch the game.

  8. #18
    Join Date
    Nov 2004
    Beans
    101

    Re: Alpha Centauri crashes?

    [QUOTE=BrendanM;2944043
    To summarize, I installed using the normal Loki installer......[/QUOTE]

    how did you do this - i can't install the loki installer as it is greyed out and i get an error :
    This installation doesn't support glibc-2.1 on Linux / x86

    how many people actually have this game working? would be very grateful for a detailed blow by blow description of exactly what you did

    thanks

    Doc

    PS - when the post talk about 'installing; libs in a certain directory does this mean you just copy them to the directory? - or do you need to do anything else?

    thanks again

  9. #19
    Join Date
    Jul 2007
    Beans
    18

    Re: Alpha Centauri crashes?

    I have it working, the static version, when I try to start the dynamic version I get the same inconsistency errors as above. I disabled compositing as detailed above to get the static version to work. The only problem is that I can't see the movies, my monitor flicks to no signal when they come on. I can hear sound though. Anybody any idea how to force the movies to play at a reasonable resolution / refresh rate using the static version?

  10. #20
    Join Date
    May 2007
    Beans
    46
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Alpha Centauri crashes?

    Quote Originally Posted by Doctoxic View Post
    how did you do this - i can't install the loki installer as it is greyed out and i get an error :
    This installation doesn't support glibc-2.1 on Linux / x86

    how many people actually have this game working? would be very grateful for a detailed blow by blow description of exactly what you did

    thanks

    Doc

    PS - when the post talk about 'installing; libs in a certain directory does this mean you just copy them to the directory? - or do you need to do anything else?

    thanks again
    Well, I finally got it working. I posted my step-by-step instructions over in this thread.
    http://ubuntuforums.org/showthread.php?t=345846

Page 2 of 5 FirstFirst 1234 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •