Page 3 of 6 FirstFirst 12345 ... LastLast
Results 21 to 30 of 55

Thread: HOWTO: Nvidia 9742 beta drivers in Edgy/Feisty

  1. #21
    Join Date
    Nov 2006
    Beans
    1
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: HOWTO: Nvidia 9742 beta drivers in Edgy/Feisty

    This error has been bugging me for some time now:

    ERROR: The kernel source path '=/usr/src/linux-headers-2.6.17-10-generic' does
    not exist. Please make sure you have installed the kernel source files
    for your kernel and that they are properly configured; on Red Hat Linux
    systems, for example, be sure you have the 'kernel-source' or
    'kernel-devel' RPM installed. If you know the correct kernel source
    files are installed, you may specify the kernel source path with the
    '--kernel-source-path' command line option.
    I have installed via the Synaptic Package Manager the following:

    linux-headers-2.6.17-10-generic
    linux-headers-2.6.17-10
    kernel-headers-2.4.27-2-386
    kernel-headers-2.4.27-2

    ...Or at least that's what's in /usr/src/. Any help would be greatly apriciated.


    ePlus

  2. #22
    Join Date
    Dec 2004
    Location
    London, UK
    Beans
    69
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: HOWTO: Nvidia 9742 beta drivers in Edgy/Feisty

    Okay, this worked perfectly for me until I rebooted, at which point I got an error saying: "API mismatch: the NVIDIA kernel module has the version 1.0-7184, but this X module has the version 1.0-9742..."

    I tried a few things, none of which worked, then came across this nvnews post.

    What worked for me was the very last bit:

    you can edit the /etc/default/linux-restricted-modules configuration file and disable the NVIDIA linux-restricted kernel modules (nvidia, nvidia_legacy) via:

    DISABLED_MODULES="nv"
    Hope this helps if anybody else has similar problems.
    "Only two things are infinite: the universe and human stupidity, and I'm not sure about the universe."
    Albert Einstein

  3. #23
    Join Date
    Jun 2006
    Beans
    50
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: HOWTO: Nvidia 9742 beta drivers in Edgy/Feisty

    Worked like magic. Thank ye.
    -Ev

    Gyf þu riht nimst, nelt ðu wifes wesan!

  4. #24
    Join Date
    Oct 2005
    Location
    CT, USA
    Beans
    60
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: HOWTO: Nvidia 9742 beta drivers in Edgy/Feisty

    Do you need to uninstall the restricted modules packages for this to work? I need them for my wireless card, but I'd love to get the beta driver...

  5. #25
    Join Date
    Oct 2005
    Beans
    102

    Re: HOWTO: Nvidia 9742 beta drivers in Edgy/Feisty

    My linux-restricted-modules are installed and everything is working fine.

  6. #26
    Join Date
    Oct 2006
    Location
    United States
    Beans
    625
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: HOWTO: Nvidia 9742 beta drivers in Edgy/Feisty

    At last running on 6.10..

    The only way that I get the drivers to compile is uninstalling the restricted modules packages, if not, lot of errors or driver different version of X11 happens

    Thank for the guide
    ^MEDUZA^

  7. #27
    Join Date
    Oct 2005
    Location
    United Kingdom
    Beans
    4,848

    Re: HOWTO: Nvidia 9742 beta drivers in Edgy/Feisty

    Quote Originally Posted by whitewizardcoder View Post
    Do you need to uninstall the restricted modules packages for this to work? I need them for my wireless card, but I'd love to get the beta driver...
    Follow this post as well...

    (it is explained in the UDSF doc)
    Quote Originally Posted by Marquis_de_Carabas View Post
    Okay, this worked perfectly for me until I rebooted, at which point I got an error saying: "API mismatch: the NVIDIA kernel module has the version 1.0-7184, but this X module has the version 1.0-9742..."

    I tried a few things, none of which worked, then came across this nvnews post.

    What worked for me was the very last bit:
    you can edit the /etc/default/linux-restricted-modules configuration file and disable the NVIDIA linux-restricted kernel modules (nvidia, nvidia_legacy) via:

    DISABLED_MODULES="nv"
    Hope this helps if anybody else has similar problems.
    Every time you install Jaunty, a kitten........ wait sorry what year is this again?
    Please don't PM support questions, post a thread so that everyone can benefit
    Join us in #ubuntuforums on irc.freenode.net

  8. #28
    Join Date
    Oct 2005
    Location
    CT, USA
    Beans
    60
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: HOWTO: Nvidia 9742 beta drivers in Edgy/Feisty

    That worked! Thanks for the guide!

  9. #29
    Join Date
    Jun 2006
    Location
    Sunny South Florida
    Beans
    93
    Distro
    Ubuntu 10.04 Lucid Lynx

    Lightbulb Re: HOWTO: Nvidia 9742 beta drivers in Edgy/Feisty

    Quote Originally Posted by whitewizardcoder View Post
    That worked! Thanks for the guide!
    Works for me too. Just a quick note to everyone. Make sure you aren't neglecting to use "uname -r" in the command for the nvidia installer. That is to say:

    Code:
    sudo ./nvidia-installer -n -s --x-prefix=/usr/lib/xorg/ --kernel-source-path=/usr/src/linux-headers-`uname -r`
    and NOT something like:

    Code:
    sudo ./nvidia-installer -n -s --x-prefix=/usr/lib/xorg/ --kernel-source-path=/usr/src/linux-headers-2.6.17-10
    I say this because I was just hitting TAB to complete my directory info and it didn't work with the "...2.6.17-10" path (but the `uname -r` did instead). It seems weird that it didn't though, seeing as how I am using that kernel.
    Last edited by mjpoetic; November 17th, 2006 at 04:43 PM. Reason: minor addition
    "Education is the most powerful weapon which you can use to change the world." - Nelson Mandela

  10. #30
    Join Date
    Aug 2006
    Beans
    166
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HOWTO: Nvidia 9742 beta drivers in Edgy/Feisty

    Quote Originally Posted by mjpoetic View Post
    I say this because I was just hitting TAB to complete my directory info and it didn't work with the "...2.6.17-10" path (but the `uname -r` did instead). It seems weird that it didn't though, seeing as how I am using that kernel.
    That's because you've got more than one item (dir/file) in /usr/src/ starting with linux-headers-2.6.17-10, and since tabbing can't guess which one you want, it just completes the first (piece of) string that is common to all such items. Double-tab then to display all possibilities.

    Additionally, type in a terminal uname -r, echo `uname -r`, or echo $(uname -r) to see what `uname -r` and $(uname -r) are replaced with when parsed in a command, and what was missing when you tried using linux-headers-2.6.17-10 through tabbing (possibly -386, -686, -generic, etc).
    Last edited by Shinoda; November 18th, 2006 at 05:42 PM. Reason: minor bettering

Page 3 of 6 FirstFirst 12345 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •