Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: How to enable Numlock on startup in KDE

  1. #1
    Join Date
    Sep 2006
    Location
    Brooklyn, NY
    Beans
    59
    Distro
    Kubuntu 6.06

    How to enable Numlock on startup in KDE

    This guide is for _KDE_ users who want to have Numlock on at startup. numlockx only works in GNOME, but in KDE, this feature is already built in.

    All you need to do is:

    Open up /etc/kde3/kdm/kdmrc in a text editor. Search for "NumLock" and you should arrive at something that looks like the following:

    Code:
    # What to do with the Num Lock modifier for the time the greeter is running:
    # "Off" - turn off
    # "On" - turn on
    # "Keep" - do not change the state
    # Default is Keep
    #NumLock=Off
    Uncomment the last line so it looks like:

    Code:
    # What to do with the Num Lock modifier for the time the greeter is running:
    # "Off" - turn off
    # "On" - turn on
    # "Keep" - do not change the state
    # Default is Keep
    NumLock=On
    It's that simple!

  2. #2
    Join Date
    Jun 2006
    Location
    Groningen
    Beans
    835
    Distro
    Kubuntu 12.04 Precise Pangolin

    Re: How to enable Numlock on startup in KDE

    why not
    Menu -> System Settings -> Hardware -> Keyboard -> NumLock on KDE startup -> Turn on

  3. #3
    Join Date
    Jan 2005
    Location
    Italy - between Alps and Mediterranean Sea
    Beans
    20
    Distro
    Kubuntu 6.10 Edgy

    Re: How to enable Numlock on startup in KDE

    This tip is nice (both ways work). I was thinking to set this problem, but I've been lazy recently and didn't search around.

    Thanks for supporting a lazy Kubuntu user

    Andy
    Last edited by darkghost; November 9th, 2006 at 05:09 PM. Reason: Typos and poor english

  4. #4
    Join Date
    Sep 2006
    Location
    Brooklyn, NY
    Beans
    59
    Distro
    Kubuntu 6.06

    Re: How to enable Numlock on startup in KDE

    Because that turns it on after login. If you want it to turn on at bootup, then this is the way to do it.

  5. #5
    Join Date
    Jan 2008
    Beans
    333

    Re: How to enable Numlock on startup in KDE

    The information above seems to be out of date. I was unable to follow it.
    Instead, I did this:
    Control Panel -> Peripherals -> Keyboards
    (Turn On - Numlock at Startup)

  6. #6
    Join Date
    Feb 2008
    Location
    Cape Town, South Africa
    Beans
    Hidden!
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: How to enable Numlock on startup in KDE


  7. #7
    Join Date
    Feb 2008
    Location
    Cape Town, South Africa
    Beans
    Hidden!
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: How to enable Numlock on startup in KDE

    Something funny in that file
    Code:
    #!/bin/sh
    # Stolen from the debian kdm setup, aren't I sneaky
    # Plus a lot of fun stuff added
    #  -George

  8. #8
    Join Date
    May 2005
    Location
    US
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How to enable Numlock on startup in KDE

    Quote Originally Posted by anystupidname View Post
    The information above seems to be out of date. I was unable to follow it.
    Instead, I did this:
    Control Panel -> Peripherals -> Keyboards
    (Turn On - Numlock at Startup)
    Quote Originally Posted by TheWizzard View Post
    why not
    Menu -> System Settings -> Hardware -> Keyboard -> NumLock on KDE startup -> Turn on
    Yes, I'm not quite sure why this tutorial has people editing configuration files. Even in 2005 (when I first started out with Mepis), KDE had the option to keep numlock on at startup.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	KDE Numlock.png 
Views:	374 
Size:	30.4 KB 
ID:	61027  

  9. #9
    Join Date
    May 2008
    Beans
    1,029

    Re: How to enable Numlock on startup in KDE

    I wanted to post how I got numlockx to work at kdm startup in case it helps somebody. I didn't notice this posted anywhere in this thread and this was the only way that I got it to work. The options in the control center only effect numlock after you log in.

    Open /etc/kde3/kdm/Xsetup and add the following to it:
    Code:
    if [ -x /usr/bin/numlockx ]; then
          /usr/bin/numlockx on
    fi
    Edit: I was able to figure this out with help from this page: http://wiki.archlinux.org/index.php/...lock_on_Bootup. According to this page Xsetup is located in /usr/share/config/kdm/Xsetup. But I found it in /etc/kde3/kdm/Xsetup, I'm guessing that is because I am using a different version of kdm, or linux, or something. Also this page says that all you have to add is "numlockx on". I did not try this so I don't know if it works.
    Last edited by dodle; August 25th, 2008 at 04:35 AM.

  10. #10
    Join Date
    Feb 2008
    Location
    Cape Town, South Africa
    Beans
    Hidden!
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: How to enable Numlock on startup in KDE

    Quote Originally Posted by rubinboy View Post
    Quote Originally Posted by dodle View Post
    Open /etc/kde3/kdm/Xsetup and add the following to it:
    Code:
    if [ -x /usr/bin/numlockx ]; then
          /usr/bin/numlockx on
    fi
    Very similar to "my" way for Gnome. Maybe think about adding it to the wiki.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •