Results 1 to 4 of 4

Thread: Upgraded to Edgy and Firefox unable to open .deb files with gdebi-gtk

  1. #1
    Join Date
    Oct 2006
    Beans
    11

    Upgraded to Edgy and Firefox unable to open .deb files with gdebi-gtk

    Going nutz trying to figure out this problem. In 6.06 Firefox v1.5x would ask to open .deb files with gdebi-gtk. Edgy has Firefox v2.0 and never prompts to install.deb files when you click on a .deb download link.

    Application gdebi-gtk is installed in the same place in both 6.06 and 6.10,
    /usr/bin/gdebi-gtk.

    It's not in the "View and Edit options" of the Firefox "Download" tab.

    Any ideas?


    TIA,
    David

  2. #2

    Question Re: Upgraded to Edgy and Firefox unable to open .deb files with gdebi-gtk

    Hi, did you solve this?

    I'm having the same thing with Firefox 2.x on Hardy Heron.

    Have already used it once to install a package (Salasaga), then came back later after rebooting the system (a virtual machine) and now... packages don't have the option to install with GDebi.. just save to disk.

    Even went back to the exact same Salasaga download on SourceForge and that also just "Save to disk" option.

  3. #3

    Exclamation Re: Upgraded to Edgy and Firefox unable to open .deb files with gdebi-gtk

    Hmmmm, am now suspecting it's something to do with the mime headers (content type) being sent by the web server.

    Different SourceForge mirrors are sending different mime header content type info for the exact same file.

    This one from Internap works fine, GDebi is presented, etc:

    http://internap.dl.sourceforge.net/s...untu1_i386.deb

    Content type sent by the Internap web server is "Content-Type: text/plain".

    This one from Switch (exact same file) only gives the "Save a file" option:

    http://switch.dl.sourceforge.net/sou...untu1_i386.deb

    Content type sent by the Switch web server is "Content-Type: application/octet-stream".

    How strange.

  4. #4
    Join Date
    Aug 2007
    Location
    Torrington, Wyoming
    Beans
    372
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Upgraded to Edgy and Firefox unable to open .deb files with gdebi-gtk

    hey if is that old and unanswered then leave it be please.
    すべてと、そして、すべてへのリナックスは自由を鳴らせました。
    Linux to all, and to all, let freedom ring.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •