Page 93 of 137 FirstFirst ... 43839192939495103 ... LastLast
Results 921 to 930 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #921
    Join Date
    Mar 2008
    Beans
    62
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    CIFS VFS: Server not responding
    If you see this error during shutdown, and or your shutdown sequence halts because of this error message:
    Code:

    [18.312000] CIFS VFS: Server not responding
    [18.312000] No response for cmd 5 mid 8

    Run these two commands:
    Code:

    ln -s /etc/init.d/umountnfs.sh /etc/rc0.d/K15umountnfs.sh
    ln -s /etc/init.d/umountnfs.sh /etc/rc6.d/K15umountnfs.sh

    Source: http://ubuntuforums.org/showthread.php?t=1128729

    *thanks to incoming429 for testing the fix on this error.
    I have done the above but I still get the Server not responding message when switching down, I have tried manually unmounting the drives but it says that I need to be root - what have I missed?

    David

  2. #922
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by swatsbiz View Post
    I have done the above but I still get the Server not responding message when switching down, I have tried manually unmounting the drives but it says that I need to be root - what have I missed?

    David
    When it says you need to be root, just prefix your command with sudo like so:
    Code:
    sudo umount /media/sharename
    Here's another possibility for fixing the CIFS VFS: Server not responding error:
    1) Edit /etc/gdm/PostSession/Default
    Code:
    gksudo gedit /etc/gdm/PostSession/Default
    2) Add your unmount line to the top of the file (right below #!/bin/sh) like so:
    Code:
    #!/bin/sh
    umount /media/sharename
    
    PATH="/usr/bin:$PATH:/bin:/usr/bin"
    OLD_IFS=$IFS
    
    gdmwhich () {
      COMMAND="$1"
      OUTPUT=
      IFS=:
      for dir in $PATH
      do
        if test -x "$dir/$COMMAND" ; then
          if test "x$OUTPUT" = "x" ; then
            OUTPUT="$dir/$COMMAND"
          fi
        fi
      done
      IFS=$OLD_IFS 
      echo "$OUTPUT"
    }
    
    exit 0
    Save the file and exit.
    Last edited by dmizer; May 15th, 2009 at 12:40 AM.

  3. #923
    Join Date
    Mar 2008
    Beans
    62
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mount samba shares with utf8 encoding using cifs

    Thanks dmizer,

    adding the umount for each of the network shares in the PostSession/Default worked a charm

  4. #924
    Join Date
    Jul 2008
    Beans
    68
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Angry Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by sloppyc View Post
    Thanks to the OP! This worked flawlessly on the first try. I just skipped the netbios part and substituted the IP address for my own needs. Now I have my shared media from my Vista box mounted at bootup. Awesome.

    Okay, this did work in Hardy. I upgraded to Jaunty, now I get this:
    Code:
    mount error(13): Permission denied
    Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)
    mount error(13): Permission denied
    Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)
    mount error(13): Permission denied
    Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)
    mount error(13): Permission denied
    Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)
    Here's my fstab:
    Code:
    # /etc/fstab: static file system information.
    # Use 'vol_id --uuid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    # / was on /dev/sda1 during installation
    UUID=af04d48e-9288-41b6-9d3f-d7ced1be6ac8 /               ext3    relatime,errors=remount-ro 0       1
    # /home was on /dev/sdb1 during installation
    UUID=2f52c6fd-e43d-4796-b2a5-fdf944e31ee7 /home           ext3    relatime        0       2
    # swap was on /dev/sda5 during installation
    UUID=63cde2cd-974c-33a1-de20-181f6e7ea2a2 none            swap    sw              0       0
    /dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
    
    ##Network shares
    //192.168.0.199/Audio           /media/Audio            cifs    credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_m$
    //192.168.0.199/Videos          /media/Videos           cifs    credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_m$
    //192.168.0.199/Software        /media/Software         cifs    credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_m$
    //192.168.0.199/iTunes          /media/iTunes           cifs    credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_m$
    I have set up smbpasswd and I can access the shares when I go the "connect to server" route. So the account does have permission.

    I tried adding "nounix" after ".smbcredentials" and that made no difference (do I really want "nounix" anyway? I'm just running Vista at the moment, but I will be installing Ubuntu and openSUSE on here and would like the shares avalable to the other PCs no matter what OS I'm in as I did before I upgraded my machines this week)

  5. #925
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    @sloppyc:

    Make sure that smbfs is installed:
    Code:
    sudo aptitude install smbfs

  6. #926
    Join Date
    Jul 2008
    Beans
    68
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    @sloppyc:

    Make sure that smbfs is installed:
    Code:
    sudo aptitude install smbfs
    It is.

  7. #927
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Jaunty seems to have UFW enabled by default. Try this:
    Code:
    sudo ufw disable
    Then try to connect again.

  8. #928
    Join Date
    Mar 2009
    Beans
    19

    Re: Mount samba shares with utf8 encoding using cifs

    Thanks dmizer for creating and posting this tutorial. Without it, I and many other M$ users starting of in Linux would be lost in getting our network drives to work. I was until I found this thread in trying to get my Dlink DNS323 to work.

    I am having an issue and I hope you can help. I am using linuxMint 7 based off jaunty. It is in RC1 form right now and I have installed the kubuntu-desktop because I prefer KDE over gnome. I did not have this issue in Gnome...

    Here is the problem, with my NAS set to sleep after 30 minutes of inactivity. I have a line in fstab to automount on boot for one folder without password. I have noticed that the drive wakes from sleep without me even navigating to it. The mount is in my /home/usr/mnt/xxx folder. This issue of it waking after boot is irritating me.

    It will even wake up when I am using Firefox or Open Office and use the file dialog system. Initially I thought it was due to them being GTK apps. But then I realized that the drive is mounted in my home user folder system and that is where firefox, open office open the file dialog system to.

    So I have now moved the mount to my root, /mnt/xxx/ This seems to have solved the problem of it waking up on boot as well as in firefox, open office file dialogs. But if I do a file search in Dolphin it will go through all folders including the root /mnt/ folders and wake up the drive.

    Since I have hopefully stopped this from waking up every few minutes without me even navigating to it the file search isn't that big of deal.

    Like I said, this is a folder without password restrictions. So I can see where it would search and wake it up.

    But do you know how to stop this behavior regardless of where it is mounted, file dialog usage, or file search?

    Is there any way of setting a user/password in ubuntu for a guest mounted network drive? Maybe this would stop the behavior in having a password entered before gaining access to it???

    Thank you for any help...I do appreciate it on this very aggravating problem.

  9. #929
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Can't think of anything other than to exclude the directory from the search.

  10. #930
    Join Date
    Jul 2008
    Beans
    68
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    Jaunty seems to have UFW enabled by default. Try this:
    Code:
    sudo ufw disable
    Then try to connect again.
    Good to know, I didn't realize.

    That didn't have any effect. I'm embarrassed to admit that the formatting of my .smbcredentials was incorrect all along. That's what I get for doing things in a hurry late at night.

    So, the guide works flawlessly in jaunty as-is, just as it did in Hardy for me. Thanks again

Page 93 of 137 FirstFirst ... 43839192939495103 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •