Page 78 of 137 FirstFirst ... 2868767778798088128 ... LastLast
Results 771 to 780 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #771
    Join Date
    Jul 2006
    Location
    NB, Canada
    Beans
    41
    Distro
    Ubuntu Jaunty Jackalope (testing)

    Re: Mount samba shares with utf8 encoding using cifs

    after that and then doing the "sudo mount -a" I get this when opening the docs folder:

    "docs" could not be found. Perhaps it has recently been deleted.

    also, the shares are running on a DLINK DNS-323 NAS and not on a windows machine.

  2. #772
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by reets View Post
    after that and then doing the "sudo mount -a" I get this when opening the docs folder:

    "docs" could not be found. Perhaps it has recently been deleted.

    also, the shares are running on a DLINK DNS-323 NAS and not on a windows machine.
    What is the output of:
    Code:
    smbtree

  3. #773
    Join Date
    Jul 2006
    Location
    NB, Canada
    Beans
    41
    Distro
    Ubuntu Jaunty Jackalope (testing)

    Re: Mount samba shares with utf8 encoding using cifs

    reets@ubuntu:~$ smbtree
    Password:
    Server requested LANMAN password (share-level security) but 'client lanman auth' is disabled
    failed tcon_X with NT_STATUS_OK
    Server requested LANMAN password (share-level security) but 'client lanman auth' is disabled
    failed tcon_X with NT_STATUS_OK
    reets@ubuntu:~$

    i typed in my normal admin password when it asked, not sure if that's what it wanted (it's the same password on my shares also).

  4. #774
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by reets View Post
    reets@ubuntu:~$ smbtree
    Password:
    Server requested LANMAN password (share-level security) but 'client lanman auth' is disabled
    failed tcon_X with NT_STATUS_OK
    Server requested LANMAN password (share-level security) but 'client lanman auth' is disabled
    failed tcon_X with NT_STATUS_OK
    reets@ubuntu:~$

    i typed in my normal admin password when it asked, not sure if that's what it wanted (it's the same password on my shares also).
    Sorry, use this instead:
    Code:
    smbtree user=username[password]
    Replace "username" and "password" with the same ones you used in the CIFS mount command.

  5. #775
    Join Date
    Jul 2006
    Location
    NB, Canada
    Beans
    41
    Distro
    Ubuntu Jaunty Jackalope (testing)

    Re: Mount samba shares with utf8 encoding using cifs

    reets@ubuntu:~$ smbtree user=reets
    Password:
    reets@ubuntu:~$


    reset the pass on the NAS to make sure and how nothing seems to happen (i use the same username and pass on the shares as i do for my ubuntu login)

    this is in my fstab:
    Code:
    //DLINK-80CEDB/Volume_1/docs /media/docs cifs username=reets,password=pass,iocharset=utf8,nobrl,nounix,file_mode=0777,dir_mode=0777 0 0
    this is in my nsswitch.conf:
    Code:
    passwd:         compat
    group:          compat
    shadow:         compat
    
    hosts:          files mdns4_minimal [NOTFOUND=return] wins dns mdns4
    networks:       files
    
    protocols:      db files
    services:       db files
    ethers:         db files
    rpc:            db files
    
    netgroup:       nis
    Last edited by reets; November 21st, 2008 at 02:03 AM.

  6. #776
    Join Date
    Nov 2005
    Beans
    43

    Re: Mount samba shares with utf8 encoding using cifs

    Hello. I'm new to this thread and need some help.

    I followed the instructions in the first post in this thread "to the T" and yet, when I type "sudo mount -a", I get the following error message:

    mount error 6 = No such device or address

    Following are extracts from the various files I changed while attempting to set up my Windows share as a permanent SMB mount:

    Text added to /etc/fstab

    # smb share
    //office/backup /media/backup cifs guest,rw,file_mode=0777,dir_mode=0777 0 0

    Output of smbtree

    john@john-desktop:~$ smbtree
    Password:
    MSHOME
    \\OFFICE OFFICE

    Text from /etc/samba/smb.conf – not the entire file, just the part that seemed relevant.

    [global]

    ## Browsing/Identification ###

    # Change this to the workgroup/NT-domain name your Samba server will part of
    workgroup = MSHOME

    # server string is the equivalent of the NT Description field
    server string = %h server (Samba, Ubuntu)

    # Windows Internet Name Serving Support Section:
    # WINS Support - Tells the NMBD component of Samba to enable its WINS Server
    # wins support = no

    # WINS Server - Tells the NMBD components of Samba to be a WINS Client
    # Note: Samba can be either a WINS Server, or a WINS Client, but NOT both
    ; wins server = w.x.y.z

    # This will prevent nmbd to search for NetBIOS names through DNS.
    dns proxy = no

    # What naming service and in what order should we use to resolve host names
    # to IP addresses
    ; name resolve order = lmhosts host wins bcast

    #### Networking ####

    # The specific set of interfaces / networks to bind to
    # This can be either the interface name or an IP address/netmask;
    # interface names are normally preferred
    ; interfaces = 127.0.0.0/8 eth0

    # Only bind to the named interfaces and/or networks; you must use the
    # 'interfaces' option above to use this.
    # It is recommended that you enable this feature if your Samba machine is
    # not protected by a firewall or is a firewall itself. However, this
    # option cannot handle dynamic or non-broadcast interfaces correctly.
    ; bind interfaces only = yes

    From /etc/nsswitch.conf:
    hosts: files mdns4_minimal [NOTFOUND=return] wins dns mdns4

    Any ideas why I can't mount my Windows share successfully, either manually or "automagically"?

    FWIW, I'm able to mount my network drives through Nautilus by navigating to the drive, right-clicking and selecting "mount volume" (or some such).

    Thanks, mojohn
    Last edited by mojohn; November 23rd, 2008 at 12:01 AM. Reason: To provide additional information

  7. #777
    Join Date
    Jun 2007
    Location
    Puerto Rico
    Beans
    159
    Distro
    Ubuntu 16.04 Xenial Xerus

    Angry Re: Mount samba shares with utf8 encoding using cifs

    Dmizer, this has been a great HOWTO. I have a NAS device (an HDD enclosure) connected to my router (Netgear Rangemax Wireless Router). I followed your howto but got stumped on the netbios part. Although this computer is a dual boot with XP, the NAS doesn't have anything to do with the two OSes I have. I am able to access the NAS from XP and was able to access the NAS from Hardy without any trouble. As soon as I upgraded to Intrepid I lost my connection to the NAS. This is the link to my NAS (http://www.premiertek.net/products/e...-35-LANII.html). If you follow the page you can see that it says that it has a mini server offering FTP/SMB server services. Although it has a web administration page, it is very basic and limited and I'm not able to access the server configuration. I think that the problem lies with the upgrade in Intrepid (something made by Ubunutu) or by the Samba people. I do not have a full Samba server configured, only the smbclient and common files. There is some problem with the repositories that prevents me from doing a full install. I did a firmware upgrade and that didn't work. Would you have a suggestion on how to make it work? I would even try installing FreeNAS on the device if there was a way to do it withoutha big chance of ending up with a brick.
    ¡Levántate!, ¡Revuélvete!, ¡Resiste!
    Haz como el toro acorralado: ¡muge!
    O como el toro que no muge: ¡EMBISTE!
    - José de Diego, En la brecha -

  8. #778
    Join Date
    Jun 2008
    Beans
    4

    Re: Mount samba shares with utf8 encoding using cifs

    Maybe it would be handy for the start post to add this:
    When you've got a share with different restrictions per user, you can add different lines to mount a share, and you the noauto option. Then you create a script for each user when he log's on he can mount the share.
    Therefore the line in your fstab needs the users option. Watch out, your mounting point must have read/write right to mount your share!

    a little example (for user flipo):

    //xxx.xxx.x.xxx/main /mnt/nas cifs users,credentials=/home/flipo/.smbcred,iocharset=utf8,file_mode=0777,dir_mode=07 77,uid=flipo,gid=flipo,auto 0 0

    then in the ls -l output of /mnt/nas must be:
    -rw------- 1 flipo flipo 36 2008-11-22 23:47 .smbpasswd

    to do this you can use this command:
    sudo chown flipo:flipo /mnt/nas
    sudo chmod 600 /home/flipo/.smbcred

    in the .smbcred file there must be
    username=flipo
    password="flipo'spass"

    with user in this file it apparently doesn't work on intrepid?

  9. #779
    Join Date
    Mar 2008
    Location
    Somma Lombardo - Italy
    Beans
    218
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Mount samba shares with utf8 encoding using cifs

    @dmizer:
    Finally I could solve my problem with Imomega StoreCenter Pro.
    I switched to ntp (cifs still has problems with 8.10).
    The problem with ntp is that you have to specify on NAS settings a valid range of IP (or even * for all) that have access to it otherwise it will not mout.
    Thanks.

  10. #780
    Join Date
    Mar 2005
    Location
    Geneva
    Beans
    13
    Distro
    Xubuntu 8.04 Hardy Heron

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    Well, they do not appear to be in utf8, so what language are the file names written in? There may only be one option for your language, but if not, it will essentially come down to trial and error.
    The files in my home directory are written in the same language as the files on the department folder, which I am able to mount without a problem. I'm therefore not sure that encoding is the problem

    Quote Originally Posted by dmizer View Post
    AD means "Active Directory". You may have to contact the network administrator to find out for sure.
    Same as above, the fact that I can mount the department folders but not my own lead me to believe AD does not have anything to do with it.

    In other words, I'm still clueless

Page 78 of 137 FirstFirst ... 2868767778798088128 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •