Page 74 of 137 FirstFirst ... 2464727374757684124 ... LastLast
Results 731 to 740 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #731
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    nexusnode,

    Please try adding the nobrl option like so:
    Code:
    //netbiosname/sharename    /media/sharename        cifs    credentials=/root/.smbcredentials,iocharset=utf8,nobrl,file_mode=0777,dir_mode=0777 0 0

  2. #732
    Join Date
    Nov 2008
    Location
    England
    Beans
    40
    Distro
    Ubuntu

    Re: Mount samba shares with utf8 encoding using cifs

    Thanks for the pointer, but I am sorry to say that it hasn't helped. Is there any info I could gather that would help the diagnosis?

    //10.0.0.11/fred /media/fred cifs credentials=/home/fred/cifscred,iocharset=utf8,nobrl,file_mode=0777,dir_m ode=0777,nounix,noperms,uid=1000,gid=1000, 0 0
    That is the line in my fstab at the moment, does that shed any light?

    Thanks!!
    Last edited by nexusnode; November 7th, 2008 at 09:02 PM.

  3. #733
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    I honestly don't have a lot of hope for this one, nexusnode. Komodo appears to be an old gtk only app, and I don't know if it's in development anymore. There are two things you can try.

    First, try removing the iocharset=utf8 option and see if that helps. I suspect that komodo can't use utf8. But, that's something of a long shot.

    The other thing you can do is try asking this person how he has his cifs mount set up: http://www.nabble.com/Komodo,-Ubuntu...d15820452.html
    http://www.nabble.com/user/UserProfile.jtp?user=688589

  4. #734
    Join Date
    Nov 2008
    Location
    England
    Beans
    40
    Distro
    Ubuntu

    Re: Mount samba shares with utf8 encoding using cifs

    Oh dear!
    Komodo is definetly still in development - they have in the last week or so released a new version! I don't know if its a GTK only app - I'm not sure what I would be looking for to identify it.

    I tried removing that utf8 option but that just made everything fail, and I have emailed the user that you referenced.

    The bit that confuses me is that whilst using 8.04 I had the same setup but no problems..

    Thanks again dmizer!

  5. #735
    Join Date
    Nov 2008
    Location
    England
    Beans
    40
    Distro
    Ubuntu

    Re: Mount samba shares with utf8 encoding using cifs

    Just spoke to a friend of mine about Komodo being an old GTK app. He says he thinks not. Just to make sure were talking about the same thing, this is the link to their site:

    http://www.activestate.com/Products/...odo_edit.mhtml

  6. #736
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Well, I installed from the repos, and apparently the komodo version in the repos is quite old. 0.9x to be exact. From 2005, and it is most certainly a GTK app ... lol.

    It's still probable that it's a GTK app especially since you can use it in Windows and Mac. GTK is more suitable to crossplatform development. Otherwise, you'd have to run komodo through an X server like Cygwin, or write completely different sets of code for all three platforms (unlikely). In any case, since it's still under development, there should not be a problem with CIFS compatibility.

    You might also try talking to the komodo community to see if anyone else is having the problem. I wish I could offer more assistance, but I'm just not very familiar with this application, and since you indicate that everything else seems to work ok (other than komodo) it would be difficult for me to hunt down this particular issue. Ultimately, it may end up being a bug report, but it's too early to tell yet.
    Last edited by dmizer; November 9th, 2008 at 03:52 AM.

  7. #737
    Join Date
    Nov 2008
    Location
    England
    Beans
    40
    Distro
    Ubuntu

    Re: Mount samba shares with utf8 encoding using cifs

    Haha no worries - the komodo thats in the repos is something else entirely and yea - doesn't look like its moved for a while.

    I emailed that guy you suggested and he has come back with some info but has said that he will have to go to work to get the rest of it so I would have thought it will be sometime this coming week I will get a reply.

    The bit that I don't understand, if this is a problem with Komodo, is why it worked fine under 8.04. And the bit thats frustrating me even more is I don't even know where to look for more detailed logs.

    I have a couple of avenues of testing to go down yet but im running into a lot of dead ends.

    Thanks for the help though, I appreciate it.

  8. #738
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by nexusnode View Post
    The bit that I don't understand, if this is a problem with Komodo, is why it worked fine under 8.04. And the bit thats frustrating me even more is I don't even know where to look for more detailed logs.
    Sorry, I did not mean to suggest that the problem was WITH Komodo. I mean to suggest that since the problem is SPECIFIC to Komodo, people who know Komodo better than me will be more likely to be able to help you.

    For example: If you can figure out why this is happening, I might be able to suggest a work around.
    Last edited by dmizer; November 10th, 2008 at 03:00 AM.

  9. #739
    Join Date
    Mar 2008
    Location
    Somma Lombardo - Italy
    Beans
    218
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Mount samba shares with utf8 encoding using cifs

    Hi, I have a problem with a mounted share...
    It was working fine with 8.04, I have problems since I updated to 8.10.

    I tried many settings in my /etc/fstab entry but nothing changes...

    I can create, delete or overwrite files on that mounted share, but I cannot save directly on it (with any program like gedit or openoffice etc).
    So, if I open a file on that share for example with gedit, I cannot save it (I get a message saying "unexpected error: not a directory"). So I have to save it locally (Desktop) and then drag and drop with nautilus and overwrite it.

    Do you have any idea on how to solve this?
    Thanks!

  10. #740
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by lviggiani View Post
    Hi, I have a problem with a mounted share...
    It was working fine with 8.04, I have problems since I updated to 8.10.

    I tried many settings in my /etc/fstab entry but nothing changes...

    I can create, delete or overwrite files on that mounted share, but I cannot save directly on it (with any program like gedit or openoffice etc).
    So, if I open a file on that share for example with gedit, I cannot save it (I get a message saying "unexpected error: not a directory"). So I have to save it locally (Desktop) and then drag and drop with nautilus and overwrite it.

    Do you have any idea on how to solve this?
    Thanks!
    Have you tried the nobrl option? If so, what is your current fstab line?

Page 74 of 137 FirstFirst ... 2464727374757684124 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •