Page 66 of 137 FirstFirst ... 1656646566676876116 ... LastLast
Results 651 to 660 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #651
    Join Date
    Apr 2008
    Beans
    81
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    i'm not for sure what Os is handling the share because this is my network drive at my college. I assume its windows but i'm not for sure. This is my line to mount the share.

    Code:
    //student/gilberjp$    /media/NDrive        cifs    credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    What do you mean have i enabled the root account? I don't follow. Is there a way to figure it out. And no i am the only one who has access to this share and this is the only machine i have any form of linux on.

    Thanks for the troubleshooting help. Its appreciated.

  2. #652
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by suzypeppercorn View Post
    i'm not for sure what Os is handling the share because this is my network drive at my college. I assume its windows but i'm not for sure. This is my line to mount the share.

    Code:
    //student/gilberjp$    /media/NDrive        cifs    credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    Try this line:
    Code:
    //student/gilberjp$    /media/NDrive        cifs    credentials=/root/.smbcredentials,nounix,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    Quote Originally Posted by suzypeppercorn View Post
    What do you mean have i enabled the root account? I don't follow. Is there a way to figure it out.
    Don't worry about it. If you had done so, you would know it. There's no need to enable it, but if you had, it may cause this problem.

    Quote Originally Posted by suzypeppercorn View Post
    And no i am the only one who has access to this share and this is the only machine i have any form of linux on.

    Thanks for the troubleshooting help. Its appreciated.
    It's no problem, hope that gets you working.

  3. #653
    Join Date
    Apr 2008
    Beans
    81
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    i tried the new line in my fstab and i even restarted my system and the problem is still there.

    I'm so confused as to why this isn't working. Any other ideas? Could it be something that i didn't set correctly with my permissions?

  4. #654
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by suzypeppercorn View Post
    i tried the new line in my fstab and i even restarted my system and the problem is still there.

    I'm so confused as to why this isn't working. Any other ideas? Could it be something that i didn't set correctly with my permissions?
    The answer to this problem exists in this thread somewhere. I'm not too sure exactly where though so I'll have to dig a bit, and I'm under some tight deadlines at work.

    I'll do what I can to find the answer as soon as possible though. I know it's probably critical for you to have this access.

  5. #655
    Join Date
    Apr 2008
    Beans
    81
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    i looked through most of the thread and someone had almost the exact same problem and they said their solution was to add a line to the end of their samba.conf file of something close to that.

    The line was inherit owner yes or something similar. I tried that before and it didn't work. I'm not if i completely understood the directions though.

    Its not really that critical for me as i only use my network drive for backups and storage. I use it incase my laptop crashes or something. And plus i have windows on here and i can access my network drive from there fine. If you got work you don't have to rush around for me. Just whenever you get some free time we can try and fix this.

    Thanks for the help man

  6. #656
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Okay, let's take a deeper look at things. Please post the output of:
    Code:
    ls -l /media/NDrive
    and
    Code:
    ls -n /media/NDrive
    and
    Code:
    cat /etc/passwd | grep ubuntu-username
    replace ubuntu-username with your actual ubuntu user name.

  7. #657
    Join Date
    Apr 2008
    Beans
    81
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Code:
    ls -l /media/NDrive
    Code:
     ls -l /media/NDrive
    total 1
    drwxrwxrwx 1 root root  0 2008-08-28 10:37 Backups
    -rwxrwxrwx 1 root root 79 2008-09-11 12:56 desktop.ini
    drwxrwxrwx 1 root root  0 2008-09-11 12:56 My Music
    drwxrwxrwx 1 root root  0 2008-09-11 12:56 My Pictures
    drwxrwxrwx 1 root root  0 2007-09-13 17:03 RECYCLER
    drwxrwxrwx 1 root root  0 2008-09-08 19:57 School Work
    Code:
    $ ls -n /media/NDrive
    total 1
    drwxrwxrwx 1 0 0  0 2008-08-28 10:37 Backups
    -rwxrwxrwx 1 0 0 79 2008-09-11 12:56 desktop.ini
    drwxrwxrwx 1 0 0  0 2008-09-11 12:56 My Music
    drwxrwxrwx 1 0 0  0 2008-09-11 12:56 My Pictures
    drwxrwxrwx 1 0 0  0 2007-09-13 17:03 RECYCLER
    drwxrwxrwx 1 0 0  0 2008-09-08 19:57 School Work
    Code:
    cat /etc/passwd | grep joe
    
    joe:x:1000:1000:Joe,,,:/home/joe:/bin/bash
    hows it looking?

  8. #658
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Okay, lets try changing the ownership on one directory for testing:
    Code:
    sudo chown -R joe:joe /media/NDrive/RECYCLER
    Run this command again:
    Code:
    ls -l /media/NDrive
    If the output shows this:
    Code:
    drwxrwxrwx 1 joe joe  0 2007-09-13 17:03 RECYCLER
    Then try to unmount and remount the drive to see if the permissions are persistent. If they are persistent, try running the same command on the rest of the directories. It's entirely possible that it was simply a glitch on the server side.

  9. #659
    Join Date
    Apr 2008
    Location
    Astoria, NY
    Beans
    25
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Mount samba shares with utf8 encoding using cifs

    I followed the directions to a T, but when I tested, this came up:

    wawny@sgt-pepper:~$ sudo mount -a
    mount error: could not find target server. TCP name netbiosname/WAWNY. not found
    No ip address specified and hostname not found


    I can confirm that the Netbiosname and Share name are correct.

    Any ideas?
    The Polite Society
    A less civilized approach to comedy.

  10. #660
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by iamshawnrice View Post
    I followed the directions to a T, but when I tested, this came up:

    wawny@sgt-pepper:~$ sudo mount -a
    mount error: could not find target server. TCP name netbiosname/WAWNY. not found
    No ip address specified and hostname not found


    I can confirm that the Netbiosname and Share name are correct.

    Any ideas?
    Please post your fstab line, as well as the output of:
    Code:
    smbtree

Page 66 of 137 FirstFirst ... 1656646566676876116 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •