Page 65 of 137 FirstFirst ... 1555636465666775115 ... LastLast
Results 641 to 650 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #641
    Join Date
    Sep 2005
    Location
    Watertown, SD
    Beans
    214
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Mount samba shares with utf8 encoding using cifs

    ******FEISTY USERS******
    If you see an error on shutdown, and or your shutdown sequence halts because of this error message:
    Code:

    [18.312000] CIFS VFS: Server not responding
    [18.312000] No response for cmd 5 mid 8

    please see the fix provided in this link: http://ubuntuforums.org/showthread.php?t=293513
    *thanks to incoming429 for testing the fix on this error.
    This affects Hardy also (me at least) the fix still works.

  2. #642
    Join Date
    Apr 2008
    Beans
    45

    Re: Mount samba shares with utf8 encoding using cifs

    dmizer,

    I'm hoping you can help me. I used to be able to mount a Windows PC network drive / share, but I've messed it up somehow.

    Share and folder: //MEDIA-PC/dwitkin
    IP Address of PC: 192.168.1.100

    When I use smbtree, I get:
    Code:
    dave@dave-laptop:~$ smbtree
    Password:
    failed tcon_X with NT_STATUS_ACCESS_DENIED
    failed tcon_X with NT_STATUS_ACCESS_DENIED
    dave@dave-laptop:~$
    I've tried a few things:
    1. I've shut down the firewall on the windows server, and still the same thing.
    2. I can successfully ping the PC using either the IP address or the pc name.
    3. I tried mounting using the IP address rather than the name of the server. No luck, same thing.
    4. I made sure that winbind, samba, smbfs and smbclient are installed
    5. I tried:
    Code:
    dave@dave-laptop:~$ smbclient -L //192.168.1.100/dwitkin
    Error connecting to 192.168.1.100 (Connection refused)
    Connection to 192.168.1.100 failed (Error NT_STATUS_CONNECTION_REFUSED)

    Can you walk me through some additional troubleshooting steps?

    Your help and expertise is appreciated...

  3. #643
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Hi dwitkin,

    Is there a firewall in place on the Ubuntu machine as well? To double check, please post this command:
    Code:
    sudo iptables -L
    The output should look like this:
    Code:
    $ sudo iptables -L
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination         
    
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination         
    
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination
    Do you also have a samba server configured to share files from Ubuntu to Windows? If so, please post the contents of /etc/samba/smb.conf

  4. #644
    Join Date
    Apr 2008
    Beans
    45

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by dmizer View Post
    Hi dwitkin,

    Is there a firewall in place on the Ubuntu machine as well? To double check, please post this command:
    Code:
    sudo iptables -L
    The output should look like this:
    Code:
    $ sudo iptables -L
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination         
    
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination         
    
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination
    Do you also have a samba server configured to share files from Ubuntu to Windows? If so, please post the contents of /etc/samba/smb.conf
    dmizer,

    Thanks for the quick response and help. I just realized that now I can't print to my network printers (which are attached the the windows PC also), which makes it even more urgent for me to solve this.

    In any case, no, I don't think I have a firewall setup on the ubuntu machine (my laptop). Here is the output from the iptables command you suggested:

    Code:
    dave@dave-laptop:~$ sudo iptables -L
    [sudo] password for dave:
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination
    
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination
    
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination
    dave@dave-laptop:~$
    On your second question, no, I don't currently use samba to share files from Ubuntu (my laptop) to Windows.

    Let me know what you suggest next. In the meantime, I think I'm going to try uninstalling and re-installing Samba and the other related packages... worth a shot.

  5. #645
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    dwitkin,

    On the Ubuntu computer, please post the output of the following command:
    Code:
    uname -n
    Also, post the contents of /etc/hosts

  6. #646
    Join Date
    Apr 2008
    Beans
    45

    Re: Mount samba shares with utf8 encoding using cifs

    dmizer,

    Nevermind... figured it out. Actually, I think you might have guessed the answer because you asked me to post my hosts file. It turns out that the Hosts file was the culprit. Many months ago, I added my home server to the hosts file pretending it had a static IP address because that was the only way I could figure out how to address it from my Ubuntu laptop. I have maybe 5 ip-addressable devices on my network, but my home pc server usually has 192....100. Usually, but not always... I got the connection denied message because another device too the IP address I hard-coded into the Hosts file. Ugh.

    Any idea of where there is a good how-to on getting ubuntu to figure out the right IP address from the host name without hard-coding it into the Hosts file?

    In any case, again, I appreciate your help.

  7. #647
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Glad you got it sorted!

    Just a quick run through on name resolution because that's not really what this howto is about but this should get you started:

    I use winbind and samba for my local name resolution. At least one computer on your network will need to have a properly configured samba server (Windows or Ubuntu. For configuring an Ubuntu samba server, see the first link in my sig), then (on all Ubuntu computers in your network) follow the steps in this howto under "Pre-work" below where it says, "To mount a windows share on a DHCP network, it is convenient to be able to mount by netbios name ..."

    Make a backup of your current hosts configuration for safety's sake, and then remove all the hand configured stuff. Reboot the network, and you should have DHCP name resolution.

    There are other ways as well, like Bind9 for example. You can look for more information at http://help.ubuntu.com

  8. #648
    Join Date
    Dec 2007
    Location
    Netherlands
    Beans
    4
    Distro
    Ubuntu Jaunty Jackalope (testing)

    Talking Re: Mount samba shares with utf8 encoding using cifs

    Great Guide!!!

    I fall in love with Geany but it didn't support network shares :S Now I have found this guide I can use Geany!

    I use a temp mount, but using desktop icons to mount or unmount it. If you want to do it too:

    Replace sudo with gksu and put double quotes around the command. Voila!

    This guide really makes me realise that even if it doesn't work out of the box, you can still make it work using guides like this one!

    With Windows if it doesn't work it doesn't work. No other way out.

    Thanks again!
    Paul

  9. #649
    Join Date
    Apr 2008
    Beans
    81
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    i have just recently ran into a problem. anything i write to my network folder is owned by root.

    has anyone else run into this problem?

  10. #650
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by suzypeppercorn View Post
    i have just recently ran into a problem. anything i write to my network folder is owned by root.

    has anyone else run into this problem?
    I've seen this a number of times. First, I need to know some information about your setup.

    What OS is hosting the share?
    What is the exact line you're using to mount the share?
    Have you enabled the root account?
    Is there more than one linux computer accessing the share?

Page 65 of 137 FirstFirst ... 1555636465666775115 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •