Page 18 of 137 FirstFirst ... 816171819202868118 ... LastLast
Results 171 to 180 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

  1. #171
    Join Date
    Jan 2006
    Beans
    141

    Re: Mount samba shares with utf8 encoding using cifs

    That seemed to clear it up for me!

    Although for clarification, this wasn't coming from a windows share, this was from a samba share running edgy in server mode!

  2. #172
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    Quote Originally Posted by glave View Post
    That seemed to clear it up for me!
    fantastic!

    [...] this was from a samba share running edgy in server mode!
    if both your server and your client are linux, you should use nfs instead of samba. it's much easier to configure, and way faster. the fourth link in my sig will show you how to set up both the server and client. only a few lines of cli as compared to this mess.

  3. #173
    Join Date
    Jan 2006
    Beans
    141

    Re: Mount samba shares with utf8 encoding using cifs

    Unfortunately, I'm sharing out to windows machines as well, else I'd probably opt for nfs as the sole option!

  4. #174
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    nothing to stop you from using both

  5. #175
    Join Date
    Jan 2007
    Beans
    2

    Re: Mount samba shares with utf8 encoding using cifs

    About mounting the ARGOSY HD363N (NAS) with cifs

    Quote Originally Posted by dmizer View Post
    ....
    if you could also try mounting with the "verbose" option like i requested from borka in post 162, i might be able to figure out more
    ....
    I tried the verbose option but it doesn't give me any clue.

    Code:
    michael@hppavilion-linux:~$ sudo mount -t cifs --verbose //192.168.0.10/Apps /home/michael/mnt/Apps -o username=michael
    parsing options: rw,username=michael
    Password: 
    
    mount.cifs kernel mount options unc=//192.168.0.10\Apps,ip=192.168.0.10,pass=1234,ver=1,rw,username=michael 
    mount error 20 = Not a directory
    Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)
    michael@hppavilion-linux:~$

  6. #176
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    humm ... MichaelJohansson and borka, i've been doing some digging and most of the information i'm finding on the error code 20 is quite old. so i did some digging on your particular unit, and it would seem that it's a buggy little sucker. it says cifs support, but apparently cifs support is something of an overstatement.

    you can try going here:
    http://www.argosyusa.net/product.asp...ct_name=HD363N
    and make sure you have the latest firmware loaded (requires windows).

    there's a healthy discussion you might try sifting through. located here:
    http://www.futurehardware.in/66931.htm
    it would appear that both windows and linux users are having problems with the unit.

    otherwise you may just be stuck with smbfs. there are reasons why cheap hardware is cheap ...

    HD363N NAS - 2 <> dmizer - 0

    sorry folks ...
    Last edited by dmizer; January 10th, 2007 at 09:19 AM.

  7. #177
    Join Date
    May 2006
    Beans
    4

    Re: Mount samba shares with utf8 encoding using cifs

    Sorry for being away for some days, got my hands on some other problem..
    But as Michaels smbfs options worked to get swedish characthers working, I think I can live with using that for now

    Anyhow, I wish I had done some research about this particular NAS before I bought it, but that one was the only one that they sold at the time in the small town I live in
    Otherwise I would have gone with some other hardware for it

    Well well, thanks for you help guys, atleast I wont go anyfurther trying to get CIFS working with the Agrosys NAS..

    Cya around
    //Borka

  8. #178
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    sorry again, and thanks for trying.

    updated the howto to include a small disclaimer about NAS devices and the ARGOSY HD363N in particular.

  9. #179
    Join Date
    Jan 2006
    Location
    Reno, NV
    Beans
    22
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Mount samba shares with utf8 encoding using cifs

    so i get all the way to
    Code:
    sudo mount -a
    , and it wont let me have a "$" at the end of a share, such as the hidden default shares on windows drives, and the "\ "trick for spaces doesn't work either. BUT, I've gotten around all that by creating new shares but now I get this:
    Code:
    mount: mount point 0 does not exist
    when I enter
    Code:
    sudo mount -a
    any ideas?

  10. #180
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Mount samba shares with utf8 encoding using cifs

    you can mount "hidden" (in quotes because they are only hidden from ms machines) directories by putting quotes around the directory like so:
    Code:
    //netbiosname/"sharename$"
    if that doesn't work, post the output of:
    Code:
    smbtree
    and your fstab line.

Page 18 of 137 FirstFirst ... 816171819202868118 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •