Peope, it's a long thread and I read until page 22 and tried all your tips but I am soo tired and I think I know the answer will be a disappointment, but I just gotta try this.

My network is:
main machine running Ubuntu
kids/gaming machine running XP

just bought a NAS, a western digital My Book World Edition (

No problems interfacing with the NAS from the XP machine but on the linux machine I initially just went with Ubuntu and connected to it and the wheels fell off soon after. Obviously Ubuntu defaults to samba. It's slow and unreliable or so I found.

Googled around and found this thread so obviously tried my luck setting up a cifs link to the NAS. There is only one source I found who claims that this NAS does smb and cfis.

I can set up a link between the Ubuntu machine to one of the shares on the XP box. No problems there. It's all set up nicely, right?

Then I try my luck with the NAS.
I set up a link to one of the NAS shares. It (partially) succeeds and I can browse the folders. But I can not for the life of me set up a link to the share where I get rw access.

And I *know* I have configured the NAS correctly.

At this moment I am just trying to manual mounting, so here's my smbtree:

        \\TERRA                         terra
                \\TERRA\IPC$            IPC Service (terra)
                \\STIMPY\Brother                Brother HL-820
                \\STIMPY\Iwar's Documents
                \\STIMPY\Mum and Dad    
                \\STIMPY\print$                 Printer Drivers
                \\STIMPY\IPC$                   Remote IPC
        \\REN                           Samba 3.0.26a
                \\REN\IPC$              IPC Service (Samba 3.0.26a)
TERRA is the NAS, REN runs Ubuntu and STIMPY is the XP box

On REN I created two 'folders' in /media called 'public' and 'dvdrw'
I have also created a credentials file in root as per dmizer's instructions, who I hastily add should be at the very least be nominated for some Nobel prize or another for outstanding work in the field of CFIS mounting.

These credentials should yield rw access on ALL shares on TERRA.

Anyhoo, when I run:

sudo mount -t cifs -o rw,credentials=/root/.smbcredentials,file_mode=0777,dir_mode=0777 //terra/public /media/public

sudo mount -t cifs //terra/public /media/public -o credentials=/root/.smbcredentials,username=####,password=####,file_mode=0777,dir_mode=0777
I get the desktop 'public' icon alright, but I can only browse its contents.

Soooo... seeing as I can connect to XP using CIFS, and I can partically connect to the NAS using cifs too, can I assume that I should be able to get the whole hog working on cifs? Or should I abandon and lump samba?

Any help greatly appreciated