Results 1 to 10 of 1362

Thread: Mount samba shares with utf8 encoding using cifs

Threaded View

  1. #11
    Join Date
    Jan 2010

    Re: Mount samba shares with utf8 encoding using cifs

    Alright, I've stumbled upon this thread thanks to an old archive in ubuntu, but I figured I'd hop in here.

    I'm on 11.04 Narwhal server, and I'm using win server 2k3.

    I'm having a problem someone had a long time ago, which is that I'm mounting successfully but I can't edit the files. I can copy them but I cannot write to them. I'm using something that looks like this in my fstab:

    //compression1.mydomain.local/share /media/share cifs iocharset=utf8,credentials=/root/.smbcredentials,noperm,file_mode=0777,dir_mode=077 7,uid=0,gid=0 0 0

    As you can see, I've tried specifying root's uid and gid (I'm doing this all as root for the moment), and I'm specifying noperm. The file and dir mode are both 0777, and doing an ls shows that it's owned by root/root, and it's allowing rwx to everyone.

    That being said, I still get "permission denied" if I try to make a new directory in there, or edit a file, or delete something. I've checked the windows machine, the user I'm logging in as has FULL permissions to the share, and the files are NOT set to read-only.

    Anything else I'm not trying?


    Never mind, I'm a complete idiot. I had changed the local file permissions but not the share permissions, our support guy figured it out. Problem Exists in Windows. (pew pew!)

    Sorry for adding more glut to this pile, but now everyone knows: check the *share* permissions on windows, too!
    Last edited by NateDSaint; July 13th, 2011 at 05:22 PM.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts