Page 6 of 6 FirstFirst ... 456
Results 51 to 54 of 54

Thread: HOWTO: Maple

  1. #51
    Join Date
    Apr 2008
    St Andrews, Scotland
    Ubuntu 8.04 Hardy Heron

    Re: HOWTO: Maple

    Hi - thanks for the instructions - the install worked fine after a wee bit of fiddling The only problem is that when I run xmaple (I use /root/maple9.5/bin/xmaple) it just won't start - the command line version works just fine but I need to use the gui for plotting and such... I tried capturing the output of the program using nohup but it exits without saying anything so I have absolutely no idea what the problem is.

    (I am now using ArchLinux and KDE4.1 but this is the only guide I could find anywhere that applied to the problem)

  2. #52
    Join Date
    Jan 2009

    Re: HOWTO: Maple

    Hey all. I'm really new to ubuntu and I'm trying to load maple 10 on Intrepid Ibex. I followed the HOWTO and I still got the same error message. Any help would be much appreciated.

  3. #53
    Join Date
    Sep 2008

    Re: HOWTO: Maple

    Quote Originally Posted by gertvdijk View Post
    Great How-to. Still one problem: Maple just won't start. When I execute xmaple in the terminal nothing shows, no window, no error.
    I use Ubuntu Gutsy (7.10) 64-bit and Maple 10 .bin installer provided by my university. The activation failed in the installation process (too many registrations on purchase code). Could that be the problem? I just skipped the activation step and Maple assured me I can activate at a later time.
    Edit: Now I have downloaded a license.dat file the maple commandline tool comes with the following:

    So I found out that I miss the X86_64 dir! Well... I just symlinked that non-existing dir to the bin.IBM_INTEL_LINUX dir (Is that a good idea?). Now Maple is complaining about the license file.

    Edit2: I also needed to symlink the jre dir. Besides, somehow the license file I downloaded was empty.
    Solved that and now Maple is up and running @ Gutsy 64-bit!

    For in the how-to
    If you're running 64-bit version you need to symlink the non-existing dirs bin.X86_64_LINUX and jre_X86_64_LINUX to their 32-bit equivalents:
    # First go to the install location e.g. /usr/local/maple10/
    $ ln -s bin.IBM_INTEL_LINUX/ bin.X86_64_LINUX
    $ ln -s jre.IBM_INTEL_LINUX/ jre.X86_64_LINUX
    If you must use a network license and you don't get this option when installing Maple (Maple 11 & up seems to provide this):
    download the license.dat file you must acquire from your institution or company and place it in the license/ dir.
    Simply making a symbolic link didn't do it for me. I copied jre.IBM_INTEL_LINUX to a new directory jre.X86_64_LINUX. This works.


  4. #54
    Join Date
    Jul 2011

    How to install maple 9.5 on Ubuntu 11.04

    I just successfully install maple 9.5 for single user on Ubuntu 11.04 after many trials.
    The guide provided by
    is lack of some detail for this version of ubuntu.

    Before you do this:
    1. use the Ubuntu software center to install the <libghc6, font python font manager>

    2. Info: Maple will be install in directory: opt/maple9.5
    Copy the files from cdrom to home/user
    (note: if you cannot mount the cdrom: you will need isobuster under Windows to extract the needed files from the right track).
    3. use the commands as recommended by ubuntu community:
    (i) use terminal (control + alt +T) to enter the following command lines after lines -- each ending with <enter>
    (ii) sudo mkdir -p /opt/maple9.5 (you shall install in this directory)
    (iii) sudo ./installMapleLinuxSU

    Maple installer will appear:
    >> enter serial number
    >> directory -- you must locate opt/maple9.5 (do not use root directory)
    >> message will indicate success and you now can close the installer.

    (iv) Terminal screen may report some problems -- just ignore but record the message on paper for future use
    (v) use the exact command given by ubuntu comm guide.
    on the terminal, add these two lines:
    sudo mkdir -p /usr/local/bin <enter>
    sudo ln -s /opt/maple9.5/bin/{x, } maple/user/local/bin

    (vi) You are DONE with installing
    You will need to run maple.
    How? click <system file> <opt> <maple9.5><bin>
    select <xmaple> <copy to > <desktop>
    (vii) from desktop click <xmaple> select <run>
    (viii) you can see maple appears ... good luck.


Page 6 of 6 FirstFirst ... 456


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts