Page 40 of 91 FirstFirst ... 3038394041425090 ... LastLast
Results 391 to 400 of 910

Thread: How I got Guild Wars working in Wine 0.9.23

  1. #391
    Join Date
    Oct 2006
    Location
    Illinois
    Beans
    462
    Distro
    Hardy Heron (Ubuntu Development)

    Re: How I got Guild Wars working in Wine 0.9.23

    Try these Registry settings. Bumped my framerates up by around 10.
    (Save this as a .reg file and import it in regedit)
    Code:
    REGEDIT4
    
    
    
    [HKEY_CURRENT_USER\Software\Wine\Direct3D]
    
    "DirectDrawRenderer"="opengl"
    
    "OffscreenRenderingMode"="backbuffer"
    
    "opengl"="enabled"
    
    "RenderTargetLockMode"="auto"
    
    "UseGLSL"="enabled"
    
    "VideoMemorySize"="256"
    Ubuntu > Windows
    Man is free at the instant he wants to be. -- Voltaire

  2. #392
    Join Date
    Dec 2005
    Beans
    733
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: How I got Guild Wars working in Wine 0.9.23

    i only get 10 fps or less when i am in the login and character screens in guildwars.
    When i am actually playing it runs at 20-26 fps, on windows it usually ran at 56-60 fps.
    Last edited by cor2y; April 1st, 2007 at 06:49 PM.

  3. #393
    Join Date
    Jan 2007
    Beans
    26

    Re: How I got Guild Wars working in Wine 0.9.23

    Mh 0.9.34 works fine now, but I still need the lights-patch?! Am I the only one who still needs it?

    To test this it seems that the Jin Jea Monastry is the best place to do it (Factions/Cantha Tutorial) just walk around the city, while looking around. If your GW locks up you will need the patch

  4. #394
    Join Date
    Feb 2007
    Beans
    40
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: How I got Guild Wars working in Wine 0.9.23

    Quote Originally Posted by Azakus View Post
    Try these Registry settings. Bumped my framerates up by around 10.
    (Save this as a .reg file and import it in regedit)
    Code:
    REGEDIT4
    
    
    
    [HKEY_CURRENT_USER\Software\Wine\Direct3D]
    
    "DirectDrawRenderer"="opengl"
    
    "OffscreenRenderingMode"="backbuffer"
    
    "opengl"="enabled"
    
    "RenderTargetLockMode"="auto"
    
    "UseGLSL"="enabled"
    
    "VideoMemorySize"="256"
    What is this even supposed to do. I personally noticed absolutely nothing. A little explanation as to what a registry file will do would help .

  5. #395
    Join Date
    Oct 2006
    Location
    Illinois
    Beans
    462
    Distro
    Hardy Heron (Ubuntu Development)

    Re: How I got Guild Wars working in Wine 0.9.23

    Quote Originally Posted by Factory View Post
    What is this even supposed to do. I personally noticed absolutely nothing. A little explanation as to what a registry file will do would help .
    Those registry entries make WINE use OpenGL to render files instead of the buggier GDI32, at the expense of some compatibility (or so I've heard). Earlier posts here have more detail. I'll dreg those up.
    http://ubuntuforums.org/showpost.php...&postcount=231
    http://wiki.winehq.org/UsefulRegistryKeys
    Ubuntu > Windows
    Man is free at the instant he wants to be. -- Voltaire

  6. #396
    Join Date
    Jan 2007
    Beans
    388

    Re: How I got Guild Wars working in Wine 0.9.23

    I got it running with the script, and I got roughtly the same performance, but I had a lot of trouble with rendering. With things on auto detect (medium setting) I'd get flashes of unrendered ground, jumpy blocks, etc. Turned down to low this reduced to near zero, still very playable. But after a while of playing (no specific time) things that were working would stop rendering. The ground, just about every enemy, some armors, etc. Mostly outside of town. It made the game no fun to play - you can only kill so many enemies that are just white manikans before you get bored. Did anyone else experience this? Does the new version of Wine make it any better?

  7. #397
    Join Date
    Feb 2007
    Beans
    40
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: How I got Guild Wars working in Wine 0.9.23

    Quote Originally Posted by rillip View Post
    I got it running with the script, and I got roughtly the same performance, but I had a lot of trouble with rendering. With things on auto detect (medium setting) I'd get flashes of unrendered ground, jumpy blocks, etc. Turned down to low this reduced to near zero, still very playable. But after a while of playing (no specific time) things that were working would stop rendering. The ground, just about every enemy, some armors, etc. Mostly outside of town. It made the game no fun to play - you can only kill so many enemies that are just white manikans before you get bored. Did anyone else experience this? Does the new version of Wine make it any better?
    Simply 'yes'. With every new release of Wine Guild Wars seems to run better.

    Hopefully we'll be at 100% conversion... I'm half-expecting version 1.0 to do this.

  8. #398
    Join Date
    Mar 2007
    Beans
    36
    Distro
    Ubuntu

    Re: How I got Guild Wars working in Wine 0.9.23

    I have the latest version of wine, and installed Guild Wars. When the game starts up, it goes very, very slow, getting to the point where I can't even exit out normally. My system is somewhat old, but with the settings low, it could run guild wars without a huge problem.

    Is there anything I could do to fix this?

  9. #399
    Join Date
    Jan 2007
    Beans
    23

    Re: How I got Guild Wars working in Wine 0.9.23

    I seem to be experiencing the same slowdown issue. I can play for maybe 10 minutes before the game grinds to a halt.

  10. #400
    Join Date
    Jan 2007
    Beans
    26

    Re: How I got Guild Wars working in Wine 0.9.23

    Today I was testig around with various windows-versions (in the winecfg-menu) and was very surprised, that there was a difference between the fps I got. Here a list of the fps on one scene (Guildhall):

    Win2.0 : 57
    Win3.0 : 57-58
    Win3.1 : 58-59
    WinNT3.5 : 57-58
    WinNT4.0 : 56-57
    Win95 : 57
    Win98 : 57
    WinME : 57
    Win2000 : 57
    WinXP : 58
    Win2003 : 57

    I am using Win3.1 now. And I can recommend the tool "rovclock" which allows over- / underclocking of ati-cards, very usefull for me.
    I recently tried the open source radeon drivers (r300 for me) and got it working (with not that good performance and graphic errors, but it is working) If you just start GW without changing anything to your system it will use software rendering. You will have to install the tool driconf, start it and switch off the "fallback anything" button and disable the first button on the next page. Then GW will run with hardware rendering
    Last edited by Flyser; April 5th, 2007 at 04:03 PM.

Page 40 of 91 FirstFirst ... 3038394041425090 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •