Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 36

Thread: HOWTO: Japanese input in qt and gtk!

  1. #21
    Join Date
    Sep 2005
    Ubuntu Breezy 5.10

    Re: HOWTO: Japanese input in qt and gtk!

  2. #22
    Join Date
    May 2005

    Re: HOWTO: Japanese input in qt and gtk!

    To run SCIM without Gnome or GDM,
    or with any single KDE-based application:

    (setup note: I use FVWM2 and also have removed GDM, which means the scripts /etc/X11/Xsession.d/75custom-scim_startup and ~/.gnome2/session-manual have no effect even if I start Gnome. The only KDE-based application I use is Opera, the static version. These instructions are current for Edgy.)

    To get SCIM and Anthy for Japanese, I installed the following packages:
    scim, scim-anthy, scim-gtk2-immodule, scim-modules-socket, scim-modules-table, scim-qtimm, scim-tables-ja, scim-uim
    uim-anthy, uim-common, uim-fep, uim-gtk2.0, uim-qt, uim-utils, uim-xim

    If you run GDM, you also will need m17n-env and scim-m17n

    Then I ran scim-setup once from the command line to configure it. Recent versions don't seem to require this -- activate SCIM by pressing control+space, and right-click on the SCIM icon, then look around at the options. They used to be confusing but now are straightforward, and the defaults probably will be acceptable.

    To make SCIM available for everything, I have a script that starts X, SCIM and FVWM. This should work for any window manager, adjusting the last line. (For Gnome it would be xinit /usr/bin/gnome-session)
    LINGUAS=en_US.UTF-8; export LINGUAS
    SUPPORTED=en_US:C:en_US:ISO-8859-15:ja_JP.eucJP:ja_JP.UTF-8:ja_JP:ja:ja_JP.JIS7:ja_JP.SJIS; export SUPPORTED
    LANG=en_US.UTF-8; export LANG
    LC_CTYPE=en_US.UTF-8; export LC_CTYPE
    XMODIFIERS="@im=local"; export XMODIFIERS
    GTK_IM_MODULE="scim"; export GTK_IM_MODULE
    QT_IM_MODULE="scim"; export QT_IM_MODULE
    XIM_PROGRAM="scim -d"; export XIM_PROGRAM
    scim -d
    # start whatever window manager you use
    xinit /usr/bin/fvwm -f /home/james/.fvwm/.fvwm2rc

    I've left in the QT line for laughs -- it doesn't make any difference.

    To get Opera (or any other single KDE program) to accept input through SCIM, this works from the command line:
    scim -d & QT_IM_MODULE="xim" opera &

    This does create a second instance of SCIM. But the second one is quite small, and the two don't interfere with each other. If I exit Opera the second instance remains, but if I start Opera again it is reused, so I never have more than those two instances.

    You can also make it the startup command for that program in your window manager. In FVWM, the line is
    + "Opera" Exec exec scim -d & QT_IM_MODULE="xim" opera
    In Gnome, I suppose it would be
    scim -d & QT_IM_MODULE="xim" opera
    Last edited by James Keating; February 4th, 2007 at 02:13 PM. Reason: clarity, update

  3. #23
    Join Date
    Apr 2006
    Tokyo, Japan

    Re: HOWTO: Japanese input in qt and gtk!

    Unfortunately SCIM fails with a lot of commercial softwares like Realplayer, Opera, Adobe Acrobat Reader. For personal use, uim and anthy are much more reliable than scim (or skim in KDE).

  4. #24
    Join Date
    May 2006

    Re: HOWTO: Japanese input in qt and gtk!


    Just a quick not to let you know that for kubuntu I had to install the following package: scim-qtimm
    Otherwise only my gnome apps worked with scim.


  5. #25
    Join Date
    Apr 2006

    Re: HOWTO: Japanese input in qt and gtk!

    Quote Originally Posted by mrbass

    Add scim to GNOME (ubuntu)
    sudo touch ~/.gnome2/session-manual
    echo "[Default]" >> ~/.gnome2/session-manual
    echo "num_clients=1" >> ~/.gnome2/session-manual
    echo "0,RestartStyleHint=3" >> ~/.gnome2/session-manual
    echo "0,Priority=50" >> ~/.gnome2/session-manual
    echo "0,RestartCommand=scim -d" >> ~/.gnome2/session-manual
    echo "0,Program=scim" >> ~/.gnome2/session-manual
    I assume that if I do this, I will have scim working in Ubuntu. I just upgraded to Dapper, is the process the same?


  6. #26
    Join Date
    Sep 2006

    Thumbs down Re: HOWTO: Japanese input in qt and gtk!

    This worked great!

    For those who got errors trying to set it up, make sure to use sudo.

  7. #27
    Join Date
    Mar 2007

    Re: HOWTO: Japanese input in qt and gtk!

    Hello all,

    I just had a fresh install of ubuntu. I installed Japanese language support as instructed but I have a problem.

    Here is my problem:
    I press "w" and hiragana "wa" shows up on the screen (without waiting for me to enter a), then i press "k" it shows "ka" in hiragana. so if i press "sksk" i end up with "sakasaka" on the screen. It has auto completion which i dont want.

    Another problem is that if I press enter after typing "watashiha" ,which is shown in hiragana on screen, it converts that string back to romaji. So i am unable to enter hiragana because they all end up in romaji.

    Also, if i press space the kanji choosing screen does not show up. So I am unable to select kanji characters.

    All of these futures were working on my old ubuntu. I dont know what is wrong with the new one. Any help is appreciated.
    Thanks a lot.
    Last edited by kebellekek; March 26th, 2007 at 08:51 AM.

  8. #28
    Join Date
    May 2005

    Re: HOWTO: Japanese input in qt and gtk!

    Looks like you're in hiragana mode. You should be able to get Anthy by cycling through input modes with Control+Alt+Down or Up (I believe that's the default).

    To adjust settings, right-click on the SCIM icon at the far left of the SCIM toolbar that pops up. Click on SCIM setup. Front End, Global Setup lets you change the key combinations that turn SCIM on and off, and cycle through the input modes. IMEngine, Global Setup lets you pick which input modes can be available. For simplicity, I have English/European, plus Anthy and Hiragana -- you have to make Hiragana mode available to input with Anthy the usual way by typing Romaji that change to hiragana that you convert to kanji. Under IMEngine, Anthy, I have Input mode: Hiragana, Typing method: Romaji and Conversion mode: Multi segment.

  9. #29
    Join Date
    Apr 2005
    Ubuntu Development Release

    Re: HOWTO: Japanese input in qt and gtk!


    Use this guide for installing Japanese, Korean or Chinese write support.

    The one instructed in this thread is too old. It was meant for Hoary.

    So here it is:

    SCIM for Ubuntu (GNOME)

    SCIM for Kubuntu (KDE)

  10. #30
    Join Date
    Mar 2007

    Re: HOWTO: Japanese input in qt and gtk!

    Thank you so much both of you.

    Now it works like a charm.

Page 3 of 4 FirstFirst 1234 LastLast


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts