Results 1 to 2 of 2

Thread: HOW TO: Fix: Ubuntu freezes up after login ... no desktop

  1. #1
    Join Date
    Aug 2006
    Ann Arbor Michigan
    Ubuntu 14.04 Trusty Tahr

    Tip to fix: Ubuntu freezes up after login ... no desktop

    I had a problem some time ago where I would put in my login name and password, and then the system would hang forever with no desktop, no splash screen, nothing. Rebooting did not fix this. X was dead. The only work-around that would help was to create a whole new user and start over, killing the old user.
    This is for Edgy, 32bit. Tested, reproduced and it works.
    It may not work for all hang issues, but I have helped more than one system recover using this fix, and have not yet had to do anything else. This also should work on other releases and architecture types.
    I do not plan on supporting this thread, it is simple beyond belief.

    Simply press ctrl+alt+F1. (switch to the first console)

    Enter in your login name and password. (log in)

    enter in: "rm /tmp -r" (clear out your /tmp directory)
    **you may want to do that as root, or use sudo if there are files that won't go away**
    edit: if you try this as root **make certain you do not actually remove the tmp directory itself!!!**

    reboot for good measure. (reboot for good measure)

    That's right. Simply clear out your temp files. Did you press ctrl+alt+backspace and then tried to log in, or cut power to the system and forgot to mention that? When X is shut off in this way, the OS and other programs do not get to clean up after themselves, so whatever caused your hang to begin with, was still in there, causing your system to hang when you tried to log in again.

    I hope this helps someone!!! I smashed my head into a brick wall for a few weeks before stumbling onto this very simple fix. GOOD LUCK

    Last edited by alienseer23; April 20th, 2007 at 06:21 AM.

  2. #2
    Join Date
    Apr 2008

    Re: HOW TO: Fix: Ubuntu freezes up after login ... no desktop

    And if i accidently remove the tmp directory?

    I guess i was supposed to be 'in' the directory, before i ran the 'rm /tmp -r' command? Because just running it deletes the tmp directory... so either i'm missing something or you've failed to specify exactly how one does not remove the directory you're telling the terminal to purge.

    Hope you can reply in the next 5 minutes because my essay is due... and it's lost in some weird 'hang' limbo restart failure.

    Update: This even older thread got me out of that pickle and back into the no desktop problem / session lasting less than 10 seconds problem. So my chmod is either wrong or i should delete the tmp folder again and follow the aforementioned thread, found here:
    Last edited by an0nu4nc3; May 11th, 2009 at 03:24 PM. Reason: Update


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts