Page 8 of 17 FirstFirst ... 678910 ... LastLast
Results 71 to 80 of 162

Thread: Howto Get Eyetoy Webcam working for Ubuntu

  1. #71
    Join Date
    Jan 2006
    Location
    Philadelphia
    Beans
    4,076
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Howto Get Eyetoy Webcam working for Ubuntu

    found the answer to the problem. first question in the linux driver faq clued me in:
    http://www.rastageeks.org/ov51x-jpeg/index.php/FAQ

    plugged the cam directly into the usb port rather than into the usb hub, and it started working.

  2. #72
    Join Date
    Nov 2008
    Beans
    32

    Re: Howto Get Eyetoy Webcam working for Ubuntu

    Using ver ov51x-jpeg-1.5.9 when I get to

    sudo insmod /lib/modules/`uname -r`/extra/ov51x.ko

    I get the no such (file or directory) error

    and if I try

    sudo modprobe ov51x-jpeg

    then I get the (unknown symbol in module error)

    Any ideas on what to do now!?

  3. #73
    Join Date
    Jan 2006
    Location
    Philadelphia
    Beans
    4,076
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Howto Get Eyetoy Webcam working for Ubuntu

    Quote Originally Posted by wlbragg View Post
    Using ver ov51x-jpeg-1.5.9 when I get to

    sudo insmod /lib/modules/`uname -r`/extra/ov51x.ko

    I get the no such (file or directory) error

    and if I try

    sudo modprobe ov51x-jpeg

    then I get the (unknown symbol in module error)

    Any ideas on what to do now!?
    well, where did you put ov51x.ko?

  4. #74
    Join Date
    Nov 2008
    Beans
    32

    Re: Howto Get Eyetoy Webcam working for Ubuntu

    Where the directions told me to although the directions said
    Code:
    sudo insmod /lib/modules/`uname -r`/extra/ov51x.ko
    driver name has changed to
    Code:
    sudo insmod /lib/modules/`uname -r`/extra/ov51x-jpeg.ko
    so I tried
    Code:
    sudo insmod /lib/modules/`uname -r`/extra/ov51x-jpeg.ko
    that gave me the
    Code:
    (unknown symbol in module error)
    I don't get the "file or directory not found anymore" that was a mistake on my part.
    dmesg
    Code:
    [  835.946661] ov51x_jpeg: disagrees about version of symbol video_devdata
    [  835.946677] ov51x_jpeg: Unknown symbol video_devdata
    [  835.947166] ov51x_jpeg: disagrees about version of symbol video_unregister_device
    [  835.947168] ov51x_jpeg: Unknown symbol video_unregister_device
    [  835.947353] ov51x_jpeg: disagrees about version of symbol video_device_alloc
    [  835.947355] ov51x_jpeg: Unknown symbol video_device_alloc
    [  835.947450] ov51x_jpeg: disagrees about version of symbol video_register_device
    [  835.947453] ov51x_jpeg: Unknown symbol video_register_device
    [  835.947759] ov51x_jpeg: disagrees about version of symbol video_usercopy
    [  835.947761] ov51x_jpeg: Unknown symbol video_usercopy
    [  835.947844] ov51x_jpeg: disagrees about version of symbol video_device_release
    [  835.947847] ov51x_jpeg: Unknown symbol video_device_release
    Last edited by wlbragg; February 26th, 2009 at 06:10 PM. Reason: Correction

  5. #75
    Join Date
    Nov 2008
    Beans
    32

    Re: Howto Get Eyetoy Webcam working for Ubuntu

    Also I never saw a reply to what to do if your Eyetoy only shows up in device manager under audio as mine does?
    And also what does the video device show up as when done right in /dev/?
    Last edited by wlbragg; February 26th, 2009 at 07:26 PM.

  6. #76
    Join Date
    Jan 2006
    Location
    Philadelphia
    Beans
    4,076
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Howto Get Eyetoy Webcam working for Ubuntu

    Hi
    not sure about what's going on with your "unknown symbol" error...

    but about the audio-only: that happened to me when i plugged the webcam into a usb hub - once i plugged it directly into a built in usb port, it worked just fine.

    also i'll note that it works even without the special ov51x-jpeg driver - plugged it into the usb port directly, and it worked with stock drivers that come with the ubuntu 8.10 install... so try it.

  7. #77
    Join Date
    Mar 2006
    Location
    Akron Ohio, USA
    Beans
    17
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Howto Get Eyetoy Webcam working for Ubuntu

    Heh. My EyeToy isn't even showing up in the device manager. =/

  8. #78
    Join Date
    Nov 2008
    Beans
    32

    Re: Howto Get Eyetoy Webcam working for Ubuntu

    Wish I could help you out but I haven't gotten any farther on mine either. I did find out that it will show one frame every now and then in VLC if I keep hitting connect to capture device over and over using /dev/video0 which is where my device is registering. Sometimes I get just a garbled green screen and sometimes nothing at all. Even though both entries in Device Manager show up as audio and streaming audio. The streaming audio is the video portion. The audio portion is working by default.
    Did you try and make sure you plugged it into a direct usb port and not a hub port? I tried all my ports as I have no clue which if any are hub or direct?

  9. #79
    Join Date
    Jan 2006
    Location
    Philadelphia
    Beans
    4,076
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Howto Get Eyetoy Webcam working for Ubuntu

    Quote Originally Posted by wlbragg View Post
    Wish I could help you out but I haven't gotten any farther on mine either. I did find out that it will show one frame every now and then in VLC if I keep hitting connect to capture device over and over using /dev/video0 which is where my device is registering. Sometimes I get just a garbled green screen and sometimes nothing at all. Even though both entries in Device Manager show up as audio and streaming audio. The streaming audio is the video portion. The audio portion is working by default.
    Did you try and make sure you plugged it into a direct usb port and not a hub port? I tried all my ports as I have no clue which if any are hub or direct?
    is it working with cheese? (that's what mine works with well)

  10. #80
    Join Date
    Jun 2008
    Location
    Right behind you stalking
    Beans
    126
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Howto Get Eyetoy Webcam working for Ubuntu

    http://www.rastageeks.org/downloads/...g-1.0.0.tar.gz

    404 error?

    I was looking forward to this as well.

    Edit - I just went straight to the website, I guess it blocks hotlinks.

    Okay new problem.

    sawan@SawanPC:~/ov51x-jpeg-1.5.8$ xawtv
    [: 12: (opcode:: unexpected operator
    This is xawtv-3.95.dfsg.1, running on Linux/i686 (2.6.22-16-generic)
    xinerama 0: 1280x1024+0+0
    X Error of failed request: XF86DGANoDirectVideoMode
    Major opcode of failed request: 137 (XFree86-DGA)
    Minor opcode of failed request: 1 (XF86DGAGetVideoLL)
    Serial number of failed request: 69
    Current serial number in output stream: 69

    Any ideas? Thanks!
    Last edited by tehforum; March 8th, 2009 at 09:12 PM.

Page 8 of 17 FirstFirst ... 678910 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •