Page 26 of 66 FirstFirst ... 16242526272836 ... LastLast
Results 251 to 260 of 654

Thread: HOWTO: ipw2200 + wpa

  1. #251
    Join Date
    Apr 2005
    Beans
    514

    Re: HOWTO: ipw2200 + wpa

    Are you sure?
    In a previous post you said that the eth1 interface was activated but doesn't get any IP address. So, if eth1 is shown by ifconfig, it'll be shown by the network panel too, which is just a GUI of ifconfig.

  2. #252
    Join Date
    Apr 2005
    Beans
    514

    Re: HOWTO: ipw2200 + wpa

    Quote Originally Posted by scottylans
    I'm not sure either!

    I wish Luca would put this stuff in the howto.
    I REALLY DO appreciate it - don't get me wrong, but this is the second time I've had to mention things that we're simply not included in the how-to.

    For example - the bit about installing gcc, linux-headers - that wasn't in the original FAQ - it was assumed

    It's GREAT of him to do this for us - it is but when someone points out a flaw with the documentation it should be updated.

    I want you (all) to know, not only am I a linux newbie but I'm following the how-to word for word on a FRESH installed copy of ubuntu from the 5.04 CD
    every time something goes wrong, I re-start from a fresh re-install.

    Therefore I see every problem with the how-to - because I follow it word for word

    I think there should be at least these 2 changes.


    1, information on how to add the repositories in synaptic so the users know EXACTLY (and I quote) what this means
    "
    Since we have to compile the driver from sources, we need the packages: build-essential, gcc, linux-headers-myOwnKernelVersion.
    "

    and how to actually do it.


    2, information on the ieee "bug" thing - so the users know that the remove-old script does NOT work and needs to be manually fixed.



    (thanks again luca - but plz update how-to very comprehensively - it will stop a lot of idiot posters (like me!) who ask questions)
    HowTo edited.

  3. #253
    Join Date
    May 2005
    Location
    Melbourne, AU
    Beans
    123

    Re: HOWTO: ipw2200 + wpa

    Quote Originally Posted by luca_linux
    Are you sure?
    In a previous post you said that the eth1 interface was activated but doesn't get any IP address. So, if eth1 is shown by ifconfig, it'll be shown by the network panel too, which is just a GUI of ifconfig.


    Well it's greyed out - when I go into it, it asks for a SSID and a WEP key??
    Surely this means the network control panel isn't fully compatible with the WPA supplicant?


    Anyhow!

    Here's the results of ifconfig



    eth1 Link encap:Ethernet HWaddr 00:12:F0:80:A0:87
    inet6 addr: fe80::212:f0ff:fe80:a087/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:6328 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1275 errors:0 dropped:0 overruns:0 carrier:1
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    Interrupt:7 Base address:0xa000 Memory:faffc000-faffcfff



    but here's something interesting from dmesg

    "IPv6 over IPv4 tunneling driver"
    "eth1: no IPv6 routers present"

    Maybe eth1 is set to only be running on ipv6?

    BTW as I mentioned in my other post.

    I've tried
    sudo wpa_supplicant -B -i eth1 -c /etc/wpa_supplicant.conf -D ipw -w -dd
    sudo wpa_supplicant -B -i eth1 -c /etc/wpa_supplicant.conf -D ipw -dd
    (no w)

    doesn't make a difference.
    I think I am very close now
    Once we work it out - I'll help update the how-to so it's flawless - from a fresh 5.04 cd to working.

  4. #254
    Join Date
    May 2005
    Location
    Melbourne, AU
    Beans
    123

    Re: HOWTO: ipw2200 + wpa

    Quote Originally Posted by luca_linux
    Are you sure?
    In a previous post you said that the eth1 interface was activated but doesn't get any IP address. So, if eth1 is shown by ifconfig, it'll be shown by the network panel too, which is just a GUI of ifconfig.

    damnit! I think I am close!!!!!!
    I have disabled ALL encryption on my router.
    My drivers (ipw) are installed good enough to work fine without encryption! - the problem is definately with the WPA supp!

    Also when I logged off my machine it said "wpa disabled, please see /etc/default/wpasupplicant"

    So I've checked it out, it says this./



    # /etc/default/wpasupplicant

    # WARNING! Make sure you have a configuration file!

    ENABLED=0

    # Useful flags:
    # -D <driver> Wireless Driver
    # -i <ifname> Interface (required, unless specified in config)
    # -c <config file> Configuration file
    # -d Debugging (-dd for more)
    # -w Wait for interface to come up

    OPTIONS="-w"



    Does this mean I've done something wrong during the howto?

  5. #255
    Join Date
    Apr 2005
    Beans
    514

    Re: HOWTO: ipw2200 + wpa

    Are you sure you have /etc/wpa_supplican.conf file?
    Anyway, try to change "ENABLE=0" to "ENABLE=1" in /etc/default/wpasupplicant.
    If it doesn't work, change it back to "0".

    Then, also try to remove and reinstall wpasupplicant.

  6. #256
    Join Date
    Oct 2004
    Location
    Trailer Park
    Beans
    347
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: ipw2200 + wpa

    Quote Originally Posted by luca_linux
    Are you sure you have /etc/wpa_supplican.conf file?
    Anyway, try to change "ENABLE=0" to "ENABLE=1" in /etc/default/wpasupplicant.
    If it doesn't work, change it back to "0".

    Then, also try to remove and reinstall wpasupplicant.
    just wanted to say thanks for this howto -i setup my intel card faster in linux than in windows
    I haven't tried wpa yet but I will soon enough

  7. #257
    Join Date
    May 2005
    Location
    Melbourne, AU
    Beans
    123

    Re: HOWTO: ipw2200 + wpa

    Quote Originally Posted by luca_linux
    Are you sure you have /etc/wpa_supplican.conf file?
    Anyway, try to change "ENABLE=0" to "ENABLE=1" in /etc/default/wpasupplicant.
    If it doesn't work, change it back to "0".

    Then, also try to remove and reinstall wpasupplicant.

    I'm going to try this tonight (enable 1 / 0) thing.
    I thought maybe that this enabled it anyhow so it didn't matter
    "sudo wpa_supplicant -B -i eth1 -c /etc/wpa_supplicant.conf -D ipw -w -dd" ????

    How do I remove wpa supplicant? (thanks)

  8. #258
    Join Date
    Aug 2005
    Beans
    1

    Re: HOWTO: ipw2200 + wpa

    Hello,

    I've translated the "Ubuntu + ipw2200 + WPA + Startup Script" wiki entry (here) into French (there).

    Hope you'll like it

  9. #259
    Join Date
    Apr 2005
    Beans
    514

    Re: HOWTO: ipw2200 + wpa

    Just remove it through Synaptic or dpkg.

  10. #260
    Join Date
    Apr 2005
    Beans
    514

    Re: HOWTO: ipw2200 + wpa

    Quote Originally Posted by Gobelet
    Hello,

    I've translated the "Ubuntu + ipw2200 + WPA + Startup Script" wiki entry (here) into French (there).

    Hope you'll like it
    Good work.

Page 26 of 66 FirstFirst ... 16242526272836 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •