Results 1 to 10 of 654

Thread: HOWTO: ipw2200 + wpa

Threaded View

  1. #11
    Join Date
    Apr 2005

    Re: HOWTO: ipw2200 + wpa

    Quote Originally Posted by 67fbd400_Linux
    I Just loaded up my Latitude c600 with ubuntu. This forum rocks. I noticed many people having the same problem of connecting with WPA + DHCP. I believe I have found the answer.

    You need to edit your /etc/wpa_supplicant.conf and add ap_scan=2 this allow you to search for hidden ap's. Before I made this change I was not able to locate my ap.

    psk="Secret Key"

    I also had to change the networking start script to S41networking.

    sudo rm /etc/rcS.d/S40networking

    sudo ln -s /etc/init.d/networking /etc/rcS.d/S41networking

    I added wpasupplicant to the /etc/rcS.d/ directory to start at S40wpa_supplicant.

    sudo ln -s /etc/init.d/wpasupplicant /etc/rcS.d/S40wpa_supplicant

    The start script order change was because I noticed wpasupplicant was sTarting after networking.

    I am also using the default start script for wpasupplicant.

    I hope this helps some people get connect thise who can't get IP's this will help.

    Luca great job on the how to you might want to add some of this to it.
    Thanks for the suggesting, I'll add it to my HowTo.
    Anyway, as said in the wpa_supplicant documentation, "scan_ssid=1" allows the scanning with SSID-specific Probe Request frames (this can be used to find APs that do not accept broadcast SSID or use multiple SSIDs; this will add latency to scanning, so enable this only when needed).
    While "ap_scan=2" let wpa_supplicant performing the scan instead of the driver.
    So, I think there may be a bug in ipw2200 on some system configurations and only add the "ap_scan=2" option if you get troubles finding your AP.
    Last edited by luca_linux; July 28th, 2005 at 11:17 AM.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts