Problem solved in Windows by disabling/enabling MAC filter on the router
( don't even ask how that comes! )

Now, in Kubuntu, it still doesn't work

The card gets recognized, but

jochus@bacardi:~$ dmesg | grep -i intel
[4294667.296000] ACPI: FADT (v001 INTEL  ALVISO   0x06040000 LOHR 0x0000005f) @
[4294667.296000] ACPI: MADT (v001 INTEL  ALVISO   0x06040000 LOHR 0x0000005f) @                                                                                                    0x3fee9efc
[4294667.296000] ACPI: MCFG (v001 INTEL  ALVISO   0x06040000 LOHR 0x0000005f) @                                                                                                    0x3fee9f9c
[4294667.296000] ACPI: DSDT (v001 INTEL  ALVISO   0x06040000 MSFT 0x0100000e) @                                                                                                    0x00000000
[4294671.448000] CPU: Intel(R) Pentium(R) M processor 1.73GHz stepping 08
[4294686.686000] agpgart: Detected an Intel 915GM Chipset.
[4294688.469000] ieee80211: Copyright (C) 2004-2005 Intel Corporation <jketreno@                                                                                         >
[4294688.966000] ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.1.0
[4294688.966000] ipw2200: Copyright(c) 2003-2006 Intel Corporation
[4294688.966000] ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
... now, there's something wrong with my eth1

jochus@bacardi:~$ dmesg | grep eth1
[4294693.947000] ADDRCONF(NETDEV_UP): eth1: link is not ready
What could be the problem?