Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 47

Thread: [HOW TO] Mounting smbfs Shares Permanently

  1. #11
    Join Date
    Mar 2005
    Location
    Cabot, AR
    Beans
    18
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: [HOW TO] Mounting smbfs Shares Permanently

    Quote Originally Posted by bigbadsi View Post
    After reboot mount doesn't show my share.

    Is this a permissions issue at startup, do I need to include other options in /etc/fstab or am I missing something else? Also, is there a log I should have checked (I looked in /var/log/samba but didn't know what I was looking at)?
    Check your system log to see if you get this error:

    smbfs: mount_data version 1684370019 is not supported

    I've been troubleshooting that one tonight and unable to find any information other than it used to work in Breezy then stopped working in Dapper. I found a suggestion to add smbfs to /etc/modules but that has not worked for me. I'm still looking for an answer.

  2. #12
    Join Date
    Mar 2006
    Beans
    3

    Re: [HOW TO] Mounting smbfs Shares Permanently

    Quote Originally Posted by DoomedTX View Post
    Check your system log to see if you get this error:

    smbfs: mount_data version 1684370019 is not supported

    I've been troubleshooting that one tonight and unable to find any information other than it used to work in Breezy then stopped working in Dapper. I found a suggestion to add smbfs to /etc/modules but that has not worked for me. I'm still looking for an answer.
    I had the same error. After installing the smbfs package with
    Code:
    sudo apt-get install smbfs
    the error went away.

    cu,

    Andre

  3. #13
    Join Date
    Mar 2005
    Location
    Cabot, AR
    Beans
    18
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: [HOW TO] Mounting smbfs Shares Permanently

    Unfortunately this does not fix the problem for me as smbfs was already installed. From what I've read, not having smbfs installed causes a similar error but that is not the case here. I've done a lot of searching on the 'net and so far the only advice I've found that wasn't "install smbfs" was to add smbfs to the modules loaded at startup. Again, this did not work for me. I could probably get around this by adding the mount commands to a script run towards the end of startup like .bashrc or something like that, but I'd rather have a real fix to this problem that appeared in the Breezy to Edgy upgrade.
    Last edited by DoomedTX; November 23rd, 2006 at 05:34 PM.

  4. #14
    Join Date
    Sep 2006
    Location
    Groningen / Netherlands
    Beans
    113

    Re: [HOW TO] Mounting smbfs Shares Permanently

    Quote Originally Posted by Bill_MI View Post
    Geco, be assured your HowTo has been used successfully. Good jub!

    I have an interesting result when using /etc/fstab: The HAL (hald) fails to come up cleanly *sometimes* (which makes me think network state is involved). I've set it aside for now until I can find out how to get some clues - any appreciated.
    i have the same problem, help will be appreciated
    The Linux Counter Project #432059
    The Ubuntu Counter Project #8465
    In his house at R'lyeh dead Cthulhu waits dreaming, yet he shall rise and his kingdom shall cover the Earth.

  5. #15
    Join Date
    Aug 2005
    Location
    Scotland
    Beans
    1
    Distro
    Kubuntu 6.10 Edgy

    Re: [HOW TO] Mounting smbfs Shares Permanently

    Hi,

    I have a FAT32 formated disk on a server running an old mandrake version (9), I normally mount this partition over the network on my ubuntu box. I have had no problem on Hoary for ages, but now that I have upgraded to 6.10 on an AMD64 box I get the weirdest problem.

    I can create files save them the first time.
    I cannot save an edited file, it blanks the old file and that's it (but I can save as a new file).

    However there are variations:

    if I use vi to edit an existing file, I get permission denied (cannot write file) and the original file is wiped when I quit without saving.
    if I use gedit, I get a warning that it cannot backup the file and ask me to "save anyway" which, when I do, saves the file with the changes...
    If I use Gimp to edit an existing file it gives me the same error as vi and blanks the image file.

    I have looked everywhere for answers, copied my old fstab smbfs line from my previous box to my new one and even the smb.conf but it still doesn't solve the problem, I am at the end of my ideas. The only thing I saw was some posts that resembles my case and it is apparently a bug
    http://www.google.co.uk/search?q=samba+blanked

    so if someone has a better idea please let me know.

    thank you very much

    bib
    Last edited by bib; February 13th, 2007 at 10:43 AM.

  6. #16
    Join Date
    Feb 2007
    Beans
    15

    Re: [HOW TO] Mounting smbfs Shares Permanently

    Hey, im kind of new to linux/xubuntu and I'm having an hard time mounting my ntfs network drive.
    I aint really sure of what to do but anyway, my windows workgroup is called Scott and my computer name is GABEY. The path I want to access is the whole C: drive on Gabey's computer.

    Here's how I'm trying to access it,

    sudo mount -t smbfs //GABEY/C /media/WINDOWS -o username=bleh,password=

    I dont have a password on gabey's computer and this is what i'm getting:


    Anonymous login successful
    7421: tree connect failed: ERRDOS - ERRnoaccess (Access denied.)
    SMB connection failed


    Can someone help me out?!?

  7. #17
    Join Date
    Jul 2006
    Beans
    107

    Re: [HOW TO] Mounting smbfs Shares Permanently

    Quote Originally Posted by Ares2 View Post
    Hey, im kind of new to linux/xubuntu and I'm having an hard time mounting my ntfs network drive.
    I aint really sure of what to do but anyway, my windows workgroup is called Scott and my computer name is GABEY. The path I want to access is the whole C: drive on Gabey's computer.

    Here's how I'm trying to access it,

    sudo mount -t smbfs //GABEY/C /media/WINDOWS -o username=bleh,password=

    I dont have a password on gabey's computer and this is what i'm getting:


    Anonymous login successful
    7421: tree connect failed: ERRDOS - ERRnoaccess (Access denied.)
    SMB connection failed


    Can someone help me out?!?
    try
    Code:
    sudo mount -t smbfs //GABEY/C /media/WINDOWS -o username=bleh,guest
    Debian testing user.
    Don't underestimate the power of *nix manual!!!
    Code:
     geco@biohazard:~$ man man

  8. #18
    Join Date
    Oct 2006
    Location
    Netherlands
    Beans
    Hidden!
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: [HOW TO] Mounting smbfs Shares Permanently

    I followed this How To and it was useful and helpful to me. I can mount all shares flawlessly, I only have one problem: I can't mount shares that have a space in the directory name. e.g: the directory in this fstab line:

    Code:
    //Enigma-V2/Mijn Muziek /home/blaatmeister/Desktop/Samba/Muziek smbfs credentials=/home/blaatmeister/.smbpasswd,uid=blaatmeister 0 0
    When I type sudo mount -a in the terminal, I get the following error:

    Code:
    [mntent]: line 12 in /etc/fstab is bad
    Line 12 is the line I previously gave.

    I tried all these variations of line 12:

    Code:
    "//Enigma-V2/Mijn Muziek" /home/blaatmeister/Desktop/Samba/Muziek smbfs credentials=/home/blaatmeister/.smbpasswd,uid=blaatmeister 0 0
    Code:
    //Enigma-V2/Mijn\ Muziek /home/blaatmeister/Desktop/Samba/Muziek smbfs credentials=/home/blaatmeister/.smbpasswd,uid=blaatmeister 0 0
    Code:
    '//Enigma-V2/Mijn Muziek' /home/blaatmeister/Desktop/Samba/Muziek smbfs credentials=/home/blaatmeister/.smbpasswd,uid=blaatmeister 0 0
    They all give me the same error message as the original line.

    With the combination
    Code:
    //Enigma-V2/Mijn\Muziek /home/blaatmeister/Desktop/Samba/Muziek smbfs credentials=/home/blaatmeister/.smbpasswd,uid=blaatmeister 0 0
    I get this error message:
    Code:
    12455: tree connect failed: ERRDOS - ERRnosuchshare (You specified an invalid share name)
    SMB connection failed
    This is my entire fstab file:

    Code:
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc                                       /proc          proc         defaults                    0  0  
    # /dev/sda2
    UUID=473804f9-e426-4057-92b3-43e86ae6fa4e  /              ext3         defaults,errors=remount-ro  0  1  
    # /dev/sda5
    UUID=3d55a66d-1a14-487c-aaf0-f5e8bafb098a  none           swap         sw                          0  0  
    /dev/hdc                                   /media/cdrom0  udf,iso9660  user,noauto                 0  0  
    /dev/hdd                                   /media/cdrom1  udf,iso9660  user,noauto                 0  0  
    //Enigma-V2/Downloads /home/blaatmeister/Desktop/Samba/Downloads smbfs credentials=/home/blaatmeister/.smbpasswd,uid=blaatmeister 0 0
    //Enigma-V2/Mijn\Muziek /home/blaatmeister/Desktop/Samba/Muziek smbfs credentials=/home/blaatmeister/.smbpasswd,uid=blaatmeister 0 0
    Since the mount on line 11 works, there's nothing wrong with my .smbpasswd file.

    I can also mount the share without a problem in the terminal using the command:

    sudo smbmount "//Enigma-V2/Mijn Muziek" /home/blaatmeister/Desktop/Samba/Muziek -o credentials=/home/blaatmeister/.smbpasswd


    I'm hoping that someone here can tell me how I can mount the share using the fstab file. Thanks in advance.

  9. #19
    Join Date
    Feb 2007
    Beans
    15

    Re: [HOW TO] Mounting smbfs Shares Permanently

    Quote Originally Posted by geco View Post
    try
    Code:
    sudo mount -t smbfs //GABEY/C /media/WINDOWS -o username=bleh,guest

    I'm still getting that error, do you need any other info I can give to help me solve the problem?

  10. #20
    Join Date
    Jul 2006
    Beans
    107

    Arrow Re: [HOW TO] Mounting smbfs Shares Permanently

    Quote Originally Posted by Ares2 View Post
    I'm still getting that error, do you need any other info I can give to help me solve the problem?
    I read in smbmount manual:
    password=<arg>
    specifies the SMB password. If this option is not given then the environment variable
    PASSWD is used. If it can find no passwordsmbmount will prompt for a passeword, unless
    the guest option is given.

    Note that passwords which contain the argument delimiter character (i.e. a comma ’,’)
    will failed to be parsed correctly on the command line. However, the same password de‐
    fined in the PASSWD environment variable or a credentials file (see below) will be read
    correctly.
    so if you have no password you should do:

    guest Don’t prompt for a password
    before using mount try

    Code:
    smbmount //GABEY/C /media/WINDOWS -o username=bleh,guest
    where bleh is your username, isn't it?

    actually mount -t smbfs should call smbmount.
    Debian testing user.
    Don't underestimate the power of *nix manual!!!
    Code:
     geco@biohazard:~$ man man

Page 2 of 5 FirstFirst 1234 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •