Page 1 of 6 123 ... LastLast
Results 1 to 10 of 340

Thread: HOWTO: Enable your Wacom Intous/Graphire Tablet with Pressure Sensitivity

Hybrid View

  1. #1
    Join Date
    Jan 2005
    Beans
    Hidden!

    Arrow HOWTO: Enable your Wacom Intous/Graphire Tablet with Pressure Sensitivity

    This HOW-TO is written for USB Wacom Tablet devices.

    Some links for reference:
    Ubuntu Tablet Wiki Page
    Wacom Help Page
    Once you have some success these links will make more sense. Theres TONS of good info that will make working in The GIMP better.


    1. Connect your USB Wacom Tablet device


    2. Install "wacom-tools". This is need to set the event in your xorg.conf.

    In a terminal:
    Code:
    sudo apt-get install wacom-tools
    Or find "wacom-tools" in Synaptic.

    3. Edit this below Section "InputDevice" under the "Configured Mouse". Make sure you use the right "Device" based on how your pad is connected. ie: USB or serial.
    Code:
    Section "InputDevice"
      Driver        "wacom"
      Identifier    "stylus"
      Option        "Device"        "/dev/ttyS0"          #SERIAL ONLY
      Option        "Device"        "/dev/input/wacom"   #USB ONLY
      Option        "Type"          "stylus"
      Option        "USB"           "on"                  #USB ONLY
      Option        "ForceDevice"   "ISDV4"               #Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
      Driver        "wacom"
      Identifier    "eraser"
      Option        "Device"        "/dev/ttyS0"          #SERIAL ONLY
      Option        "Device"        "/dev/input/wacom"   #USB ONLY
      Option        "Type"          "eraser"
      Option        "USB"           "on"                  #USB ONLY
      Option        "ForceDevice"   "ISDV4"               #Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
      Driver        "wacom"
      Identifier    "cursor"
      Option        "Device"        "/dev/ttyS0"          #SERIAL ONLY
      Option        "Device"        "/dev/input/wacom"   #USB ONLY
      Option        "Type"          "cursor"
      Option        "Mode"          "relative"
      Option        "USB"           "on"                  #USB ONLY
      Option        "ForceDevice"   "ISDV4"               #Tablet PC ONLY
    EndSection
    If you have a Intuos3 or Cintiq 21UX add this section. (Untested by me)

    Code:
    Section "InputDevice"
      Driver        "wacom"
      Identifier    "pad"
      Option        "Device"        "/dev/ttyS0"          #SERIAL ONLY
      Option        "Device"        "/dev/input/wacom"   #USB ONLY
      Option        "Type"          "pad"
      Option        "USB"           "on"                  #USB ONLY
    EndSection
    4. Add these lines to the Section "ServerLayout".
    Code:
    Section "ServerLayout"
    	Identifier	"Default Layout"
    	Screen		"Default Screen"
    	InputDevice	"Generic Keyboard"
    	InputDevice	"Configured Mouse"
            InputDevice    "stylus"    "SendCoreEvents"
            InputDevice    "eraser"    "SendCoreEvents"
            InputDevice    "cursor"    "SendCoreEvents"    #For non-LCD tablets only
            InputDevice    "pad"   #For Intuos3/Cintiq 21UX/Graphire4 tablets. It should NOT send core event
    EndSection
    *NOTE*
    You can adjust the pressure curves on your tablet. Just adjust the "PressCurve" line at bottom of the stylus section.

    Example:
    Code:
    Option "PressCurve" "50,0,100,50"
    This edit will make the drawn lines appear lighter. you can still get really dark lines, you just have to press harder. Makes it easier to make really light or faint changes. -Thanx graigsmith.


    5. Reboot or restart X with ctrl-alt-backspace and launch The GIMP

    6.Enable the tablet in applications.

    The GIMP
    - File-> Preferences-> Input Devices-> "Configure Extended Input Devices".
    - Under "Device" you will have 3 settings: Cursor, Eraser and Stylus. Set them from "Disabled" to "Screen".

    Now you should have pressure sensitivity in The GIMP.

    Also, a useability note with Gimp:
    Each input device (stylus,cursor,eraser) has a completely different set of attributes in Gimp, and in theory, you can even assign a unique serial number to different pens to get even more granularity. You will experience this when you try to use your eraser for the first time. Rather than selecting the eraser tool, you get the rectangle selection tool instead. This is by design, believe it or not. Gimp does not care that its an eraser, just that it's not the pen you were just using. If you choose the eraser tool now, it will remember that for the next time you try to use it. On the plus side, you can set the eraser to be anything, including the Airbrush tool or Clone tool.
    -Taken from The Wacom Help Page.

    Inkscape
    - File-> "Input Devices...".
    (The dialog is the same as The GIMP)
    - Under "Device" you will have 3 settings: Cursor, Eraser and Stylus. Set them from "Disabled" to "Screen".

    Krita
    - Settings-> "Configure Krita..." then click on the "Tablet" icon.
    - Check the "Enable" boxes for all 3 Devices.

    Do you know of more apps that use a tablet?

    If anyone has info to make this better let me know.
    Last edited by MetalMusicAddict; March 26th, 2007 at 04:04 AM.

  2. #2
    Join Date
    Feb 2005
    Beans
    537

    Re: HOWTO: Enable your Wacom Intous/Graphire Tablet with Pressure Sensitivity

    Step 2 is unnecessary if you replace it with this easier way to get your device.

    Code:
    sudo apt-get install wacom-tools
    After installing wacom-tools and following a reboot, you should have a /dev/input/wacom device name, that should correctly point to your tablet. (haven't tested this with a serial tablet)

    Now all you have to do is just rename all your wacom devices, from /dev/input/event0 to /dev/input/wacom

    Also if you run into problems make sure that you didn't include the commented things in the xorg file.

    Code:
    Option        "Device"        "/dev/input/event0"   #USB ONLY
    is incorrect, and probably wont work right. just delete the #usb only.
    Last edited by graigsmith; February 16th, 2007 at 06:50 PM.

  3. #3
    Join Date
    Apr 2005
    Location
    Washougal, WA
    Beans
    127
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: HOWTO: Enable your Wacom Intous/Graphire Tablet with Pressure Sensitivity

    Thanks very much for this!

    Mine is on event3, btw.



    -Paul

  4. #4
    Join Date
    Jan 2005
    Location
    Portland, Oregon U.S.A.
    Beans
    1,050
    Distro
    Ubuntu Mate 15.04 Vivid Vervet

    Re: HOWTO: Enable your Wacom Intous/Graphire Tablet with Pressure Sensitivity

    The link labeled 'wacom help page' goes to Microsoft.com(!!)

  5. #5
    Join Date
    Jan 2005
    Beans
    Hidden!

    Re: HOWTO: Enable your Wacom Intous/Graphire Tablet with Pressure Sensitivity

    Wow. So does the link to the original thread.

  6. #6
    Join Date
    Aug 2005
    Location
    Prague, Czechia
    Beans
    23
    Distro
    Ubuntu 10.04 Lucid Lynx

    Thumbs up Re: HOWTO: Enable your Wacom Intous/Graphire Tablet with Pressure Sensitivity

    Thank you very much.
    Last edited by c4pp4; February 9th, 2006 at 07:34 PM.
    ThinkPad R61i, 15.4" (1280x800), Intel Core 2 Duo T5250, 2x512MB RAM, 160GB SATA, DVD±RW DL, Intel GMA X3100, Intel HDA, Bluetooth, Intel 3945 a/b/g, Gigabit Ethernet, VGA, S-Video, IEEE 1394, Multicard Reader (SD/MMC/MS/XD), Fingerprint Reader

  7. #7
    Join Date
    Jun 2006
    Location
    Texas
    Beans
    3
    Distro
    Kubuntu 6.06

    Re: HOWTO: Enable your Wacom Intous/Graphire Tablet with Pressure Sensitivity

    Hello everyone. First time posting!

    I've followed nearly all of the stuff necessary to make my Graphire 4 work. But it still doesn't work properly. Even when I hold the tip of the stylus a centimeter above the drawing surface it registers it as a button press. I'm using drivers version 0.7.4. The sensitivity does work, but when I lift off the stylus while still keeping in proximity it still seems to draw.

    Update
    After going through the arduous task of getting my tablet to work, I have finally solved the problem. Apparently my computer kept thinking it was a mouse. So I made it so that my tablet is found first by editing /etc/modules to load the wacom module first. And since wacom-tools can't seem to find my tablet through it's normal means, I've had to edit my /etc/X11/xorg.conf file to use the /dev/input/event3 devices. I've also taken the liberty of making the wacom rules for udev load first (by making them 10-wacom.rules instead of maybe 45-wacom.rules in the /etc/udev/rules.d directory).
    Last edited by Ertain; June 30th, 2006 at 11:21 PM.

  8. #8
    Join Date
    Jul 2006
    Beans
    284

    Re: HOWTO: Enable your Wacom Intous/Graphire Tablet with Pressure Sensitivity

    Followed this tutorial and neither Inkscape, nor GIMP or Krita recognize my wacom devices on Dapper Flight. Stylus itself works as usual mouse device.

    Here is excerpt from my xorg.cong:

    Code:
    Section "ServerLayout"
    	Identifier     "Default Layout"
    	Screen      0  "aticonfig Screen 0" 0 0
    	InputDevice    "Generic Keyboard"	"CoreKeyboard"
    	InputDevice    "Configured Mouse"	"CorePointer"
    	InputDevice    "Synaptics Touchpad"
            InputDevice    "stylus"    "SendCoreEvents"
            InputDevice    "eraser"    "SendCoreEvents"
            InputDevice    "cursor"    "SendCoreEvents"    # For non-LCD tablets only
    EndSection
    
    Section "InputDevice"
    	Identifier  "Configured Mouse"
    	Driver      "mouse"
    	Option	    "CorePointer"
    	Option	    "Device" "/dev/input/mouse0"
    	Option	    "Protocol" "ImPS/2"
    	Option	    "Emulate3Buttons" "true"
    	Option	    "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Synaptics Touchpad"
    	Driver      "synaptics"
    	Option	    "SendCoreEvents" "true"
    	Option	    "Device" "/dev/psaux"
    	Option	    "Protocol" "auto-dev"
    	Option	    "HorizScrollDelta" "0"
    EndSection
    
    Section "InputDevice"
    	Driver        "wacom"
    	Identifier    "stylus"
    	Option        "Device"        "/dev/input/event4"   # USB ONLY
    	Option        "Type"          "stylus"
    	Option        "USB"           "on"                  # USB ONLY
    EndSection
    
    Section "InputDevice"
    	Driver        "wacom"
    	Identifier    "eraser"
    	Option        "Device"        "/dev/input/event4"   # USB ONLY
    	Option        "Type"          "eraser"
    	Option        "USB"           "on"                  # USB ONLY
    EndSection
    
    Section "InputDevice"
    	Driver        "wacom"
    	Identifier    "cursor"
    	Option        "Device"        "/dev/input/event4"   # USB ONLY
    #	Option        "Device"        "/dev/input/wacom"   # USB ONLY
    	Option        "Type"          "cursor"
    	Option        "USB"           "on"                  # USB ONLY
    EndSection
    Last edited by prokoudine; July 14th, 2006 at 10:03 PM. Reason: more information

  9. #9
    Join Date
    Dec 2009
    Beans
    1

    Re: HOWTO: Enable your Wacom Intous/Graphire Tablet with Pressure Sensitivity

    Hello UbuntuHeads,

    I've done this

    sudo apt-get install wacom-tools
    But.... sorry, newby here.... struggling with Ubuntu 9.10 and Wacom Bamboo tablet.... where do I enter the rest of the code? I would really appeciate a hint

  10. #10
    Join Date
    Jun 2010
    Location
    Eureka, CA
    Beans
    2
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Enable your Wacom Intous/Graphire Tablet with Pressure Sensitivity

    Another set of thanks for the instructions. I'm new to Linux, installed Ubuntu 10,04, followed the instructions on configuring The GIMP, and Bob's your uncle! I'm in business again with my Wacom tablet, with buttons remapped to suit my preferences. I also installed MyPaint, which works really nicely with Wacom devices.

Page 1 of 6 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •