Results 1 to 2 of 2

Thread: DNSMAQ + DHCP with virtual network

  1. #1
    Join Date
    Feb 2022
    Beans
    3

    DNSMAQ + DHCP with virtual network

    Hya,

    my ubuntu server box have two NIC's one the public interface and the other the internal. I prefer the traditional model, network interfaces instead of the netplan, and it works well.

    By eth0, i created the eth0:0 virtual interface with another ip address.

    By dnsmasq, i have the following dhcp entries:

    Code:
    interface=eth0
    interface=eth0:0
    interface=eth1
    interface=wap0
    listen-address=192.168.80.4
    listen-address=192.168.58.4
    listen-address=192.168.28.4
    listen-address=127.0.0.1
    .....
    dhcp-option=eth0,3,192.168.80.4
    dhcp-option=eth0:0,3,192.168.80.4
    dhcp-option=wap0,3,192.168.80.4
    dhcp-option=option:router,192.168.80.4
    .....
    dhcp-range=eth0,192.168.80.10,192.168.80.240,255.255.255.0,6h
    dhcp-range=eth1,192.168.58.10,192.168.58.240,255.255.255.0,6h
    dhcp-range=wap0,192.168.28.10,192.168.28.240,255.255.255.0,6h
    dhcp-range=eth0:0,192.168.58.100,192.168.58.240,255.255.255.0,6h
    
    .....

    But it seams that for eth0:0 the address allocation does not work.

    Any hints?

    Thx in advance!




  2. #2
    Join Date
    May 2024
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: DNSMAQ + DHCP with virtual network

    The ":" notation likely has a special meaning in the dnsmasq config:

    -F, --dhcp-range=[tag:<tag>[,tag:<tag>],][set:<tag>,]<start-IPv6addr>[,<end-IPv6addr>|constructor:<in‐
    terface>][,<mode>][,<prefix-len>][,<lease time>]

    Can you give the virtual interface a different name without that character?

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •