Results 1 to 5 of 5

Thread: Videos and Thumbnails not working on Ubuntu 24.04

  1. #1
    Join Date
    May 2006
    Location
    Israel
    Beans
    1,968

    Question Videos and Thumbnails not working on Ubuntu 24.04

    Today I did an installation of Ubuntu 24.04, kept my home folder that was used by Linux Mint.
    I did have some desktop crashing issues, but I solved it by removing the .gnome related dirs.

    Now I have a new issue,
    I cannot view any thumbnails in 'files',
    There were old threads that it's somehow related to apparmor, but I have the latest version in which it was fixed.

    Also a somehow related issue, I cannot play any videos, not in VLC or on any other player.
    dmesg shows:

    audit: type=1400 audit(1718040850.090:5237030): apparmor="DENIED" operation="symlink" class="file" profile="snap.vlc.vlc" name="/dev/char/195:255" pid=107301 comm="glxinfo" requested_mask="c" denied_mask="c" fsuid=1000 ouid=1000
    And many other apparmor="DENIED" lines for other apps,

    I noticed that I don't have this file (dunno if I should)
    /etc/apparmor.d/usr.bin.snap

    I've run:
    sudo dpkg-reconfigure apparmor

    and even:
    sudo apt reinstall snapd

    But still the same issue.
    Last edited by MaximB; June 10th, 2024 at 09:58 PM.

  2. #2
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    13,736
    Distro
    Ubuntu

    Re: Videos and Thumbnails not working on Ubuntu 24.04

    As far as snaps go,
    snaps don't handle symlinks or understand what they even are.
    The expected behavior is to bind mount the source and the destination.

    As far as not seeing thumbnails in Files try deleting the "fail" folder in ~/.cache/thumbnails.
    I've seen that work myself.
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  3. #3
    Join Date
    May 2006
    Location
    Israel
    Beans
    1,968

    Re: Videos and Thumbnails not working on Ubuntu 24.04

    I didn't understand what I should do in the first part,
    And if I use flatpak vlc the videos will run? or should I try to get a .deb package?

    I already removed the "fail" folder in ~/.cache/thumbnails, but it didn't resolve the issue.

  4. #4
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    13,736
    Distro
    Ubuntu

    Re: Videos and Thumbnails not working on Ubuntu 24.04

    And if I use flatpak vlc the videos will run? or should I try to get a .deb package?
    Sure. Either should work, I would think.
    Snaps are weird. Sorry.
    I already removed the "fail" folder in ~/.cache/thumbnails, but it didn't resolve the issue.
    Yep, I don't know what's gong on with some users and thumbnails.
    Might have some common thing/setup that not everyone else has or does.
    ???
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  5. #5
    Join Date
    May 2006
    Location
    Israel
    Beans
    1,968

    Re: Videos and Thumbnails not working on Ubuntu 24.04

    After removing the default vlc and installing vlc with apt - the videos started running again....
    Also when I installed Steam via the software manager it had bugs (couldn't add a third dist to storage and it didn't recognize my ~/.steam/root/compatibilitytools.d/ dir, so no Proton-GE), but after installing Steam via the Steam website .deb method - those bugs were gone.

    The thumbnails issue I solved by:
    sudo apt install ffmpegthumbnailer
    and also running this (not sure if the second command is mandatory as I run it first and it didn't work)
    sudo sysctl -w kernel.apparmor_restrict_unprivileged_userns=0

    Why ho why do they insist on shipping a LTS release with broken snaps? it's supposed to be stable...

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •