Hi all. I am stuck in a boot loop on a new Linux Mint install.
(Microsoft Surface Laptop Go 3
Some context:

  • Had windows and installed Ubuntu (in order to dual boot) yesterday but Windows would skip Grub so I ran this command (yeah I know):

    bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi
  • After this, nothing worked and I ended up in a command line every time I restart the pc.
  • I decided then that I would create another USB but this time using Linux Mint, and I did a fresh install using the option "Erase disk and install Linux Mint".

It seemed to have installed it correctly but now I am stuck in a loop where I see the GRUB options, I select Linux Mint, and then it restarts the computer again.

  • The only ways for me to get into Linux Mint are:
    - selecting the UEFI option on Grub, and then tell the laptop to boot immediately using the selected option and then it loads Mint correctly.
    - on grub, typing "c", which goes into a command line, then I press exit; which restarts the pc, and then I see grub and I select Mint and it loads correctly.

I ran boot-repair with no success, and it gave me this paste bin:


Thanks everyone! this has been a frustrating experience