Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 27

Thread: Libreoffice not handling filenames with umlauts

  1. #11
    Join Date
    Nov 2023
    Beans
    15

    Re: Libreoffice not handling filenames with umlauts

    I suspect it's somehow KDE that is the culprit. I just ran Tails on my laptop, started LO and saved a file named xä, it worked. Only thing that doesn't work is LO + KDE...

  2. #12
    Join Date
    Mar 2010
    Location
    /home
    Beans
    9,554
    Distro
    Xubuntu

    Re: Libreoffice not handling filenames with umlauts

    I tried replicating this in a VM with Kubuntu 22.04.

    Added German as an input method, opened and closed a couple of LO Writer documents with umlauts in the text and filename and they open and save correctly.

    Very curious.

    What happens if you try this:
    Rename the file to remove umlauts >> open or save the file >> rename the file again to include umlauts

    It's not much of a workaround but does it solve the issue?

  3. #13
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: Libreoffice not handling filenames with umlauts

    Try issuing the command

    Code:
    touch Lüft
    in a terminal (while your working directory is your /home) and see if a file is created.
    Please read The Forum Rules and The Forum Posting Guidelines

    A thing discovered and kept to oneself must be discovered time and again by others. A thing discovered and shared with others need be discovered only the once.
    This universe is crazy. I'm going back to my own.

  4. #14
    Join Date
    Nov 2023
    Beans
    15

    Re: Libreoffice not handling filenames with umlauts

    I tried touching something with the letter ö, all I got was (arg: 6) ä and å wouldn't work at all, nothing displayed..

  5. #15
    Join Date
    Mar 2010
    Location
    /home
    Beans
    9,554
    Distro
    Xubuntu

    Re: Libreoffice not handling filenames with umlauts

    Are you saying that no text document was created in your Home folder?

    The touch command creates an empty text file in the current working directory (by default the home folder).

    If it did not, then I am beginning to suspect that you need to reconfigure your locale settings.

  6. #16
    Join Date
    Nov 2023
    Beans
    15

    Re: Libreoffice not handling filenames with umlauts

    Nothing happened…
    If it is a locale problem, what should I do?
    Last edited by aeh63; 4 Weeks Ago at 06:20 PM.

  7. #17
    Join Date
    Mar 2010
    Location
    /home
    Beans
    9,554
    Distro
    Xubuntu

    Re: Libreoffice not handling filenames with umlauts

    Do you have the same issue with other foreign accents such as circonflexe or the German sharp S (ß)?

    Even though QIII and I are not 100% sure it is a locale issue, try this:
    Code:
    sudo dpkg-reconfigure locales
    Also, I guess it does no harm to check this:

    Open LibreOffice and go to Tools -> Options -> Load/Save -> General.

    Ensure that "Save" options are configured to use Unicode or UTF-8 encoding.
    Last edited by Rubi1200; 4 Weeks Ago at 01:05 PM. Reason: added info

  8. #18
    Join Date
    Nov 2023
    Beans
    15

    Re: Libreoffice not handling filenames with umlauts

    No luck. Besides there is no mention about UTF-8 on the General (as above) settings page…

  9. #19
    Join Date
    Sep 2006
    Beans
    1,966
    Distro
    Ubuntu 24.04 Noble Numbat

    Re: Libreoffice not handling filenames with umlauts

    Hello,

    you could check also if something is messed up with your account. One quick test would be to create a new user, log in as that new user and test LO. If it is working with umlauts, then there is something wrong with your account. If not, then the issue is more general. I do not have the UTF-8 on General settings page either. Are you sure that the correct keyboard is selected for your account? One easy thing would be to remove it and add it back again and check.

    Some ideas,
    Regards!

  10. #20
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: Libreoffice not handling filenames with umlauts

    Do you have Unicode in configs?

    Unicode is the character set. UTF-8 is the encoding.
    Last edited by QIII; 3 Weeks Ago at 09:46 PM.
    Please read The Forum Rules and The Forum Posting Guidelines

    A thing discovered and kept to oneself must be discovered time and again by others. A thing discovered and shared with others need be discovered only the once.
    This universe is crazy. I'm going back to my own.

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •