Results 1 to 5 of 5

Thread: [SOLVED-almost] Wine works but is really slow to start even on SSD(?)

  1. #1
    Join Date
    May 2024
    Beans
    32

    Question [SOLVED-almost] Wine works but is really slow to start even on SSD(?)

    I have a computer that's about a year old and I got Linux on it finally and Wine is on it too.
    Is Wine really this slow lately? Over the years I've used Wine and it was never too slow.
    But lately, I'm almost about to give up right before each program loads. Is this slowness normal?

    I have a high-speed SSD, so this seems surprising. I'm using wine-staging.

    What can you tell me?
    Last edited by 909mjolnir; 2 Weeks Ago at 12:03 AM. Reason: sorta fixed

  2. #2
    Join Date
    Apr 2024
    Location
    Nova Scotia, Canada
    Beans
    32
    Distro
    Xubuntu 24.04 Noble Numbat

    Re: Wine works but is really slow to start even on SSD(?)

    I haven't noticed any slowness here. I've been using Wine Stable and Development.

  3. #3
    Join Date
    May 2024
    Beans
    32

    Re: Wine works but is really slow to start even on SSD(?)

    Yeah, you wouldn't have noticed slowness on your own computer. Each computer is like it's own fingerprint or snowflake. No two are alike.
    But anyways, I found some info about this all of a sudden: https://www.reddit.com/r/linux_gamin...ime/?rdt=57594

    I remember this was a problem with Ubuntu Studio having hundreds to thousands of fonts instead of maybe 6 fonts.
    I gotta get in there and manually delete them.

  4. #4
    Join Date
    May 2024
    Beans
    32

    Re: Wine works but is really slow to start even on SSD(?)

    OK, wine is still slow, but I found the "wineserver -p" command and added it to my Session startup list.
    Also, I set up a Session startup to run Appetizer or winecfg at startup. After that, wine is a little faster.
    I can't tell which fonts are needed or not, so I can't delete them. So I can't do that.

    But my system is at least running.
    I turned off some other extras (forgot what they were already).

  5. #5
    Join Date
    Apr 2014
    Location
    Tucson AZ, USA
    Beans
    1,078
    Distro
    Ubuntu

    Re: [SOLVED-almost] Wine works but is really slow to start even on SSD(?)

    I run Battle.net via Bottles frontend for wine. It takes a fairly long time (relative to native programs) to load the Battle.net client and then whatever game. Once it's up though it runs perfectly, arguably better performance than Windows ever gave me. I haven't figured out why it takes so long to load initially. It does bug me but not a major problem.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •