Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: livepatchd error: The platform Ubuntu 22.10 is not supported.

  1. #1
    Join Date
    Nov 2013
    Location
    EU
    Beans
    11
    Distro
    Ubuntu

    Question livepatchd error: The platform Ubuntu 22.10 is not supported.

    Upgraded successfully from Mantic to Noble via standard upgrade method (no -d or other trickery used).

    Enrolled Ubuntu Pro but seeing errors, namely "livepatchd error: The platform Ubuntu 22.10 is not supported."

    I am obviously not running 22.10 so something is not quite right. How to correct it? Many thanks.



    EDIT: forced reinstall of ubuntu-pro-client, didn't fix it.
    Attached Images Attached Images
    Last edited by rjgoverna; 4 Weeks Ago at 12:51 PM. Reason: adding prefix, adding note

  2. #2
    Join Date
    Oct 2008
    Location
    Rezzoaglio (GE) Italy
    Beans
    692
    Distro
    Ubuntu Development Release

    Re: livepatchd error: The platform Ubuntu 22.10 is not supported.

    ubuntu-pro is only for LTS version. what version are you using? upgrade completed or?
    Last edited by corradoventu; 4 Weeks Ago at 01:55 PM.

  3. #3
    Join Date
    Nov 2013
    Location
    EU
    Beans
    11
    Distro
    Ubuntu

    Re: livepatchd error: The platform Ubuntu 22.10 is not supported.

    Quote Originally Posted by corradoventu View Post
    ubuntu-pro is only for LTS version. what version are you using? upgrade completed or?
    Yep. It's all there, I'm running 24.04 LTS, aka Noble:
    Upgraded successfully from Mantic to Noble via standard upgrade method (no -d or other trickery used).
    You can see I've successfully enrolled Pro. As per the screenshot, esm-apps and esm-infra are fine but livepatch seems to think I'm running 22.10.

    Reinstalling ubuntu-pro-client didn't help either.

    EDIT: reinstalling ubuntu-advantage-tools also doesn't fix it.
    Last edited by rjgoverna; 3 Weeks Ago at 03:33 PM.

  4. #4
    Join Date
    Mar 2010
    Location
    USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: livepatchd error: The platform Ubuntu 22.10 is not supported.

    Quote Originally Posted by rjgoverna View Post
    Yep. It's all there, I'm running 22.04 LTS, aka Noble:

    You can see I've successfully enrolled Pro. As per the screenshot, esm-apps and esm-infra are fine but livepatch seems to think I'm running 22.10.

    Reinstalling ubuntu-pro-client didn't help either.

    EDIT: reinstalling ubuntu-advantage-tools also doesn't fix it.
    Well no. You said you went from Mantic, which is 23.10, to Noble, which is 24.04. That is where you enrolled into Ubuntu Pro. ( It had nothing to do with 22.04. )

    I asked the Canonical Ubuntu Pro Team where to refer people for support for Ubuntu Pro, when I was testing it for Ubuntu Members. Below is the instructions.

    Regardless... Go to https://ubuntu.com/pricing/pro... In the lower right of that page is a contact dialog. It will say "Leave a Message", or "Chat"... When it says "Chat", talk with a person from their support team, and ask them. Explain it just like I did above, then tell them the errors you are getting.

    "Concurrent coexistence of Windows, Linux and UNIX..." || Ubuntu user # 33563, Linux user # 533637
    Sticky: Graphics Resolution | UbuntuForums 'system-info' Script | Posting Guidelines | Code Tags

  5. #5
    Join Date
    Nov 2013
    Location
    EU
    Beans
    11
    Distro
    Ubuntu

    Re: livepatchd error: The platform Ubuntu 22.10 is not supported.

    oh I see, typo on my second reply. Now amended. First post accurate.

    In short, on this machine: Jammy (22.04 LTS, first enrollment) > Mantic (23.10, unenrolled) > Noble (24.04 LTS, re-enrolled).
    Not sure what's up with the "Ubuntu 22.10 is not supported" error.

    Cheers, I'll give that a shot.
    Last edited by rjgoverna; 3 Weeks Ago at 04:00 PM.

  6. #6
    Join Date
    Mar 2010
    Location
    USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: livepatchd error: The platform Ubuntu 22.10 is not supported.

    I'm thinking the code is still wet on that. Updates for "Released Noble" just started rolling out recently. They are still working things out with Ubuntu Pro ESM as it relates to Noble. I wouldn't expect their to be much updates through Ubuntu Pro ESM yet... It's only less than a month since it's release.

    But LivePatch being broken for Noble... That is definitely a Bug that they need to be made aware of. They (there) all work for Canonical they can make things happen.

    We here are just volunteers who are Users sharing our experience with other Users.

    "Concurrent coexistence of Windows, Linux and UNIX..." || Ubuntu user # 33563, Linux user # 533637
    Sticky: Graphics Resolution | UbuntuForums 'system-info' Script | Posting Guidelines | Code Tags

  7. #7
    Join Date
    Nov 2013
    Location
    EU
    Beans
    11
    Distro
    Ubuntu

    Re: livepatchd error: The platform Ubuntu 22.10 is not supported.

    Yep, I expect it all to be ironed out by the time 24.04.1 comes out. All in all the upgrade went smoothly and this is a very minor issue for my use case.

    Quote Originally Posted by MAFoElffen View Post
    But LivePatch being broken for Noble... That is definitely a Bug that they need to be made aware of.
    My thoughts exactly. The sort of feedback I expect will be useful to the folks at Canonical.

  8. #8
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    13,703
    Distro
    Ubuntu

    Re: livepatchd error: The platform Ubuntu 22.10 is not supported.

    It's probably basing it on what kernel is running.
    Look a what kernel version is current in use
    Code:
    uname -a
    It's possible, albeit odd, to still have the 22.10 kernel installed and by some odder chance it being the kernel in use.
    That kernel series for 22.10 was automatically installed to 22.04 as an upgraded HWE kernel.
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  9. #9
    Join Date
    Nov 2013
    Location
    EU
    Beans
    11
    Distro
    Ubuntu

    Re: livepatchd error: The platform Ubuntu 22.10 is not supported.

    Quote Originally Posted by deadflowr View Post
    It's probably basing it on what kernel is running.
    Look a what kernel version is current in use
    Good point. Double checked, all looks normal.

    Linux E6420 6.8.0-31-generic #31-Ubuntu SMP PREEMPT_DYNAMIC Sat Apr 20 00:40:06 UTC 2024 x86_64 x86_64 x86_64 GNU/Linux

  10. #10
    Join Date
    Nov 2013
    Location
    EU
    Beans
    11
    Distro
    Ubuntu

    Re: livepatchd error: The platform Ubuntu 22.10 is not supported.

    Good news, fixed it by reinstalling the livepatch snap.

    sudo snap remove --purge canonical-livepatch
    sudo snap install canonical-livepatch
    sudo pro enable livepatch

    It's now up and running.



    Only niggle left to fix is the following error:

    Successfully processed your pro configuration.
    Successfully refreshed your subscription.
    /usr/lib/python3/dist-packages/uaclient/apt_news.py:160: Warning: W: Download is performed unsandboxed as root as file '/run/ubuntu-advantage//aptnews.json' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)
    acq.run()
    Successfully updated Ubuntu Pro related APT and MOTD messages.
    Attached Images Attached Images
    Last edited by rjgoverna; 3 Weeks Ago at 05:19 PM.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •