Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Install Power ISO in Ubuntu

  1. #1
    Join Date
    Feb 2023
    Beans
    12

    Install Power ISO in Ubuntu

    Hi I want to install Power ISO in Ubuntu and I don't know how to start.Can someone help me?I need this to download an iso file game.

  2. #2
    Join Date
    Jun 2006
    Location
    UK
    Beans
    Hidden!
    Distro
    Ubuntu 22.04 Jammy Jellyfish

    Re: Install Power ISO in Ubuntu

    Support, not chat. Thread moved to General Help.
    Ubuntu 22.04 Desktop Guide - Ubuntu 24.04 Desktop Guide - Forum Guide to BBCode - Using BBCode code tags

    Member: Not Canonical Team

    If you need help with your forum account, such as SSO login issues, username changes, etc, the correct place to contact an admin is here. Please do not PM me about these matters unless you have been asked to - unsolicited PMs concerning forum accounts will be ignored.

  3. #3
    Join Date
    Jun 2010
    Location
    London, England
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Install Power ISO in Ubuntu

    This is what the original poster is talking about.

    https://www.poweriso.com/download-po...-for-linux.htm

    Ubuntu comes with a utility to burn ISO images to USB memory sticks. It is called Startup Disk Creator. Or you can download and install mkusb which I have found very useful.

    https://help.ubuntu.com/community/mkusb

    It might be helpful if we knew what game you want to run. The instructions of the game's developer might be informative.

    Regards
    It is a machine. It is more stupid than we are. It will not stop us from doing stupid things.
    Ubuntu user #33,200. Linux user #530,530


  4. #4
    Join Date
    Feb 2023
    Beans
    12

    Re: Install Power ISO in Ubuntu

    https://imgur.com/a/JszUHKB
    This is how I typed in the terminal and I can't get the software to work.How do I fix this issue?

  5. #5
    Join Date
    Dec 2014
    Beans
    2,658

    Re: Install Power ISO in Ubuntu

    Never knew that there is a Linux version of Power Iso. I've been using gcdemu for a long time for the purpose of mounting CD/DVD images and I'm quite happy with it. There's also Acetone Iso. gcdemu can be found at https://cdemu.sourceforge.io/ and they have a PPA for Ubuntu. Acetone Iso is in the repositories.

    Holger

  6. #6
    Join Date
    Jun 2014
    Beans
    7,523

    Re: Install Power ISO in Ubuntu

    The message in the image you posted indicates that a plugin could not be found and suggests reinstalling the application which I take to mean the poweriso application. Have you tried that?

  7. #7
    Join Date
    Feb 2023
    Beans
    12

    Re: Install Power ISO in Ubuntu

    Quote Originally Posted by yancek View Post
    The message in the image you posted indicates that a plugin could not be found and suggests reinstalling the application which I take to mean the poweriso application. Have you tried that?
    How do I install this plugin?Can someone help?

  8. #8
    Join Date
    Dec 2014
    Beans
    2,658

    Re: Install Power ISO in Ubuntu

    It's actually not the xcb plugin itself, it's the whole thing which is incompatible. If you run it with
    Code:
    QT_DEBUG_PLUGINS=1 ./poweriso.sh
    you get (a lot) more detailed information. The program tries to bring all the libraries it needs along, but some are missing and are used from the system. Those aren't compatible with the ones the program brings along (specifically libqxcb needs libfontconfig, libfreetype, libbrotlidec, and libbrotlicommon which aren't included and those on your system need a newer version of libc than the one which is included; and of course the included libraries and the program need that old version of libc). It's a classical case of dependency hell. This program was compiled on February 10th in 2019 and the world has moved on since then.

    Holger

  9. #9
    Join Date
    Mar 2007
    Location
    Promiseland
    Beans
    1,622
    Distro
    Xubuntu 22.04 Jammy Jellyfish

    Re: Install Power ISO in Ubuntu

    Seems like you need to use a different utility, or a different OS.
    Supported operating systems:
    Windows 11, Windows 10, Windows 8 / 8.1, Windows 7, Windows Vista, Windows 2008, Windows 2003, Windows XP, Windows 2000, Windows Me, Windows 98
    Cheers,


    The Linux Command Line at http://linuxcommand.org/

  10. #10
    Join Date
    Feb 2023
    Beans
    12

    Re: Install Power ISO in Ubuntu

    Quote Originally Posted by grahammechanical View Post
    This is what the original poster is talking about.

    https://www.poweriso.com/download-po...-for-linux.htm

    Ubuntu comes with a utility to burn ISO images to USB memory sticks. It is called Startup Disk Creator. Or you can download and install mkusb which I have found very useful.

    https://help.ubuntu.com/community/mkusb

    It might be helpful if we knew what game you want to run. The instructions of the game's developer might be informative.

    Regards
    I just want to extract the ISO file.
    I replaced the commands powersh file and now I get this error
    export LD_LIBRARY_PATH=1.
    export QT_QPA_PLATFORM_PLUGIN_PATH=1.
    ./poweriso
    export QT_DEBUG_PLUGINS=1
    unset LD_LIBRARY_PATH




    ./poweriso: ./libc.so.6: version `GLIBC_2.38' not found (required by /lib/x86_64-linux-gnu/libGLX.so.0)
    ./poweriso: ./libc.so.6: version `GLIBC_2.34' not found (required by /lib/x86_64-linux-gnu/libGLX.so.0)
    ./poweriso: ./libc.so.6: version `GLIBC_2.38' not found (required by /lib/x86_64-linux-gnu/libGLdispatch.so.0)
    ./poweriso: ./libc.so.6: version `GLIBC_2.34' not found (required by /lib/x86_64-linux-gnu/libGLdispatch.so.0)
    ./poweriso: ./libc.so.6: version `GLIBC_2.33' not found (required by /lib/x86_64-linux-gnu/libX11.so.6)
    ./poweriso: ./libc.so.6: version `GLIBC_2.34' not found (required by /lib/x86_64-linux-gnu/libX11.so.6)
    ./poweriso: ./libc.so.6: version `GLIBC_2.38' not found (required by /lib/x86_64-linux-gnu/libX11.so.6)
    ./poweriso: ./libc.so.6: version `GLIBC_2.38' not found (required by /lib/x86_64-linux-gnu/libxcb.so.1)
    ./poweriso: ./libc.so.6: version `GLIBC_2.33' not found (required by /lib/x86_64-linux-gnu/libXau.so.6)
    ./poweriso: ./libc.so.6: version `GLIBC_2.33' not found (required by /lib/x86_64-linux-gnu/libbsd.so.0)
    ./poweriso: ./libc.so.6: version `GLIBC_2.38' not found (required by /lib/x86_64-linux-gnu/libbsd.so.0)
    ./poweriso: ./libc.so.6: version `GLIBC_2.33' not found (required by /lib/x86_64-linux-gnu/libmd.so.0)
    Last edited by wollyvio; June 5th, 2024 at 07:06 AM.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •