Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: ibc6-dev: Depends: libc6 (= 2.35-0ubuntu3.7) but 2.35-0ubuntu3.6 is installed

  1. #1
    Join Date
    Oct 2006
    Location
    Guyana
    Beans
    178
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    ibc6-dev: Depends: libc6 (= 2.35-0ubuntu3.7) but 2.35-0ubuntu3.6 is installed

    I can not update anything. This keeps popping up. Tried everything I could find online but still not fixed

    "libc6-dev: Depends: libc6 (= 2.35-0ubuntu3.7) but 2.35-0ubuntu3.6 is installed
    Depends: libc-dev-bin (= 2.35-0ubuntu3.7) but 2.35-0ubuntu3.7 is installed"

  2. #2
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: ibc6-dev: Depends: libc6 (= 2.35-0ubuntu3.7) but 2.35-0ubuntu3.6 is installed

    What shows with this:
    Code:
    sudo apt -f install
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags | System-info | Forum Guide lines | Arch Linux, Debian Unstable, FreeBSD

  3. #3
    Join Date
    Jun 2016
    Beans
    2,883
    Distro
    Xubuntu 22.04 Jammy Jellyfish

    Re: ibc6-dev: Depends: libc6 (= 2.35-0ubuntu3.7) but 2.35-0ubuntu3.6 is installed

    Please post the output from running the following commands in Terminal -
    Code:
    sudo apt update
    apt -s install libc6=2.35-0ubuntu3.7
    Xubuntu 22.04, ArchLinux ♦ System76 hardware, virt-manager/KVM, VirtualBox
    If your questions are resolved to your satisfaction, please use Thread Tools > "Mark this thread as solved..."

  4. #4
    Join Date
    Oct 2006
    Location
    Guyana
    Beans
    178
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: ibc6-dev: Depends: libc6 (= 2.35-0ubuntu3.7) but 2.35-0ubuntu3.6 is installed

    Code:
    Reading package lists... Done
    Building dependency tree... Done
    Reading state information... Done
    Correcting dependencies... Done
    The following packages were automatically installed and are no longer required:
      libgsoap-2.8.117 liblzf1
    Use 'sudo apt autoremove' to remove them.
    The following additional packages will be installed:
      libc6 libc6:i386
    Suggested packages:
      glibc-doc glibc-doc:i386 locales:i386
    Recommended packages:
      libnss-nis libnss-nisplus
    The following packages will be upgraded:
      libc6 libc6:i386
    2 upgraded, 0 newly installed, 0 to remove and 104 not upgraded.
    1 not fully installed or removed.
    Need to get 0 B/6,248 kB of archives.
    After this operation, 0 B of additional disk space will be used.
    Do you want to continue? [Y/n] y
    debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
    (Reading database ... 230731 files and directories currently installed.)
    Preparing to unpack .../libc6_2.35-0ubuntu3.7_amd64.deb ...
    De-configuring libc6:i386 (2.35-0ubuntu3.6), to allow configuration of libc6:amd
    64 (2.35-0ubuntu3.6) ...
    debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another p
    rocess: Resource temporarily unavailable
    dpkg: error processing archive /var/cache/apt/archives/libc6_2.35-0ubuntu3.7_amd
    64.deb (--unpack):
     new libc6:amd64 package pre-installation script subprocess returned error exit 
    status 1
    Preparing to unpack .../libc6_2.35-0ubuntu3.7_i386.deb ...
    De-configuring libc6:amd64 (2.35-0ubuntu3.6), to allow configuration of libc6:i3
    86 (2.35-0ubuntu3.6) ...
    debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another p
    rocess: Resource temporarily unavailable
    dpkg: error processing archive /var/cache/apt/archives/libc6_2.35-0ubuntu3.7_i38
    6.deb (--unpack):
     new libc6:i386 package pre-installation script subprocess returned error exit s
    tatus 1
    Errors were encountered while processing:
     /var/cache/apt/archives/libc6_2.35-0ubuntu3.7_amd64.deb
     /var/cache/apt/archives/libc6_2.35-0ubuntu3.7_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

  5. #5
    Join Date
    Oct 2006
    Location
    Guyana
    Beans
    178
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: ibc6-dev: Depends: libc6 (= 2.35-0ubuntu3.7) but 2.35-0ubuntu3.6 is installed

    Quote Originally Posted by halogen2 View Post
    Please post the output from running the following commands in Terminal -
    Code:
    sudo apt update
    apt -s install libc6=2.35-0ubuntu3.7
    Code:
    Reading package lists... Done
    Building dependency tree... Done
    Reading state information... Done
    You might want to run 'apt --fix-broken install' to correct these.
    The following packages have unmet dependencies:
     libc6 : Recommends: libnss-nis but it is not going to be installed
             Recommends: libnss-nisplus but it is not going to be installed
             Breaks: libc6:i386 (!= 2.35-0ubuntu3.7) but 2.35-0ubuntu3.6 is to be installed
     libc6:i386 : Breaks: libc6 (!= 2.35-0ubuntu3.6) but 2.35-0ubuntu3.7 is to be installed
    E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

  6. #6
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: ibc6-dev: Depends: libc6 (= 2.35-0ubuntu3.7) but 2.35-0ubuntu3.6 is installed

    One more to show please:
    Code:
    apt -s install  libc6-i386
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags | System-info | Forum Guide lines | Arch Linux, Debian Unstable, FreeBSD

  7. #7
    Join Date
    Jun 2016
    Beans
    2,883
    Distro
    Xubuntu 22.04 Jammy Jellyfish

    Re: ibc6-dev: Depends: libc6 (= 2.35-0ubuntu3.7) but 2.35-0ubuntu3.6 is installed

    Wait, you get no output at all from sudo apt update ?

    The output from the command suggested by 1fallen looks like you have something else actively trying to do something with apt packages. Do you have unattended-upgrades running? Does the problem persist if you retry sudo apt -f install when no other apt/dpkg-related processes are running?

    If none of that helps, please post the output from running the following command in Terminal -
    Code:
    apt -s install libc6:amd64=2.35-0ubuntu3.7 libc6:i386=2.35-0ubuntu3.7
    Xubuntu 22.04, ArchLinux ♦ System76 hardware, virt-manager/KVM, VirtualBox
    If your questions are resolved to your satisfaction, please use Thread Tools > "Mark this thread as solved..."

  8. #8
    Join Date
    Oct 2006
    Location
    Guyana
    Beans
    178
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: ibc6-dev: Depends: libc6 (= 2.35-0ubuntu3.7) but 2.35-0ubuntu3.6 is installed

    Code:
    Reading package lists... Done
    Building dependency tree... Done
    Reading state information... Done
    You might want to run 'apt --fix-broken install' to correct these.
    The following packages have unmet dependencies:
     libc6-dev : Depends: libc6 (= 2.35-0ubuntu3.7) but 2.35-0ubuntu3.6 is to be installed
     libc6-i386 : Depends: libc6 (= 2.35-0ubuntu3.7) but 2.35-0ubuntu3.6 is to be installed
    E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

  9. #9
    Join Date
    Oct 2006
    Location
    Guyana
    Beans
    178
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: ibc6-dev: Depends: libc6 (= 2.35-0ubuntu3.7) but 2.35-0ubuntu3.6 is installed

    Quote Originally Posted by 1fallen View Post
    One more to show please:
    Code:
    apt -s install  libc6-i386
    Code:
    Reading package lists... Done
    Building dependency tree... Done
    Reading state information... Done
    You might want to run 'apt --fix-broken install' to correct these.
    The following packages have unmet dependencies:
     libc6-dev : Depends: libc6 (= 2.35-0ubuntu3.7) but 2.35-0ubuntu3.6 is to be installed
     libc6-i386 : Depends: libc6 (= 2.35-0ubuntu3.7) but 2.35-0ubuntu3.6 is to be installed
    E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

  10. #10
    Join Date
    Oct 2006
    Location
    Guyana
    Beans
    178
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: ibc6-dev: Depends: libc6 (= 2.35-0ubuntu3.7) but 2.35-0ubuntu3.6 is installed

    Quote Originally Posted by halogen2 View Post
    Wait, you get no output at all from sudo apt update ?

    The output from the command suggested by 1fallen looks like you have something else actively trying to do something with apt packages. Do you have unattended-upgrades running? Does the problem persist if you retry sudo apt -f install when no other apt/dpkg-related processes are running?

    If none of that helps, please post the output from running the following command in Terminal -
    Code:
    apt -s install libc6:amd64=2.35-0ubuntu3.7 libc6:i386=2.35-0ubuntu3.7
    Code:
    $ sudo apt -s install libc6:amd64=2.35-0ubuntu3.7 libc6:i386=2.35-0ubuntu3.7
    Reading package lists... Done
    Building dependency tree... Done
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
      libgsoap-2.8.117 liblzf1
    Use 'sudo apt autoremove' to remove them.
    Suggested packages:
      glibc-doc glibc-doc:i386 locales:i386
    Recommended packages:
      libnss-nis libnss-nisplus
    The following packages will be upgraded:
      libc6 libc6:i386
    2 upgraded, 0 newly installed, 0 to remove and 104 not upgraded.
    1 not fully installed or removed.
    Inst libc6 [2.35-0ubuntu3.6] (2.35-0ubuntu3.7 Ubuntu:22.04/jammy-updates, Ubuntu:22.04/jammy-security [amd64]) [libc6:amd64 on libc6:i386] [libc6:i386 on libc6:amd64] [libc6:i386 ]
    Inst libc6:i386 [2.35-0ubuntu3.6] (2.35-0ubuntu3.7 Ubuntu:22.04/jammy-updates, Ubuntu:22.04/jammy-security [i386])
    Conf libc6 (2.35-0ubuntu3.7 Ubuntu:22.04/jammy-updates, Ubuntu:22.04/jammy-security [amd64])
    Conf libc6:i386 (2.35-0ubuntu3.7 Ubuntu:22.04/jammy-updates, Ubuntu:22.04/jammy-security [i386])
    Conf libc6-dev (2.35-0ubuntu3.7 Ubuntu:22.04/jammy-updates, Ubuntu:22.04/jammy-security [amd64])

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •