Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Installed Grub on a sperate drive now my Windows 10 only boots to startup repair

  1. #1
    Join Date
    May 2024
    Beans
    5

    Installed Grub on a sperate drive now my Windows 10 only boots to startup repair

    I installed Ubuntu and Grub onto a seperate SSD although this seems to have broken my Win 10 OS, was hoping for a dual boot

    Installed Boot-repair as nothing i have read so far is working, please see the pastebin: https://paste.ubuntu.com/p/63dwXbnM3T/

    I am quite noob with this so sorry if its easy fix, but also hope it is, would appreciate any help here

  2. #2
    Join Date
    Apr 2024
    Location
    Nova Scotia, Canada
    Beans
    24
    Distro
    Xubuntu 24.04 Noble Numbat

    Re: Installed Grub on a sperate drive now my Windows 10 only boots to startup repair

    I don't know if this will apply to you. When I installed Ubuntu, I had to disable RST in the BIOS settings and set it to AHCI in order to get the Ubuntu installer to boot. If I try to boot Windows without changing it back to RST It will say that the boot device is inaccessible and goes to automatic repair.

  3. #3
    Join Date
    May 2024
    Beans
    5

    Re: Installed Grub on a sperate drive now my Windows 10 only boots to startup repair

    I believe that is for intel only, i am running an AMD CPU, thanks but cant even see those 2 options within my UEFI

  4. #4
    Join Date
    Apr 2024
    Location
    Nova Scotia, Canada
    Beans
    24
    Distro
    Xubuntu 24.04 Noble Numbat

    Re: Installed Grub on a sperate drive now my Windows 10 only boots to startup repair

    Quote Originally Posted by bowiye View Post
    I believe that is for intel only, i am running an AMD CPU, thanks but cant even see those 2 options within my UEFI
    Ahh yes RST is Intel.

  5. #5
    Join Date
    Jun 2014
    Beans
    7,467

    Re: Installed Grub on a sperate drive now my Windows 10 only boots to startup repair

    So what actually happens when you boot? Does Ubuntu boot?

    I installed Ubuntu and Grub onto a seperate SSD
    That does not seem to be the case from boot repair which shows you have windows on nvme1n1p2 (line 18 boot repair) a 465GB drive. You have Ubuntu installed on sdc1 on a 232GB drive (Line 179) and both are EFI installs with the EFI files on sda1 shown beginning at line 26. The grub.cfg file on this EFI partition shows it pointing to the actual grub.cfg file on the Ubuntu partition which is on sdc1. Do you not see an entry for windows in the Grub boot menu? Have you run sudo update-grub from Ubuntu and watched the output ot see if a windows entry appears? If not, enable os-prober in Ubuntu by editing the /etc/default/grub file and adding the line:

    GRUB_DISABLE_OS_PROBER=false
    You need to make this change using a text editor with root privileges (sudo) and save the change and update-grub.

    Since both Ubuntu and windows are installed in EFI mode, there should be no problem booting both from Grub, in fact since they are on separate drives it should not matter.

  6. #6
    Join Date
    May 2008
    Beans
    4,077
    Distro
    Ubuntu 24.04 Noble Numbat

    Re: Installed Grub on a sperate drive now my Windows 10 only boots to startup repair

    Quote Originally Posted by bowiye View Post
    I installed Ubuntu and Grub onto a seperate SSD although this seems to have broken my Win 10 OS, was hoping for a dual boot
    Lines 93 > 95 - 1 OS detected OS#1: The OS now in use - Ubuntu 20.04.6 LTS on sdc1
    Unfortunately, Windows 10 is not visible to the boot-repair report

    Your Windows 10 system is (probably) located on nvme1n1p2
    This nvme1n1 disk does not have an ESP, therefore can you explain the history of your Windows OS?
    For example, was this an upgrade from XP in Legacy mode?

    The other puzzle is the nomenclature of disk nvme1n1.
    Usually, the first nvme disk is nvme0n1
    Can you shed some light on this?

    Notwithstanding my observations, please first try the suggestions offered by yancek.

  7. #7
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: Installed Grub on a sperate drive now my Windows 10 only boots to startup repair

    You also now show UEFI Secure Boot on.
    Sometimes a Windows update also updates UEFI firmware resetting to defaults which may turn Secure Boot back on.
    You may want to turn it off, but not necessary, but grub may not boot Windows. You just always choose from UEFI boot menu.

    You also then with Windows updates may have Windows fast start up turned on. You often have to turn it back off after updates in Windows.
    Fast Start up off (always on hibernation), note that Windows turns this back on with updates, SHIFT + Shut down button
    http://ubuntuforums.org/showthread.p...2#post13488472
    https://www.elevenforum.com/t/turn-o...ndows-11.1212/
    https://www.makeuseof.com/windows-11...-fast-startup/

    Unless the fast startup is on which sets hibernation flag, is then hiding NVMe drive, it does not look like nvme0 is used?

    Also the ESP - efi system partition is normally on the same drive as Windows with Windows installs.
    Ubuntu normally uses the first drive, whatever first drive is seen by UEFI/BIOS.
    Newer versions of Ubuntu now let you choose what drive to have an eSP on.

    You also have very old Windows BIOS boot installed to MBR of nvme1n1 and sdb. Those will never be used, but will not interfere with booting as long as you never choose the old BIOS mode to boot. Windows only boots in UEFI mode from gpt partitioned drives and only in old BIOS mode from MBR partitioned drives. Your sdd seems to have an old install of Windows in the BIOS/MBR configuration. With Secure boot on, that will never boot.
    UEFI boot install & repair info - Regularly Updated :
    https://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  8. #8
    Join Date
    May 2024
    Beans
    5

    Re: Installed Grub on a sperate drive now my Windows 10 only boots to startup repair

    I have run this before and my Windows OS does appear in the output, rerun for example:
    Sourcing file `/etc/default/grub'
    Sourcing file `/etc/default/grub.d/init-select.cfg'
    Generating grub configuration file ...
    Found linux image: /boot/vmlinuz-5.15.0-105-generic
    Found initrd image: /boot/initrd.img-5.15.0-105-generic
    Found linux image: /boot/vmlinuz-5.4.0-42-generic
    Found initrd image: /boot/initrd.img-5.4.0-42-generic
    Found Windows Boot Manager on /dev/sda1@/EFI/Microsoft/Boot/bootmgfw.efi
    Adding boot menu entry for UEFI Firmware Settings
    done

    Ubuntu boots fine, Grub loader seems to work fine, Windows selection is within the Grub loader although selecting it brings up the Windows Startup Repair and it is unable to fix a thing....classic startup repair

  9. #9
    Join Date
    May 2024
    Beans
    5

    Re: Installed Grub on a sperate drive now my Windows 10 only boots to startup repair

    Have you run sudo update-grub from Ubuntu and watched the output ot see if a windows entry appears?
    I have run this before and my Windows OS does appear in the output, rerun for example:
    Sourcing file `/etc/default/grub'
    Sourcing file `/etc/default/grub.d/init-select.cfg'
    Generating grub configuration file ...
    Found linux image: /boot/vmlinuz-5.15.0-105-generic
    Found initrd image: /boot/initrd.img-5.15.0-105-generic
    Found linux image: /boot/vmlinuz-5.4.0-42-generic
    Found initrd image: /boot/initrd.img-5.4.0-42-generic
    Found Windows Boot Manager on /dev/sda1@/EFI/Microsoft/Boot/bootmgfw.efi
    Adding boot menu entry for UEFI Firmware Settings
    done

    Ubuntu boots fine, Grub loader seems to work fine, Windows selection is within the Grub loader although selecting it brings up the Windows Startup Repair and it is unable to fix a thing....classic startup repair

    This nvme1n1 disk does not have an ESP, therefore can you explain the history of your Windows OS?
    Windows OS was a clean install when the machine was built, many other older drives from the PC before though, Win OS is a Samsung 980 512GB NVME, Ubuntu is a seperate 256GB Sata SSD, cant remember what type, is just an old drive from the cupboard

    For example, was this an upgrade from XP in Legacy mode?
    This machine has never had XP on it, no idea where that came from im afraid.

    The other puzzle is the nomenclature of disk nvme1n1.
    Usually, the first nvme disk is nvme0n1
    \
    Best guess is the 512GB ssd is in the 2nd NVME slot on the MOBO and i have a seperate NVME in slot 1, this is only a guess though, cant think of any other reason for this.

  10. #10
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: Installed Grub on a sperate drive now my Windows 10 only boots to startup repair

    Does Windows boot directly from UEFI boot menu, not from grub.
    If so then it is UEFI Secure boot, or if not a Windows issue.
    UEFI boot install & repair info - Regularly Updated :
    https://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •