Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Camera not working after update Ubuntu 24.04

  1. #1
    Join Date
    Apr 2024
    Beans
    1

    Camera not working after update Ubuntu 24.04

    My Camera is not working after I updated from Ubuntu 23.10 (Mantic Minotaur) to 24.04 (Noble Numbat). I purchased one of those cheap laptops Gateway GWNR7151-7BK Ryzen 7.
    Do I need to install new drivers?

  2. #2
    Join Date
    Jul 2013
    Location
    Wisconsin
    Beans
    4,966

    Re: Camera not working after update Ubuntu 24.04

    Try the much simpler step of rebooting into an older kernel at GRUB,

  3. #3
    Join Date
    Apr 2024
    Beans
    1

    Re: Camera not working after update Ubuntu 24.04

    Make sure your camera is enabled in your system settings. Updates can sometimes reset settings. Additionally, there might be an issue with the drivers. You can check for additional drivers by navigating to the "Software & Updates" application and then selecting the "Additional Drivers" tab. If you see any camera-related drivers listed there, try selecting and installing them to see if it resolves the issue with your camera.

  4. #4
    Join Date
    Apr 2005
    Location
    Ierapetra,Crete,Greece
    Beans
    45

    Re: Camera not working after update Ubuntu 24.04

    I have the same problem, camera stopped working after upgrade to 24.04 from 23.10. I installed cheese and I get this error:
    [0:12:52.893088367] [10599] WARN IPAManager ipa_manager.cpp:154 No IPA found in '/usr/lib/x86_64-linux-gnu/libcamera'
    [0:12:52.893149182] [10599] INFO Camera camera_manager.cpp:284 libcamera v0.2.0

    (cheese:10599): GStreamer-CRITICAL **: 15:37:32.012: gst_structure_get_value: assertion 'structure != NULL' failed
    [0:12:52.980798780] [10599] WARN IPAManager ipa_manager.cpp:154 No IPA found in '/usr/lib/x86_64-linux-gnu/libcamera'
    [0:12:52.980836762] [10599] INFO Camera camera_manager.cpp:284 libcamera v0.2.0
    [0:12:53.137196513] [10634] INFO Camera camera.cpp:1183 configuring streams: (0) 1280x720-MJPEG
    [0:12:53.137262839] [10625] ERROR V4L2 v4l2_videodevice.cpp:1047 /dev/video0[50:cap]: Unable to set format: Device or resource busy
    [0:12:53.138771179] [10634] WARN IPAManager ipa_manager.cpp:154 No IPA found in '/usr/lib/x86_64-linux-gnu/libcamera'
    [0:12:53.138797769] [10634] INFO Camera camera_manager.cpp:284 libcamera v0.2.0
    [0:12:53.256097013] [10633] INFO Camera camera.cpp:1183 configuring streams: (0) 1280x720-MJPEG
    [0:12:53.256174510] [10635] ERROR V4L2 v4l2_videodevice.cpp:1047 /dev/video0[50:cap]: Unable to set format: Device or resource busy

    (cheese:10599): cheese-WARNING **: 15:37:32.320: Failed to configure camera: Device or resource busy: ../src/gstreamer/gstlibcamerasrc.cpp(446): gst_libcamera_src_negotiate (): /GstCameraBin:camerabin/GstWrapperCameraBinSrc:camera_source/GstBin:bin18/GstLibcameraSrc:libcamerasrc1:
    Camera::configure() failed with error code -16
    I tried the old kernel 6.5, but the same.
    A free society is one where it is safe to be unpopular.
    -- Adlai Stevenson

  5. #5
    Join Date
    Apr 2024
    Beans
    1

    Re: Camera not working after update Ubuntu 24.04

    After installing Ubuntu 24.04 default camera apps says there's no camera found. So i installed `Cheese` and it just worked fine. But i wanted defaults to work, so i searched up on internet and got this. and after doing `systemctl --user restart pipewire` dafault Camera app working fine.

  6. #6
    Join Date
    Sep 2006
    Beans
    1,952
    Distro
    Ubuntu 24.04 Noble Numbat

    Re: Camera not working after update Ubuntu 24.04

    Hello and welcome to the forums,

    Quote Originally Posted by niamotullah99 View Post
    After installing Ubuntu 24.04 default camera apps says there's no camera found. So i installed `Cheese` and it just worked fine. But i wanted defaults to work, so i searched up on internet and got this. and after doing `systemctl --user restart pipewire` dafault Camera app working fine.
    thank you for posting this. I faced exactly the same issue and your solution is working fine. The only thing is that the command provided as a solution should be issued after every reboot.

    Regards!

  7. #7
    Join Date
    May 2024
    Beans
    1

    Re: Camera not working after update Ubuntu 24.04

    Quote Originally Posted by Claus7 View Post
    Hello and welcome to the forums,

    thank you for posting this. I faced exactly the same issue and your solution is working fine. The only thing is that the command provided as a solution should be issued after every reboot.

    Regards!
    Yes, I too find that this solves my problem (with the camera built in to my Lenovo laptop).

    Does anyone know how do we make this survive reboot?

  8. #8
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Camera not working after update Ubuntu 24.04

    I'm using Xubuntu, but should not matter, I add this to ".bashrc"
    Code:
    bash -c "sleep 10 && systemctl --user restart pipewire"
    So far So Good...

    EDIT: I feel I also need to add, once I'm logged in I open a Terminal and keep it open, That's just how i run.
    Last edited by 1fallen; May 5th, 2024 at 08:40 PM.
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags | System-info | Forum Guide lines | Arch Linux, Debian Unstable, FreeBSD

  9. #9
    Join Date
    Sep 2006
    Beans
    1,952
    Distro
    Ubuntu 24.04 Noble Numbat

    Re: Camera not working after update Ubuntu 24.04

    Hello,

    I have tested also this alternative option https://ubuntuforums.org/showthread.php?t=2496736 in another machine, so I will keep things as is at the moment, since a fix is about to take place, which might make all these solutions redundant. If on the other hand someone can't wait, the solution 1fallen proposes is what someone has to follow.

    Regards!

  10. #10
    Join Date
    May 2024
    Beans
    4

    Re: Camera not working after update Ubuntu 24.04

    Quote Originally Posted by niamotullah99 View Post
    After installing Ubuntu 24.04 default camera apps says there's no camera found. So i installed `Cheese` and it just worked fine. But i wanted defaults to work, so i searched up on internet and got this. and after doing `systemctl --user restart pipewire` dafault Camera app working fine.
    works for me too

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •