Results 1 to 3 of 3

Thread: Package 'libdvdread4' has no installation candidate

  1. #1
    Join Date
    Apr 2024
    Beans
    2

    Question Package 'libdvdread4' has no installation candidate

    Hi, i'm trying to play some encrypted DvD but i can't since some of them are probably encrypted. Itried following the guide: https://help.ubuntu.com/community/RestrictedFormats So I tried to do:
    sudo apt-get install lubuntu-restricted-extras

    then:
    sudo /usr/share/doc/libdvdread4/install-css.sh

    When i use this command this happens:

    fracru@FraCru:~$ sudo /usr/share/doc/libdvdread4/install-css.sh
    [sudo] password for fracru:
    sudo: /usr/share/doc/libdvdread4/install-css.sh: command not found

    Then i searched online and tried: sudo apt-get install libdvdread4 && sudo /usr/share/doc/libdvdread4/install-css.sh

    but i have anyway problems:
    fracru@FraCru:~$ sudo apt-get install libdvdread4 && sudo /usr/share/doc/libdvdread4/install-css.sh
    [sudo] password for fracru:
    Reading package lists... Done
    Building dependency tree... Done
    Reading state information... Done
    Package libdvdread4 is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source

    E: Package 'libdvdread4' has no installation candidate

    What should i do? Thanks a lot this is my first time using linux

  2. #2
    Join Date
    Dec 2014
    Beans
    2,656

    Re: Package 'libdvdread4' has no installation candidate

    The way to do this has changed a few times and the instructions in the wiki seem to be stuck at some point in time far in the past. Follow the link to https://help.ubuntu.com/community/Re...ts/PlayingDVDs on the page you linked and then do what it tells you to do for Ubuntu version 15.10 or newer.
    Code:
    sudo apt install libdvd-pkg
    This should download, compile, package, and install the libraries needed for DVD decoding. If it doesn't do all of that, you might have to run
    Code:
    sudo dpkg-reconfigure libdvd-pkg
    Holger

  3. #3
    Join Date
    Apr 2024
    Beans
    2

    Re: Package 'libdvdread4' has no installation candidate

    I followed both the commands but the pc still can't read some dvds. I dont know why: it recognize the title but when i try to press play, i read in the top the name of the dvd for just a sec and then it tourns again normal.

    Edit: i followed the exactly same instruction on a different pc with the same lubuntu and it works...
    Last edited by crucio200; April 21st, 2024 at 11:12 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •