Results 1 to 2 of 2

Thread: confusion about implementing quotas - where is my error?

  1. #1
    Join Date
    Apr 2024

    confusion about implementing quotas - where is my error?

    Hello good gents
    I am asking for your help, searching the web didn't solved my problem or i am being a bit dense.
    To the problem at hand.
    On a Ubuntu server 22.04 i have to implement the quotas for the users. One detail of importance: the server has a mount point called /data and users have their /home on /data/home. So in the fstab a certain disk partition is mounted at /data.
    There is no /home mount point, nor can i add one.
    What I did was:
    apt install quota
    And added then usrquota and grpquota in /etc/fstab and unmount and remount the /data, all ok.
    sudo quotacheck -ugm /data
    sudo modprobe quota_v1 -S 5.15.0-89-generic
    sudo modprobe quota_v2 -S 5.15.0-89-generic
    sudo quotaon -v /data
    Where my confusion starts.
    I can't enable quotaon -v /data/home, nor /home. - Mountpoint(or device) not found or has no quota enabled.
    Now, When i succesfully activated quotas on /data, two files were and aquota.user.

    If i simply move those two files, will allow /data/home to be seen as valid point?
    If the quota is enabled on /data, i can simply edquota for a user and will automagically understand that the quota is applied to /data/home/myuser?

    So i am stuck here, for the moment and i am asking fot your help. Kinldy point me to the right dirrection.
    Thank you in advance,
    Last edited by drakenstein; April 14th, 2024 at 08:39 AM.

  2. #2
    Join Date
    Apr 2024

    Re: confusion about implementing quotas - where is my error?

    What i already tried:
    checked the files in /etc/mtab.
    found /data with aforementioned files.

    tried to execute
     quotackeck -cug /data/home
    Same error as above.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts