Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Issues connecting Mini PC with Linux Lite 6.6 to LG TV; no HDMI signal on startup.

  1. #11
    Join Date
    Mar 2007
    Location
    Promiseland
    Beans
    1,576
    Distro
    Xubuntu 22.04 Jammy Jellyfish

    Re: Issues connecting Mini PC with Linux Lite 6.6 to LG TV; no HDMI signal on startup

    Good news, it can be done.

    I went down to the basement where my mini pc resides. One has to tinker a little bit with the settings. Not necessary to change anything in BIOS setup. Configuration settings are all in TV and in *buntu Settings > Display

    Boot with both PC nonitor and TV monitor connected, mirrowing
    https://imgur.com/DWz4qzil.png

    Boot to TV Monitor (prime)
    https://imgur.com/1OHaWqDl.png

    Note: When I tried to go to the imgur links I got a 404 not found.
    I will resubmit the before and after screenshots as attachments.
    Cheers,


    The Linux Command Line at http://linuxcommand.org/

  2. #12
    Join Date
    Mar 2007
    Location
    Promiseland
    Beans
    1,576
    Distro
    Xubuntu 22.04 Jammy Jellyfish

    Re: Issues connecting Mini PC with Linux Lite 6.6 to LG TV; no HDMI signal on startup

    1. Boot with both PC monitor and TV monitor connected, mirrowing

    2. Boot to TV monitor (prime) with HDMI cable to PC monitor disconnected.

    One other thing I should add, mine uses an AMD APU with integrated AMD graphics.
    Code:
    hugh@MA90:~$ sudo inxi -CGMxxz
    [sudo] password for hugh: 
    Machine:
      Type: Mini-pc System: ATOPNUC product: ATOPNUC MA90 v: V1.0
        serial: <filter>
      Mobo: ATOPNUC model: ATOPNUC MA90 v: Version 1.0 serial: <filter>
        UEFI: American Megatrends v: ASB20008 date: 07/19/2022
    CPU:
      Info: dual core model: AMD A9-9400 RADEON R5 5 COMPUTE CORES 2C+3G bits: 64
        type: MCP arch: Excavator rev: 0 cache: L1: 192 KiB L2: 2 MiB
      Speed (MHz): avg: 1400 min/max: 1400/2400 boost: enabled cores: 1: 1400
        2: 1400 bogomips: 9581
      Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
    Graphics:
      Device-1: AMD Stoney [Radeon R2/R3/R4/R5 Graphics] driver: amdgpu v: kernel
        ports: active: HDMI-A-1 empty: DP-1,HDMI-A-2 bus-ID: 00:01.0
        chip-ID: 1002:98e4
      Display: server: X.org v: 1.21.1.4 compositor: xfwm driver: X:
        loaded: ati unloaded: fbdev,modesetting,radeon,vesa gpu: amdgpu
        display-ID: localhost:10.0
      Monitor-1: HDMI-A-1 model: 32S305 res: 1920x1080 dpi: 69
        diag: 815mm (32.1")
    Note: The screenshot on the left is most recent showing where I booted to TV monitor only.
    Attached Images Attached Images
    Last edited by him610; April 15th, 2024 at 12:52 AM. Reason: Added diff between OP machine and mine
    Cheers,


    The Linux Command Line at http://linuxcommand.org/

  3. #13
    Join Date
    Apr 2024
    Beans
    6

    Re: Issues connecting Mini PC with Linux Lite 6.6 to LG TV; no HDMI signal on startup

    ISSUE SOLVED!

    I contacted Beelink support and they suggested to install the latest kernel.

    I installed the latest linux kernel 6.8.6 using "Mainline Kernels" tool. Although there was a warning about missing dependencies, the install finished. After reboot all looked fine on my monitor. I switched the HDMI cable to my TV, restarted the MINI S and there it worked as well. At first only video, but audio worked as well after changing output settings in the audio mixer. The TV display is now also properly identified in my display settings so I can change the resolution as well if need be.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •