Results 1 to 6 of 6

Thread: A wireless mouse working with Bluetooth connection, but not working with 2.4G connect

  1. #1
    Join Date
    Apr 2024
    Beans
    3

    Question A wireless mouse working with Bluetooth connection, but not working with 2.4G connect

    I got a new mouse and have been trying to get it to work in the 2.4G connection mode (and it does not). The mouse works fine with Bluetooth, and it works in both modes when I use it with a Windows (10) machine that has a "mouhid.sys" driver file. Any help or advice? If it helps, I'm using Ubuntu 23.10 and the command lsusb gives:

    ...
    Bus 001 Device 011: ID 3151:3020 YICHIP Wireless Device
    ...

    This vanishes when I turn the mouse off or pull the USB Receiver out of the computer, so I assume it's the wireless mouse.

    It's this mouse: https://www.amazon.com/Wireless-Bluetooth-Mouse-Rechargeable-Bluetooth5-2/dp/B0BPCW5CS6?th=1
    Last edited by dcpetit; April 4th, 2024 at 09:11 PM. Reason: improve readability

  2. #2
    Join Date
    Mar 2007
    Location
    Promiseland
    Beans
    1,622
    Distro
    Xubuntu 22.04 Jammy Jellyfish

    Re: A wireless mouse working with Bluetooth connection, but not working with 2.4G con

    @dcpetit, I queried the internet,
    what is frequency of bluetooth
    Answer:
    Bluetooth uses short-wavelength UHF radio waves with a frequency of around 2,400,000,000 to 2,485,000,000Hz, which is 2.4 to 2.485GHz. Bluetooth operates at frequencies between 2.402 and 2.480 GHz, or 2.400 and 2.4835 GHz, including guard bands 2 MHz wide at the bottom end and 3.5 MHz wide at the top. This is in the globally unlicensed (but not unregulated) industrial, scientific and medical (ISM) 2.4 GHz short-range radio frequency band.
    If you are able to connect your bluetooth devices, you utilizing the 2.4G RF band.
    Cheers,


    The Linux Command Line at http://linuxcommand.org/

  3. #3
    Join Date
    Apr 2024
    Beans
    3

    Re: A wireless mouse working with Bluetooth connection, but not working with 2.4G con

    I think the 2.4G mode and bluetooth mode on this mouse are different. The 5th picture on the Amazon link shows the two different modes (and it the description is says, " Dual-Mode Mouse(Wireless USB 2.4G+Bluetooth5.2/3.0) "), and shows the range of the bluetooth that this mouse uses. Moreover, on the bottom of the mouse there is a switch which toggles between 2.4G mode, off (mode), and bluetooth mode. The mouse is only working when it's set on bluetooth and connected that way. Thanks for your help! I appreciate your investigations to get this working

  4. #4
    Join Date
    Mar 2007
    Location
    Promiseland
    Beans
    1,622
    Distro
    Xubuntu 22.04 Jammy Jellyfish

    Re: A wireless mouse working with Bluetooth connection, but not working with 2.4G con

    Did you also read this in the description....
    Bluetooth Mouse Mode Can Connect One Device Through BT5.2/3.0 and Wireless Mouse Mode Another Device Through a 2.4G USB Receiver....Note:The USB Receiver is Stored Inside The Back of The Mouse
    That USB Receiver needs to be plugged into a USB port on your computer.
    Cheers,


    The Linux Command Line at http://linuxcommand.org/

  5. #5
    Join Date
    Apr 2024
    Beans
    3

    Re: A wireless mouse working with Bluetooth connection, but not working with 2.4G con

    Yeah, I've plugged it in. And Ubuntu seems to recognize it as the list of recognized USBs has "Bus 001 Device 011: ID 3151:3020 YICHIP Wireless Device", which goes away when I pull the USB receiver out. So the issue seems to be at the last possible step as the receiver is in the computer, the mouse is on and the red light at the bottom of the mouse is working great, the computer recognizes the mouse via USB, but the cursor doesn't move when I move the mouse... Thanks in advance!
    Last edited by dcpetit; April 7th, 2024 at 06:08 PM.

  6. #6
    Join Date
    Jul 2024
    Beans
    1

    Re: A wireless mouse working with Bluetooth connection, but not working with 2.4G con

    I have the same problem with the mouse that can work using Bluetooth or 2.4Ghz receiver and that self-reports as "YICHIP Wireless Device". If I try to use the receiver sometimes my Linux operating system does not recognize it. Usually it helps to disable mouse, pull receiver out, plug it back in and enable mouse again.

    In the system journal there are following errors:
    Jul 02 07:25:18 laptop-dell kernel: usbhid 1-2:1.1: can't add hid device: -110
    Jul 02 07:25:18 laptop-dell kernel: usbhid 1-2:1.1: probe with driver usbhid failed with error -110

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •