Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Dell XPS 14 9440 Support

  1. #11
    Join Date
    Jun 2007
    Beans
    14,801

    Re: Dell XPS 14 9440 Support

    complaining about a missing topology file 'sof-mtl-rt711.tplg'
    Shot in the dark here, but maybe the file it should be looking for is sof-mtl-rt711-4ch.tplg (this laptop has quad speakers from what I can see). Try making a symbolic link (and rebooting):
    Code:
    cd /lib/firmware/intel/sof-ace-tplg/
    sudo ln -s sof-mtl-rt711-4ch.tplg sof-mtl-rt711.tplg
    If it doesn't work, look at dmesg again to see if anything changed.

    Whether it works or not, maybe open an issue here: https://github.com/thesofproject/sof-bin/issues I'm going to guess they will make a link in their repo like I did or get/create the missing file if needed. Either that, or they can figure out where the reference to "sof-mtl-rt711.tplg" is coming from and fix that.

  2. #12
    Join Date
    Jun 2007
    Beans
    14,801

    Re: Dell XPS 14 9440 Support

    Quote Originally Posted by mixer2 View Post
    To me, it looks like you either need gstreamer 1.24.x or maybe an older version of icamera.

  3. #13
    Join Date
    Mar 2024
    Beans
    5

    Re: Dell XPS 14 9440 Support

    So...i found this thread https://github.com/thesofproject/linux/issues/4879 and it's for the 16" 9640, but i assume it's a similar audio device in the 9440.

    I'm not an expert in any of this, but it sounds like the latest kernel seems to be picking up the audio device incorrectly, and thinking it needs to use the rt711 drivers, but it should actually be the cs35l56 driver. And the fix is available (or it works in one of the latest beta Linux kernels.

    So using mainline, i changed my kernel to 6.9-rc2 (Beta/Release Candidate) rebooted and it's now seemingly using the right driver, but i'm still can't get the audio device to appear, and still only see "Dummy Output" as a device.

    For reference, here's a dump of dmesg

    sudo dmesg | grep sof
    [ 0.057606] software IO TLB: area num 32.
    [ 0.605387] PCI-DMA: Using software bounce buffering for IO (SWIOTLB)
    [ 0.605388] software IO TLB: mapped [mem 0x0000000042986000-0x0000000046986000] (64MB)
    [ 0.701510] integrity: Loaded X.509 cert 'Microsoft Windows Production PCA 2011: a92902398e16c49778cd90f99e4f9ae17c55af53'
    [ 3.702454] audit: type=1400 audit(1712298943.542:3): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/opt/microsoft/msedge/msedge" pid=760 comm="apparmor_parser"
    [ 3.939309] sof-audio-pci-intel-mtl 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040100
    [ 3.939415] sof-audio-pci-intel-mtl 0000:00:1f.3: SoundWire enabled on CannonLake+ platform, using SOF driver
    [ 3.939422] sof-audio-pci-intel-mtl 0000:00:1f.3: enabling device (0000 -> 0002)
    [ 3.939522] sof-audio-pci-intel-mtl 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if 0x040100
    [ 5.037571] sof-audio-pci-intel-mtl 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040100
    [ 5.038373] sof-audio-pci-intel-mtl 0000:00:1f.3: SoundWire enabled on CannonLake+ platform, using SOF driver
    [ 5.038744] sof-audio-pci-intel-mtl 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if 0x040100
    [ 5.038859] sof-audio-pci-intel-mtl 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
    [ 5.046837] sof-audio-pci-intel-mtl 0000:00:1f.3: use msi interrupt mode
    [ 5.066250] sof-audio-pci-intel-mtl 0000:00:1f.3: hda codecs found, mask 4
    [ 5.069522] sof-audio-pci-intel-mtl 0000:00:1f.3: Firmware paths/files for ipc type 1:
    [ 5.069526] sof-audio-pci-intel-mtl 0000:00:1f.3: Firmware file: intel/sof-ipc4/mtl/sof-mtl.ri
    [ 5.069527] sof-audio-pci-intel-mtl 0000:00:1f.3: Firmware lib path: intel/sof-ipc4-lib/mtl
    [ 5.069528] sof-audio-pci-intel-mtl 0000:00:1f.3: Topology file: intel/sof-ace-tplg/sof-mtl-cs42l43-l0-cs35l56-l23.tplg
    [ 5.070330] sof-audio-pci-intel-mtl 0000:00:1f.3: Loaded firmware library: ADSPFW, version: 2.9.0.1
    [ 5.177623] sof-audio-pci-intel-mtl 0000:00:1f.3: Booted firmware version: 2.9.0.1
    [ 15.455299] platform sof_sdw: deferred probe pending: sof_sdw: snd_soc_register_card failed -517


    But the moritz89 seems to have got it working, but i don't know how.
    Anyways, figured i'd post, see if it helps

  4. #14
    Join Date
    Jun 2007
    Beans
    14,801

    Re: Dell XPS 14 9440 Support

    Quote Originally Posted by dook123 View Post
    it's now seemingly using the right driver, but i'm still can't get the audio device to appear, and still only see "Dummy Output" as a device.
    In addition to the latest sof firmware, did you update the ucm like in https://github.com/thesofproject/lin...ent-2027703266
    Make sure you do that and reboot.

    What does this show?:
    Code:
    aplay -l
    alsaucm dump text

  5. #15
    Join Date
    Mar 2024
    Beans
    5

    Re: Dell XPS 14 9440 Support

    OK, follow the same steps in the link, but no joy. Seems to be same issue.

    sudo dmesg | grep -E 'sof-audio-pci-intel-mtl|snd_hda_intel|cs35l56|sof_sdw|sof-audio-pci-intel-mtl|input|cs42l43-codec'
    [ 0.610766] input: Lid Switch as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input0
    [ 0.610829] input: Power Button as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input1
    [ 0.610876] input: Sleep Button as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input2
    [ 0.650485] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input3
    [ 1.592331] input: PS/2 Generic Mouse as /devices/platform/i8042/serio1/input/input5
    [ 2.204410] input: ELAN900C:00 04F3:4212 Touchscreen as /devices/pci0000:00/0000:00:15.0/i2c_designware.0/i2c-0/i2c-ELAN900C:00/0018:04F3:4212.0001/input/input6
    [ 2.204513] input: ELAN900C:00 04F3:4212 as /devices/pci0000:00/0000:00:15.0/i2c_designware.0/i2c-0/i2c-ELAN900C:00/0018:04F3:4212.0001/input/input7
    [ 2.204554] input: ELAN900C:00 04F3:4212 as /devices/pci0000:00/0000:00:15.0/i2c_designware.0/i2c-0/i2c-ELAN900C:00/0018:04F3:4212.0001/input/input8
    [ 2.204632] hid-generic 0018:04F3:4212.0001: input,hidraw0: I2C HID v1.00 Device [ELAN900C:00 04F3:4212] on i2c-ELAN900C:00
    [ 2.204931] input: VEN_2C2F:00 2C2F:002B Mouse as /devices/pci0000:00/0000:00:15.2/i2c_designware.1/i2c-1/i2c-VEN_2C2F:00/0018:2C2F:002B.0002/input/input10
    [ 2.204997] input: VEN_2C2F:00 2C2F:002B Touchpad as /devices/pci0000:00/0000:00:15.2/i2c_designware.1/i2c-1/i2c-VEN_2C2F:00/0018:2C2F:002B.0002/input/input11
    [ 2.205079] hid-generic 0018:2C2F:002B.0002: input,hidraw1: I2C HID v1.00 Mouse [VEN_2C2F:00 2C2F:002B] on i2c-VEN_2C2F:00
    [ 2.715638] input: Intel HID events as /devices/platform/INTC1070:00/input/input13
    [ 2.740173] input: Intel HID 5 button array as /devices/platform/INTC1070:00/input/input14
    [ 2.802941] input: ELAN900C:00 04F3:4212 as /devices/pci0000:00/0000:00:15.0/i2c_designware.0/i2c-0/i2c-ELAN900C:00/0018:04F3:4212.0001/input/input15
    [ 2.803096] input: ELAN900C:00 04F3:4212 UNKNOWN as /devices/pci0000:00/0000:00:15.0/i2c_designware.0/i2c-0/i2c-ELAN900C:00/0018:04F3:4212.0001/input/input16
    [ 2.803147] input: ELAN900C:00 04F3:4212 UNKNOWN as /devices/pci0000:00/0000:00:15.0/i2c_designware.0/i2c-0/i2c-ELAN900C:00/0018:04F3:4212.0001/input/input17
    [ 2.803258] hid-multitouch 0018:04F3:4212.0001: input,hidraw0: I2C HID v1.00 Device [ELAN900C:00 04F3:4212] on i2c-ELAN900C:00
    [ 2.804902] i2c_hid_acpi i2c-ELAN900C:00: i2c_hid_get_input: IRQ triggered but there's no data
    [ 2.961769] input: VEN_2C2F:00 2C2F:002B Mouse as /devices/pci0000:00/0000:00:15.2/i2c_designware.1/i2c-1/i2c-VEN_2C2F:00/0018:2C2F:002B.0002/input/input19
    [ 2.961911] input: VEN_2C2F:00 2C2F:002B Touchpad as /devices/pci0000:00/0000:00:15.2/i2c_designware.1/i2c-1/i2c-VEN_2C2F:00/0018:2C2F:002B.0002/input/input20
    [ 2.962019] hid-multitouch 0018:2C2F:002B.0002: input,hidraw1: I2C HID v1.00 Mouse [VEN_2C2F:00 2C2F:002B] on i2c-VEN_2C2F:00
    [ 2.963560] Modules linked in: bluetooth intel_cstate snd dell_smm_hwmon mei_me hid_sensor_iio_common dell_wmi_ddv firmware_attributes_class wmi_bmof dell_wmi_descriptor usb_ljca intel_skl_int3472_tps68470 spi_intel_pci rc_core i2c_i801 ecdh_generic processor_thermal_mbox int3403_thermal cfg80211 intel_pmc_core mei industrialio intel_vpu soundcore i2c_algo_bit spi_intel ecc tps68470_regulator i2c_smbus igen6_edac int340x_thermal_zone clk_tps68470 mei_vsc_hw intel_vsec int3400_thermal pmt_telemetry intel_hid acpi_thermal_rel pmt_class intel_skl_int3472_discrete acpi_tad acpi_pad sparse_keymap input_leds hid_multitouch serio_raw mac_hid msr parport_pc ppdev lp parport efi_pstore dmi_sysfs ip_tables x_tables autofs4 hid_sensor_custom hid_sensor_hub intel_ishtp_hid hid_generic 8250_dw rtsx_pci_sdmmc nvme ucsi_acpi crc32_pclmul psmouse video thunderbolt typec_ucsi intel_ish_ipc nvme_core intel_lpss_pci rtsx_pci intel_lpss xhci_pci intel_ishtp typec idma64 xhci_pci_renesas nvme_auth i2c_hid_acpi i2c_hid hid wmi
    [ 3.419982] input: Dell Privacy Driver as /devices/platform/PNP0C14:02/wmi_bus/wmi_bus-PNP0C14:02/6932965F-1671-4CEB-B988-D3AB0A901919/input/input22
    [ 3.425639] input: Dell WMI hotkeys as /devices/platform/PNP0C14:02/wmi_bus/wmi_bus-PNP0C14:02/9DBB5994-A997-11DA-B012-B622A1EF5492/input/input23
    [ 3.867170] snd_hda_intel 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040100
    [ 3.867388] snd_hda_intel 0000:00:1f.3: SoundWire enabled on CannonLake+ platform, using SOF driver
    [ 4.175565] sof-audio-pci-intel-mtl 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040100
    [ 4.175587] sof-audio-pci-intel-mtl 0000:00:1f.3: SoundWire enabled on CannonLake+ platform, using SOF driver
    [ 4.175596] sof-audio-pci-intel-mtl 0000:00:1f.3: enabling device (0000 -> 0002)
    [ 4.175686] sof-audio-pci-intel-mtl 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if 0x040100
    [ 5.223265] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input24
    [ 5.223459] snd_hda_intel 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040100
    [ 5.223462] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:69/LNXVIDEO:01/input/input25
    [ 5.223500] snd_hda_intel 0000:00:1f.3: SoundWire enabled on CannonLake+ platform, using SOF driver
    [ 5.223512] sof-audio-pci-intel-mtl 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040100
    [ 5.223531] sof-audio-pci-intel-mtl 0000:00:1f.3: SoundWire enabled on CannonLake+ platform, using SOF driver
    [ 5.223923] sof-audio-pci-intel-mtl 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if 0x040100
    [ 5.229236] sof-audio-pci-intel-mtl 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
    [ 5.236429] sof-audio-pci-intel-mtl 0000:00:1f.3: use msi interrupt mode
    [ 5.256302] sof-audio-pci-intel-mtl 0000:00:1f.3: hda codecs found, mask 4
    [ 5.262237] sof-audio-pci-intel-mtl 0000:00:1f.3: Firmware paths/files for ipc type 1:
    [ 5.262244] sof-audio-pci-intel-mtl 0000:00:1f.3: Firmware file: intel/sof-ipc4/mtl/sof-mtl.ri
    [ 5.262246] sof-audio-pci-intel-mtl 0000:00:1f.3: Firmware lib path: intel/sof-ipc4-lib/mtl
    [ 5.262247] sof-audio-pci-intel-mtl 0000:00:1f.3: Topology file: intel/sof-ace-tplg/sof-mtl-cs42l43-l0-cs35l56-l23.tplg
    [ 5.263156] sof-audio-pci-intel-mtl 0000:00:1f.3: Loaded firmware library: ADSPFW, version: 2.9.0.1
    [ 5.270101] cs35l56 sdw:0:2:01fa:3556:01:2: supply VDD_P not found, using dummy regulator
    [ 5.270132] cs35l56 sdw:0:2:01fa:3556:01:2: supply VDD_IO not found, using dummy regulator
    [ 5.270147] cs35l56 sdw:0:2:01fa:3556:01:2: supply VDD_A not found, using dummy regulator
    [ 5.270912] cs35l56 sdw:0:2:01fa:3556:01:2: Got spk-id from AF01
    [ 5.271203] cs35l56 sdw:0:2:01fa:3556:01:3: supply VDD_P not found, using dummy regulator
    [ 5.271246] cs35l56 sdw:0:2:01fa:3556:01:3: supply VDD_IO not found, using dummy regulator
    [ 5.271253] cs35l56 sdw:0:2:01fa:3556:01:3: supply VDD_A not found, using dummy regulator
    [ 5.272542] cs35l56 sdw:0:2:01fa:3556:01:3: Got spk-id from AF01
    [ 5.272706] cs35l56 sdw:0:3:01fa:3556:01:0: supply VDD_P not found, using dummy regulator
    [ 5.272732] cs35l56 sdw:0:3:01fa:3556:01:0: supply VDD_IO not found, using dummy regulator
    [ 5.272743] cs35l56 sdw:0:3:01fa:3556:01:0: supply VDD_A not found, using dummy regulator
    [ 5.273200] cs35l56 sdw:0:3:01fa:3556:01:0: Got spk-id from AF01
    [ 5.273346] cs35l56 sdw:0:3:01fa:3556:01:1: supply VDD_P not found, using dummy regulator
    [ 5.273361] cs35l56 sdw:0:3:01fa:3556:01:1: supply VDD_IO not found, using dummy regulator
    [ 5.273368] cs35l56 sdw:0:3:01fa:3556:01:1: supply VDD_A not found, using dummy regulator
    [ 5.273515] cs35l56 sdw:0:3:01fa:3556:01:1: Got spk-id from AF01
    [ 5.368403] sof-audio-pci-intel-mtl 0000:00:1f.3: Booted firmware version: 2.9.0.1
    [ 5.380579] cs35l56 sdw:0:2:01fa:3556:01:3: Cirrus Logic CS35L56 Rev B0 OTP3 fw:3.4.4 (patched=0)
    [ 5.380599] cs35l56 sdw:0:3:01fa:3556:01:1: Cirrus Logic CS35L56 Rev B0 OTP3 fw:3.4.4 (patched=0)
    [ 5.394354] cs35l56 sdw:0:2:01fa:3556:01:2: Cirrus Logic CS35L56 Rev B0 OTP3 fw:3.4.4 (patched=0)
    [ 5.394361] cs35l56 sdw:0:3:01fa:3556:01:0: Cirrus Logic CS35L56 Rev B0 OTP3 fw:3.4.4 (patched=0)
    [ 5.398631] cs35l56 sdw:0:3:01fa:3556:01:1: Slave 1 state check1: UNATTACHED, status was 1
    [ 5.399350] cs35l56 sdw:0:2:01fa:3556:01:3: Slave 1 state check1: UNATTACHED, status was 1
    [ 5.399354] cs35l56 sdw:0:2:01fa:3556:01:2: Slave 2 state check1: UNATTACHED, status was 1
    [ 5.399395] cs35l56 sdw:0:3:01fa:3556:01:0: Slave 2 state check1: UNATTACHED, status was 1
    [ 9.237249] rfkill: input handler disabled
    [ 15.450342] platform sof_sdw: deferred probe pending: sof_sdw: snd_soc_register_card failed -517
    [ 16.454645] rfkill: input handler enabled
    [ 19.147197] rfkill: input handler disabled

    aplay -l
    aplay: device_list:277: no soundcards found...

    alsaucm dump text

    ALSA lib confmisc.c:165snd_config_get_card) Cannot get card index for -1
    ALSA lib parser.c:2830uc_mgr_import_master_config) card 'hw:-1' is not valid
    ALSA lib main.c:1560snd_use_case_mgr_open) error: failed to import hw:-1 use case configuration -19
    alsaucm: error failed to open sound card hw:-1: No such device

  6. #16
    Join Date
    Mar 2024
    Beans
    5

    Re: Dell XPS 14 9440 Support

    OK update - Working Audio on Dell XPS 14" (9440)!

    So, Ubuntu 24.04 got released in Beta a few days ago (https://releases.ubuntu.com/noble/)
    So...downloaded ubuntu-24.04-beta-desktop-amd64.iso to USB and installed it. This time i actually selected to install third party drivers, and it seems happy (Working GFX card) and is showing a 4050 GTX in System Details

    This version of Ubuntu comes with 6.8.0-22-generic kernel

    So i installed mainline
    sudo add-apt-repository ppa:cappelikan/ppa
    sudo apt update
    sudo apt install mainline
    And updated the kernel to 6.9-rc3 (latest but i suspect some earliers would work too)

    Then downloaded latest available sof binaries from https://github.com/thesofproject/sof-bin/releases (v2024.03)
    Extracted tar and then ran install.sh as sudo (Had issues with some folder not extracting/removing properly so removed contents of /lib/firmware/intel/sof-ace-tplg first and re-ran installer again)


    Then as per @Yellow Pasque comment, i "patched UCM" as per the thread in github issue (https://github.com/thesofproject/lin...ent-2024076848)

    curl -L -o alsa-ucm-conf.tar.gz https://github.com/alsa-project/alsa.../master.tar.gz
    tar xvzf alsa-ucm-conf.tar.gz -C /usr/share/alsa --strip-components=1 --wildcards "*/ucm" "*/ucm2"

    Rebooted and....Working audio!


    If anyone needs any further info, let me know
    Last edited by dook123; April 15th, 2024 at 06:18 AM.

  7. #17
    Join Date
    Apr 2024
    Beans
    1

    Re: Dell XPS 14 9440 Support

    It is nice that you got your Ubuntu 24.04 work on XPS 14 9440! I just wonder if all the hardware worked well with the latest released Ubuntu apart from audio and graphic card. For instance, camera, touchpad (did you test if the haptic touchpad also works). Thanks!
    It seems that updated kernel is major factor influencing the compatibility, right? Perhaps, this is why Pop os, which supports kernel 6.8, could work as well for someone.

  8. #18
    Join Date
    Jun 2012
    Beans
    28

    Re: Dell XPS 14 9440 Support

    @dook123 nice that you got audio working, thanks for the effort!
    what's a pitty is, that it requires a mainline kernel verison. hopefully it will at some point also just work with the ubuntu 24.04 kernel.

    regarding webcam it seems as also the 16" 2024 dell notebooks have the same issue: https://github.com/intel/ipu6-drivers/issues/223

    hopefully they'll fix it soon in the ipu6 drivers.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •