Results 1 to 2 of 2

Thread: Unable to install GRUB in /dev/nvme0n1

  1. #1
    Join Date
    Mar 2024
    Beans
    1

    Question Unable to install GRUB in /dev/nvme0n1

    I used this instructions (https://help.ubuntu.com/community/Fu...ion_Howto_2019) 2 years ago to setup my current pc (Ubuntu Desktop 22.04) without any problems.
    Now I have tried the same instructions to setup a new pc but I keep getting an error.
    "Unable to install GRUB in /dev/nvme0n1. Executing grub-install /dev/nvme0n1 failed.
    The hardware of the 2 pcs are identical. I also tried with a new disk in my working pc, but still the same error.
    Any ideas what I'm doing wrong?

  2. #2
    Join Date
    Jun 2014
    Beans
    7,475

    Re: Unable to install GRUB in /dev/nvme0n1

    Does the new computer have only one hard drive and is that drive blank? Which option did you select for the install, Erase disk and install or a different option? Is the new computer an EFI capable computer? Did you boot and install in EFI mode or Legacy? Did you go through the process explained on that page to "Enable encrypted Grub"? I don't use LVM or encryption so you will have to wait for someone else familiar with both to post.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •