Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Can't Install 1 package softare update

  1. #1
    Join Date
    Sep 2023
    Location
    Indonesia, West Java
    Beans
    39
    Distro
    Kubuntu

    Can't Install 1 package softare update

    I can update all application, except System Software.
    Attached Images Attached Images

  2. #2
    Join Date
    Aug 2011
    Location
    52.5° N 6.4° E
    Beans
    6,820
    Distro
    Xubuntu 22.04 Jammy Jellyfish

    Re: Can't Install 1 package softare update

    System Software is just an indication of the type of software, not the actual package name. And there could be many reasons why some upgrade doesn't install: phased updates (although they can be forced), a dependency issue resulting from a server glitch, a dependency issue resulting from packages from non-official sources on your system, broken package management.

    Let's see the details. In a terminal, run
    Code:
    sudo apt update
    sudo apt upgrade
    Those are two commands. The output is text, so you can copy-paste it to the forum.

    I use the terminal, because that's the same on every flavour of Ubuntu and has been for many releases. Unlike the GUI tools.

  3. #3
    Join Date
    Sep 2023
    Location
    Indonesia, West Java
    Beans
    39
    Distro
    Kubuntu
    Quote Originally Posted by Impavidus View Post
    System Software is just an indication of the type of software, not the actual package name. And there could be many reasons why some upgrade doesn't install: phased updates (although they can be forced), a dependency issue resulting from a server glitch, a dependency issue resulting from packages from non-official sources on your system, broken package management.

    Let's see the details. In a terminal, run
    Code:
    sudo apt update
    sudo apt upgrade
    Those are two commands. The output is text, so you can copy-paste it to the forum.

    I use the terminal, because that's the same on every flavour of Ubuntu and has been for many releases. Unlike the GUI tools.


    here the list for sudo apt update:


    Code:
    Hit:1 https://dl.google.com/linux/chrome/deb stable InRelease
    Hit:2 http://packages.microsoft.com/repos/code stable InRelease                                                
    Hit:3 https://brave-browser-apt-release.s3.brave.com stable InRelease                                          
    Hit:4 https://deb.librewolf.net jammy InRelease                                                                
    Hit:5 http://security.ubuntu.com/ubuntu jammy-security InRelease                                               
    Hit:6 https://repo.radeon.com/amdgpu/23.20/amdgpu/ubuntu jammy InRelease                                       
    Hit:7 http://id.archive.ubuntu.com/ubuntu jammy InRelease                            
    Get:8 http://id.archive.ubuntu.com/ubuntu jammy-updates InRelease [119 kB]
    Ign:9 https://ppa.launchpadcontent.net/cod...release/ubuntu jammy InRelease
    Hit:10 https://repo.radeon.com/amdgpu/23.20/rocm/apt/5.7 jammy InRelease        
    Err:11 https://ppa.launchpadcontent.net/cod...release/ubuntu jammy Release
      404  Not Found [IP: 2620:2d:4000:1::81 443]
    Reading package lists... Done
    N: Skipping acquire of configured file 'main/binary-i386/Packages' as repository 'https://brave-browser-apt-rel
    ease.s3.brave.com stable InRelease' doesn't support architecture 'i386'
    E: The repository 'https://ppa.launchpadcontent.net/codeblocks-devs/release/ubuntu jammy Release' does not have
     a Release file.
    N: Updating from such a repository can't be done securely, and is therefore disabled by default.
    N: See apt-secure(8) manpage for repository creation and user configuration details.
    And here for sudo apt upgrade

    Code:
    Reading package lists... Done
    Building dependency tree... Done
    Reading state information... Done
    You might want to run 'apt --fix-broken install' to correct these.
    The following packages have unmet dependencies:
     linux-image-generic-hwe-22.04 : Depends: linux-modules-extra-6.5.0-21-generic but it is not installed
    E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
    Last edited by deadflowr; February 24th, 2024 at 05:19 AM. Reason: posts merged; added code tags

  4. #4
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    13,611
    Distro
    Ubuntu

    Re: Can't Install 1 package softare update

    You need to fix your sources.

    First,
    the codeblocks PPA is dead and has no packages for 22.04.
    You need to remove it.
    Run
    Code:
    sudo add-apt-repository -r ppa:codeblocks-devs/daily
    Second,
    you need to add a part to the brave repo list
    should read like
    Code:
    deb [signed-by=/usr/share/keyrings/brave-browser-archive-keyring.gpg, arch=amd64] https://brave-browser-apt-release.s3.brave.com/ stable main
    You need to add the arch=amd64 or else it'll want to keep looking for the i386 packages that don't exist.


    But the only actual error is the codeblocks PPA error.

    Once you remove that you can try re-running apt update and apt upgrade.
    If it gives you the same error message again, try running the command it shows.
    Code:
    sudo apt --fix-broken install
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  5. #5
    Join Date
    Sep 2023
    Location
    Indonesia, West Java
    Beans
    39
    Distro
    Kubuntu

    Re: Can't Install 1 package softare update

    do i need remove through terminal or go to directory itself?



    because i run the first code you gave me, it giving me this message:
    Code:
    Repository: 'deb https://ppa.launchpadcontent.net/cod.../daily/ubuntu/ jammy main'
    Description:
    Built daily from an imported branch of the SVN trunk.
    
    To install Code::Blocks from this PPA, open a terminal and type:
    
    sudo add-apt-repository ppa:codeblocks-devs/daily
    sudo apt-get update
    sudo apt-get install codeblocks codeblocks-contrib
    More info: https://launchpad.net/~codeblocks-de...e/ubuntu/daily
    Removing repository.
    Press [ENTER] to continue or Ctrl-c to cancel.
    Hit:1 https://dl.google.com/linux/chrome/deb stable InRelease
    Get:2 http://packages.microsoft.com/repos/code stable InRelease [3.589 B]                                      
    Get:3 http://packages.microsoft.com/repos/code stable/main arm64 Packages [16,7 kB]                            
    Get:4 http://packages.microsoft.com/repos/code stable/main amd64 Packages [16,6 kB]                            
    Get:5 http://packages.microsoft.com/repos/code stable/main armhf Packages [16,7 kB]                            
    Hit:6 https://brave-browser-apt-release.s3.brave.com stable InRelease                                          
    Hit:7 http://id.archive.ubuntu.com/ubuntu jammy InRelease                                                      
    Get:8 http://id.archive.ubuntu.com/ubuntu jammy-updates InRelease [119 kB]                                     
    Get:9 http://security.ubuntu.com/ubuntu jammy-security InRelease [110 kB]                                      
    Hit:10 https://deb.librewolf.net jammy InRelease                                                               
    Hit:11 https://repo.radeon.com/amdgpu/23.20/amdgpu/ubuntu jammy InRelease                                      
    Hit:12 https://repo.radeon.com/amdgpu/23.20/rocm/apt/5.7 jammy InRelease                                       
    Ign:13 https://ppa.launchpadcontent.net/cod...release/ubuntu jammy InRelease
    Err:14 https://ppa.launchpadcontent.net/cod...release/ubuntu jammy Release
      404  Not Found [IP: 2620:2d:4000:1::81 443]
    Reading package lists... Done
    N: Skipping acquire of configured file 'main/binary-i386/Packages' as repository 'https://brave-browser-apt-rel
    ease.s3.brave.com stable InRelease' doesn't support architecture 'i386'
    E: The repository 'https://ppa.launchpadcontent.net/codeblocks-devs/release/ubuntu jammy Release' does not have
     a Release file.
    N: Updating from such a repository can't be done securely, and is therefore disabled by default.
    N: See apt-secure(8) manpage for repository creation and user configuration details.
    Last edited by ajgreeny; February 24th, 2024 at 08:43 AM. Reason: Code tags repaired

  6. #6
    Join Date
    Sep 2023
    Location
    Indonesia, West Java
    Beans
    39
    Distro
    Kubuntu

    Re: Can't Install 1 package softare update

    Quote Originally Posted by deadflowr View Post

    Second,
    you need to add a part to the brave repo list
    should read like
    Code:
    deb [signed-by=/usr/share/keyrings/brave-browser-archive-keyring.gpg, arch=amd64] https://brave-browser-apt-release.s3.brave.com/ stable main
    You need to add the arch=amd64 or else it'll want to keep looking for the i386 packages that don't exist.
    brave repo? you mean brave directory? like a folder file?


    edit 2: nevermind. i think i got it

    edit 3: how to edit it? i use kate it gave me weird word

    edit 4: what do you mean by https://brave-browser-apt-release.s3.brave.com/ stable main
    Last edited by rifqilubis; February 24th, 2024 at 08:14 AM.

  7. #7
    Join Date
    Aug 2011
    Location
    52.5° N 6.4° E
    Beans
    6,820
    Distro
    Xubuntu 22.04 Jammy Jellyfish

    Re: Can't Install 1 package softare update

    OK, you think you got it, but let's make it sure.

    Somewhere in the file /etc/apt/sources.list, or in a file in the directry /etc/apt/sources.list.d/ is a line telling where the brave repository can be found. That line must be changed to the one given by deadflowr. It's the line starting with deb. Note that you need root permissions to edit that file. The proper way to edit files with root permisions is to use sudoedit. By default it uses the nano text editor, but you can change that if you want, using the EDITOR environment variable.

    Your initial problem appears to be caused by a messed up package manager. A simple
    Code:
    sudo apt --fix-broken install
    should fix that, or at least give more information.

  8. #8
    Join Date
    Jul 2005
    Location
    I think I'm here! Maybe?
    Beans
    Hidden!
    Distro
    Xubuntu 22.04 Jammy Jellyfish

    Re: Can't Install 1 package softare update

    Code:
    sudoedit /etc/apt/sources.list.d/brave-browser-release.list
    and then change the line to
    Code:
    deb [signed-by=/usr/share/keyrings/brave-browser-archive-keyring.gpg, arch=amd64] https://brave-browser-apt-release.s3.brave.com/ stable main
    simply by adding that , arch=amd64.
    Press Ctrl+o (o for overwrite) then Enter, and finally Ctrl+X to close nano - #(This in case you don't know nano)

    What you see, however, is not an error but a warning that the 32bit systems are no longer available so if you do nothing about it nothing bad will happen, you will just see that warning every time you update the repos.

  9. #9
    Join Date
    Sep 2023
    Location
    Indonesia, West Java
    Beans
    39
    Distro
    Kubuntu

    Re: Can't Install 1 package softare update

    Quote Originally Posted by Impavidus View Post
    OK, you think you got it, but let's make it sure.

    Somewhere in the file /etc/apt/sources.list, or in a file in the directry /etc/apt/sources.list.d/ is a line telling where the brave repository can be found. That line must be changed to the one given by deadflowr. It's the line starting with deb. Note that you need root permissions to edit that file. The proper way to edit files with root permisions is to use sudoedit. By default it uses the nano text editor, but you can change that if you want, using the EDITOR environment variable.

    Your initial problem appears to be caused by a messed up package manager. A simple
    Code:
    sudo apt --fix-broken install
    should fix that, or at least give more information.

    done that but it gave me this, sorry for late reply. forgot to open linux.

    Code:
    sudo apt --fix-broken install
    Reading package lists... Done
    Building dependency tree... Done
    Reading state information... Done
    Correcting dependencies... Done
    The following packages were automatically installed and are no longer required:
      codeblocks-common i965-va-driver:i386 intel-media-va-driver:i386 libapparmor1:i386 libasound2:i386
      libasound2-plugins:i386 libastyle3 libasyncns0:i386 libbrotli1:i386 libc6-i386 libcodeblocks0
      libdbus-1-3:i386 libflac8:i386 libfontconfig1:i386 libfreetype6:i386 libglib2.0-0:i386 libgnutls30:i386
      libhogweed6:i386 libigdgmm12:i386 libjack-jackd2-0:i386 libnettle8:i386 libnm0:i386 libogg0:i386
      libopus0:i386 libp11-kit0:i386 libpng16-16:i386 libpulse0:i386 libsamplerate0:i386 libsndfile1:i386
      libtasn1-6:i386 libtinyxml2.6.2v5 libva-drm2:i386 libva-glx2 libva-glx2:i386 libva-x11-2:i386 libva2:i386
      libvorbis0a:i386 libvorbisenc2:i386 libvulkan1:i386 libwxbase3.0-0v5 libwxgtk3.0-gtk3-0v5 libwxsmithlib0
      libxinerama1:i386 libxss1:i386 linux-headers-6.2.0-39-generic linux-headers-6.5.0-14-generic
      linux-headers-6.5.0-15-generic linux-hwe-6.2-headers-6.2.0-39 linux-hwe-6.5-headers-6.5.0-14
      linux-hwe-6.5-headers-6.5.0-15 linux-image-6.2.0-39-generic linux-image-6.5.0-14-generic
      linux-image-6.5.0-15-generic linux-modules-6.2.0-39-generic linux-modules-6.5.0-14-generic
      linux-modules-6.5.0-15-generic linux-modules-extra-6.2.0-39-generic linux-modules-extra-6.5.0-14-generic
      linux-modules-extra-6.5.0-15-generic mesa-va-drivers:i386 mesa-vulkan-drivers:i386 va-driver-all:i386
      valgrind
    Use 'sudo apt autoremove' to remove them.
    The following additional packages will be installed:
      linux-modules-extra-6.5.0-21-generic
    The following NEW packages will be installed:
      linux-modules-extra-6.5.0-21-generic
    0 upgraded, 1 newly installed, 0 to remove and 25 not upgraded.
    45 not fully installed or removed.
    Need to get 0 B/76,6 MB of archives.
    After this operation, 455 MB of additional disk space will be used.
    Do you want to continue? [Y/n] y
    (Reading database ... 341306 files and directories currently installed.)
    Preparing to unpack .../linux-modules-extra-6.5.0-21-generic_6.5.0-21.21~22.04.1_amd64.deb ...
    Unpacking linux-modules-extra-6.5.0-21-generic (6.5.0-21.21~22.04.1) ...
    dpkg-deb (subprocess): ZSTD_decompressStream error : Corrupted block detected  
    
    dpkg-deb:error: <decompress> subprocess returned error exit status 2
    dpkg: error processing archive /var/cache/apt/archives/linux-modules-extra-6.5.0-21-generic_6.5.0-21.21~22.04.1
    _amd64.deb (--unpack):
     cannot copy extracted data for './lib/modules/6.5.0-21-generic/kernel/drivers/net/ethernet/neterion/s2io.ko' t
    o '/lib/modules/6.5.0-21-generic/kernel/drivers/net/ethernet/neterion/s2io.ko.dpkg-new': unexpected end of file
     or stream
    Errors were encountered while processing:
     /var/cache/apt/archives/linux-modules-extra-6.5.0-21-generic_6.5.0-21.21~22.04.1_amd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    
    

  10. #10
    Join Date
    Sep 2023
    Location
    Indonesia, West Java
    Beans
    39
    Distro
    Kubuntu

    Re: Can't Install 1 package softare update

    shoud i just upgrade the package(update) right now? or there something wrong

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •