Results 1 to 3 of 3

Thread: Trouble Booting GRUB Automatically from Portable USB Drive

Threaded View

  1. #1
    Join Date
    Feb 2024
    Beans
    1

    Trouble Booting GRUB Automatically from Portable USB Drive

    Hello everyone,

    I'm encountering an issue with booting GRUB automatically from a portable USB drive, and I could use some assistance in troubleshooting it.

    Here's the situation: I've installed Debian on a removable USB drive with three partitions - `sdb1` for EFI, `sdb2` for `/boot`, and `sdb3` as a LUKS encrypted drive for the root filesystem. I've configured the system to boot from the USB drive, and I can manually select it from the boot menu. However, instead of loading GRUB automatically, it takes me directly to the GRUB screen of my main OS.

    Here's what I've tried so far:
    1. Reinstalled GRUB from a live system and updated the configuration without any other drive connected to the system.
    2. Verified that GRUB is installed correctly on the EFI partition (`/boot/efi` on `sdb1`) and that the configuration points to the correct partitions and paths.
    3. Checked the UUIDs in `/etc/fstab` to ensure they match the corresponding partitions.
    4. Confirmed that Secure Boot is not enabled on the system.
    5. Tried adjusting the boot order in the BIOS/UEFI settings.

    Despite these efforts, I'm still unable to boot into GRUB automatically from the USB drive. The issue also persist among different systems.

    Interestingly, when I manually select the EFI file (`grubx64.efi`) from the boot menu, it loads GRUB without any issues.

    I'm puzzled by this behavior and would appreciate any insights or suggestions on how to resolve it. Could there be something I'm overlooking in the GRUB installation process or the system's boot configuration?

    If anyone has experienced a similar issue or has expertise in troubleshooting GRUB boot problems, I'd be grateful for your help. Thank you in advance for any assistance you can provide.

    EDIT: I have created multiple copies of the system on different usb drives and a diskimage of it on my harddrive, so I am ready to try any idea on how to resolve this problem.

    Best regards,
    Likimate
    Last edited by likimate; February 22nd, 2024 at 04:08 PM. Reason: additional information

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •