Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Autofs service won't start - missing kernel module?

  1. #11
    Join Date
    Feb 2016
    Beans
    20

    Re: Autofs service won't start - missing kernel module?

    Autofs files are already configured in our environment. However, with the validated config used successfully on other (RHEL/CentOS) servers, autofs service will not start on this problem server.

  2. #12
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Autofs service won't start - missing kernel module?

    Quote Originally Posted by ecrosby View Post
    Autofs files are already configured in our environment. However, with the validated config used successfully on other (RHEL/CentOS) servers, autofs service will not start on this problem server.
    autofs is autofs on all Linux, so what's different about the working and non-working environments?

    Any other hints in the assorted log files?

    The 5.4 kernel is pretty old. I moved to 5.15 when 18.04 standard support ended in 2023.

  3. #13
    Join Date
    Feb 2016
    Beans
    20

    Re: Autofs service won't start - missing kernel module?

    All the logs are displaying the same generic error: /usr/sbin/automount: test mount forbidden or incorrect kernel protocol version, kernel protocol version 5.00 or above required.

    Unfortunately, due to the program, we can't move to a newer kernel at this time.
    I think my options are limited. After communicating with the program leads on Friday, I think we are stuck where we are. We're either not going to use autofs and just setup a permanent NFS share for our purposes (since NFS works) or work with what we have until a much later date when we can move past 18.04.
    I appreciate your time and responses @TheFu
    Last edited by ecrosby; February 17th, 2024 at 04:16 PM.

  4. #14
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Autofs service won't start - missing kernel module?

    In googling the error ... there are a few things not mentioned. running out of inodes in /tmp/ was one. https://www.suse.com/support/kb/doc/?id=000020955
    Is this system on real hardware, inside a VM, inside a container, or a WSL thing?

    Coming back to the kernel modules,
    sudo apt -y install linux-modules-extra-$(uname -r)

    Just a few more things to check out, if you haven't already. I've used NFS for 30 yrs and can't say I've seen this issue before. Being in a secure environment makes it difficult. I'd clone the server, take that clone to a different network and work on solutions there, assuming this is allowed.

  5. #15
    Join Date
    Feb 2016
    Beans
    20

    Re: Autofs service won't start - missing kernel module?

    In googling the error ... there are a few things not mentioned. running out of inodes in /tmp/ was one. https://www.suse.com/support/kb/doc/?id=000020955
    Yep, saw that. It's not an issue.

    Is this system on real hardware, inside a VM, inside a container, or a WSL thing?
    It is a VM.

    Coming back to the kernel modules,
    sudo apt -y install linux-modules-extra-$(uname -r)
    Yep, tried that on a test machine that has a connection to the Ubuntu repository. It didn't work. I can't remember the output but it seemed there was no extra modules for that kernel being used.
    What I did do in that testing is take that same VM that was on a outward facing network to the Ubuntu repository was install the next low latency kernel version up and autofs worked. So, again, I am leaning toward the kernel that we are required to use has missing autofs modules.
    As mentioned, I'll like just have to skip the autofs option and just setup an NFS share for our purposes. Or, don't even setup the NFS share at all. I am letting the program leads make that decision.

  6. #16
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Autofs service won't start - missing kernel module?

    Well, crap.

    There's only 1 other thing, and I hate suggesting it. systemd-mount supports an automount option. This is separate from autofs.

    Https://ubuntuforums.org/showthread....6#post13935156

    It doesn't work quiet the same way - it delays mounts until requested, but it doesn't umount unused file systems later. It uses the fstab (or a unit file).
    sudoedit /etc/fstab
    # add a line to the fstab:
    Code:
    romulus:/Data/r2     /S      nfs        x-systemd.automount,x-systemd.idle-timeout=600s,proto=tcp,noauto    0     2
    where:
    * /S is the local mount point
    * x-systemd.automount appears to HAVE TO BE first in the options
    * x-systemd.idle-timeout=600s is optional AND doesn't work
    * x-systemd.device-timeout=10s is optional - stop trying after 10 sec
    * proto=tcp is a best practice for NFS
    * noauto is there to prevent mounting before a request was made

    Code:
    sudo systemctl daemon-reload
    sudo systemctl start S.automount
    OR
    Code:
    sudo systemctl restart S.automount
    For remote mounts:
    Code:
    sudo systemctl daemon-reload
    sudo systemctl restart remote-fs.target
    I tested this a few years ago and haven't touched it since. My testing was on 18.04, I think.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •