Page 4 of 4 FirstFirst ... 234
Results 31 to 40 of 40

Thread: EFI booting hangs

  1. #31
    Join Date
    Jul 2010
    Beans
    25
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: EFI booting hangs

    Quote Originally Posted by tea for one View Post
    Previously, you mentioned that you can boot this external installation in Legacy (BIOS) mode on your Fit-PC3.
    Can you boot the OS in BIOS mode and supply a boot-repair report?
    More info https://help.ubuntu.com/community/Boot-Repair - 2nd option using your installed system.

    It may provide a clue...............?
    tea for one, do you want me to run it on my fit-PC3 specifically?

  2. #32
    Join Date
    Jul 2010
    Beans
    25
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: EFI booting hangs

    I tried adding "nosmp" to the extra boot arguments in this post and got the same results:
    Quote Originally Posted by Melab View Post
    I added the following boot options to the kernel command line and booted Linux on my fit-PC3 in EFI mode:
    Code:
    earlyprintk ignore_loglevel initcall_debug earlycon=efifb
    For the first time, I am seeing output from Linux. The kernel console output stopped with these last two lines:
    Code:
    [    8.352123] printk: console [tty0] enabled
    [    8.412484] printk: bootconsole [efifb0] disabled
    Does anyone know why this is?

  3. #33
    Join Date
    Jul 2010
    Beans
    25
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: EFI booting hangs

    Does no one have any advice?

  4. #34
    Join Date
    Jun 2014
    Beans
    7,369

    Re: EFI booting hangs

    In post 29, you say: "Doing that presupposes that I have successfully booted Linux in EFI mode" in response to a suggestion to run efibootmgr. Possibly because in post 26 you say " I added the following boot options to the kernel command line and booted Linux on my fit-PC3 in EFI mode". So did you boot in EFI mode or not? Running the boot repair script using the 2nd option when booted from whatever you have and selecting the Create BootInfo Summar option will give details on your system and boot files regardless of whether it is a Legacy or EFI install.

    8.412484] printk: bootconsole [efifb0] disabled
    The error above which you report in an earlier post is discussed at the kernel.org web site at the link below. I don't know if it will help as it discusses Macs and I know nothing about them nor am I familiar with the hardware you are using. I expect the only possibility to get real help is if you can post a link to the boot repair output.

    https://docs.kernel.org/fb/efifb.html

  5. #35
    Join Date
    Jul 2010
    Beans
    25
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: EFI booting hangs

    Quote Originally Posted by yancek View Post
    In post 29, you say: "Doing that presupposes that I have successfully booted Linux in EFI mode" in response to a suggestion to run efibootmgr. Possibly because in post 26 you say " I added the following boot options to the kernel command line and booted Linux on my fit-PC3 in EFI mode". So did you boot in EFI mode or not? Running the boot repair script using the 2nd option when booted from whatever you have and selecting the Create BootInfo Summar option will give details on your system and boot files regardless of whether it is a Legacy or EFI install.



    The error above which you report in an earlier post is discussed at the kernel.org web site at the link below. I don't know if it will help as it discusses Macs and I know nothing about them nor am I familiar with the hardware you are using. I expect the only possibility to get real help is if you can post a link to the boot repair output.

    https://docs.kernel.org/fb/efifb.html
    I added those boot options by using GRUB's menu entry edit function. GRUB works just fine.

    I have been able to boot the Linux installation on my USB stick in on other platforms in EFI mode.

  6. #36
    Join Date
    Jul 2010
    Beans
    25
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: EFI booting hangs

    Quote Originally Posted by tea for one View Post
    Previously, you mentioned that you can boot this external installation in Legacy (BIOS) mode on your Fit-PC3.
    Can you boot the OS in BIOS mode and supply a boot-repair report?
    More info https://help.ubuntu.com/community/Boot-Repair - 2nd option using your installed system.

    It may provide a clue...............?
    I have attached the resulting summary.
    Attached Files Attached Files

  7. #37
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: EFI booting hangs

    Please use Boot-Repair's option to post to a pastebin site & then post link.

    Many will not download an unknown file as it may contain a virus.
    UEFI boot install & repair info - Regularly Updated :
    https://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  8. #38
    Join Date
    Jul 2010
    Beans
    25
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: EFI booting hangs

    Quote Originally Posted by tea for one View Post
    Previously, you mentioned that you can boot this external installation in Legacy (BIOS) mode on your Fit-PC3.
    Can you boot the OS in BIOS mode and supply a boot-repair report?
    More info https://help.ubuntu.com/community/Boot-Repair - 2nd option using your installed system.

    It may provide a clue...............?
    The boot info summary (the same one I attached in the form of a ZIP file) can be found here.

  9. #39
    Join Date
    Jul 2010
    Beans
    25
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: EFI booting hangs

    Quote Originally Posted by oldfred View Post
    Please use Boot-Repair's option to post to a pastebin site & then post link.

    Many will not download an unknown file as it may contain a virus.
    Weird. Okay. I have posted it here.

  10. #40
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: EFI booting hangs

    Is sda the external drive?
    Many systems promote an external drive on reboot to first drive when it is second drive when first plugged in.
    You show Windows UEFI boot on sdb.

    You show both UEFI & BIOS boot configuration. Often after updates only one or the other works.
    And then system UEFI/BIOS has to be set to match boot mode. Some newer systems will auto switch to correct mode if you select UEFI menu entry with other boot mode. Older systems required modes matched.

    Your fstab shows mount of /boot and ESP - efi system partition, so last install of grub was in UEFI mode. So always boot in UEFI mode.
    But report did not show this which it normally does.
    sudo efibootmgr -v

    But if you can boot to grub menu, not a boot issue, but something after grub.
    In grub menu remove quiet splash to see boot process. Often last line is not issue, but something before that.
    /vmlinuz-5.15.0-91-generic root=UUID=2f30d5e3-4fbe-4f2b-af8c-b81a2737a2a3 ro splash quiet
    While I have used rEFInd for emergency boot, I have never configured it for my system. It seems to add a lot of files into ESP.

    Do you always have external drive plugged in?
    UEFI usually removes or changes an entry for any drive that is removed.
    So if you have an "ubuntu" entry like an internal drive install, it then stops working. But you should always be able to boot external drive using UEFI boot menu & drive entry like when you boot the live installer. Entry actually is the /EFI/Boot/bootx64.efi. But with full installs the /EFI/ubuntu folder must exist in ESP for it to work. Some in the full install's version of bootx64.efi is hard coded to only use /EFI/ubuntu/grub.cfg.
    UEFI boot install & repair info - Regularly Updated :
    https://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

Page 4 of 4 FirstFirst ... 234

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •