Results 1 to 8 of 8

Thread: GUI fails to open after going to sleep. apparmor.service failed.

  1. #1
    Join Date
    Jan 2022
    Beans
    Hidden!

    GUI fails to open after going to sleep. apparmor.service failed.

    This has happened several times since the 6.5 update.

    I can ssh into it and this is what is going on:

    Code:
    ********:~$ sudo systemctl --failed
      UNIT             LOAD   ACTIVE SUB    DESCRIPTION           
    ● apparmor.service loaded failed failed Load AppArmor profiles
    
    LOAD   = Reflects whether the unit definition was properly loaded.
    ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
    SUB    = The low-level unit activation state, values depend on unit type.
    1 loaded units listed.
    **********:~$ uname -a
    Linux ********** 6.5.0-14-generic #14~22.04.1-Ubuntu SMP PREEMPT_DYNAMIC Mon Nov 20 18:15:30 UTC 2 x86_64 x86_64 x86_64 GNU/Linux
    Code:
    $ sudo systemctl start apparmor.service
    Job for apparmor.service failed because the control process exited with error code.
    See "systemctl status apparmor.service" and "journalctl -xeu apparmor.service" for details.
    Here is the log:

    Code:
    journalctl -xeu apparmor.service
    Jan 25 20:37:31 eng-dev2 apparmor.systemd[1231858]: Error: At least one profile failed to load
    Jan 25 20:37:31 eng-dev2 systemd[1]: apparmor.service: Main process exited, code=exited, status=1/FAILURE
    ░░ Subject: Unit process exited
    ░░ Defined-By: systemd
    ░░ Support: http://www.ubuntu.com/support
    ░░ 
    ░░ An ExecStart= process belonging to unit apparmor.service has exited.
    ░░ 
    ░░ The process' exit code is 'exited' and its exit status is 1.
    Jan 25 20:37:31 eng-dev2 systemd[1]: apparmor.service: Failed with result 'exit-code'.
    ░░ Subject: Unit failed
    ░░ Defined-By: systemd
    ░░ Support: http://www.ubuntu.com/support
    ░░ 
    ░░ The unit apparmor.service has entered the 'failed' state with result 'exit-code'.
    Jan 25 20:37:31 eng-dev2 systemd[1]: Failed to start Load AppArmor profiles.
    ░░ Subject: A start job for unit apparmor.service has failed
    ░░ Defined-By: systemd
    ░░ Support: http://www.ubuntu.com/support
    ░░ 
    ░░ A start job for unit apparmor.service has finished with a failure.
    ░░ 
    ░░ The job identifier is 11962 and the job result is failed.
    lines 499-521/521 (END)
    Jan 25 20:37:31 eng-dev2 apparmor.systemd[1231858]: Error: At least one profile failed to load
    Jan 25 20:37:31 eng-dev2 systemd[1]: apparmor.service: Main process exited, code=exited, status=1/FAILURE
    ░░ Subject: Unit process exited
    ░░ Defined-By: systemd
    ░░ Support: http://www.ubuntu.com/support
    ░░ 
    ░░ An ExecStart= process belonging to unit apparmor.service has exited.
    ░░ 
    ░░ The process' exit code is 'exited' and its exit status is 1.
    Jan 25 20:37:31 eng-dev2 systemd[1]: apparmor.service: Failed with result 'exit-code'.
    ░░ Subject: Unit failed
    ░░ Defined-By: systemd
    ░░ Support: http://www.ubuntu.com/support
    ░░ 
    ░░ The unit apparmor.service has entered the 'failed' state with result 'exit-code'.
    Jan 25 20:37:31 eng-dev2 systemd[1]: Failed to start Load AppArmor profiles.
    ░░ Subject: A start job for unit apparmor.service has failed
    ░░ Defined-By: systemd
    ░░ Support: http://www.ubuntu.com/support
    ░░ 
    ░░ A start job for unit apparmor.service has finished with a failure.
    ░░ 
    ░░ The job identifier is 11962 and the job result is failed.
    Last edited by foxsquirrel; January 26th, 2024 at 02:43 AM.

  2. #2
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: GUI fails to open after going to sleep. apparmor.service failed.

    Please show this first:
    Code:
    sudo systemctl reload apparmor.service
    Paste that back here so we can look at what's going on.

    I suspect you have a bad profile in the mix. Have you added any new profiles since the install?
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags | System-info | Forum Guide lines | Arch Linux, Debian Unstable, FreeBSD

  3. #3
    Join Date
    Jan 2022
    Beans
    Hidden!

    Re: GUI fails to open after going to sleep. apparmor.service failed.

    Code:
    sudo systemctl reload apparmor.service
    apparmor.service is not active, cannot reload.
    Code:
    ~$ sudo systemctl --failed
      UNIT             LOAD   ACTIVE SUB    DESCRIPTION                                       
    ● apparmor.service loaded failed failed Load AppArmor profiles
    ● vmware.service   loaded failed failed LSB: This service starts and stops VMware services
    
    LOAD   = Reflects whether the unit definition was properly loaded.
    ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
    SUB    = The low-level unit activation state, values depend on unit type.
    2 loaded units listed.
    Not sure how to read this, the gui is up, I am getting this via ssh.

    I have not added any profiles, unless some package did. On that machine VMware is up and the gui is up...
    Last edited by foxsquirrel; January 26th, 2024 at 04:59 AM.

  4. #4
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: GUI fails to open after going to sleep. apparmor.service failed.

    Good your here, I like a responsive poster...

    Now lets disable apparmor, and then try to boot to your Desktop.
    Code:
    sudo systemctl stop apparmor.service
    ### AND
    sudo systemctl disable apparmor.service
    Now reboot.
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags | System-info | Forum Guide lines | Arch Linux, Debian Unstable, FreeBSD

  5. #5
    Join Date
    Jan 2022
    Beans
    Hidden!

    Re: GUI fails to open after going to sleep. apparmor.service failed.

    Code:
    ********
        State: running
         Jobs: 0 queued
       Failed: 0 units
        Since: Thu 2024-01-25 23:10:00 EST; 51s ago
    That cleared up the apparmor problem.

    On the other machine I upgraded to the 6.5.15 from .14 ran the vmware removal script then reinstalled 17.5. It came up so I am assuming that is fine. What ever the issue was must have been in the .14 release?

    Update: just tried the vmware on this machine and it will not start the vm. The player will open and allow a configuration however when it is ran it breaks. I will be back tomorrow, its getting late here.
    Last edited by foxsquirrel; January 26th, 2024 at 05:25 AM.

  6. #6
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: GUI fails to open after going to sleep. apparmor.service failed.

    Ah there it is>>>" vmware removal script"
    If your now updated on vmware lets re enable apparmor *but only if it is upgraded*
    Code:
    sudo systemctl start --now apparmor.service
    #### And
    sudo systemctl status apparmor
    No Reboot yet...

    Be aware apparmor won't load on next boot until it's enabled again, but for now we need to see if its happy now.
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags | System-info | Forum Guide lines | Arch Linux, Debian Unstable, FreeBSD

  7. #7
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: GUI fails to open after going to sleep. apparmor.service failed.

    It's late here, I'll check back tomorrow.
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags | System-info | Forum Guide lines | Arch Linux, Debian Unstable, FreeBSD

  8. #8
    Join Date
    Aug 2016
    Location
    Wandering
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: GUI fails to open after going to sleep. apparmor.service failed.

    Waiting for your reply now.

    Solved via PM (This is the OP's request)
    Last edited by 1fallen; January 27th, 2024 at 07:22 PM.
    With realization of one's own potential and self-confidence in one's ability, one can build a better world.
    Dalai Lama>>
    Code Tags | System-info | Forum Guide lines | Arch Linux, Debian Unstable, FreeBSD

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •