Results 1 to 3 of 3

Thread: Mouse stopped working on Ubuntu VM

  1. #1
    Join Date
    Jan 2024
    Beans
    2

    Mouse stopped working on Ubuntu VM

    Hi,

    I've been using Ubuntu 22.04.3 virtual machine on Windows 10 with VirtualBox 7.0.10 for some time and everything was good. But suddenly, the mouse stopped working properly. I can use the icons in the sidebar but I can't click on anything in opened windows. Interestingly, after opening a new app window, I can drag it but only once. If I try to do it again, nothing happens and I have to reopen the application. I have to close apps by right-clicking on their icons in the sidebar because I can't click the X button, among the others.


    I've tried different solutions like:


    - disabling and enabling Mouse Integration
    - changing pointing device to PS/2 Mouse, USB Tablet or even USB Multi-Touch Tablet
    - killing drag&drop processes
    - unchecking Enable Nested Paging in Acceleration settings

    but nothing helped. What else can I do?

  2. #2
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Mouse stopped working on Ubuntu VM

    Reinstall the Guest Additions.
    I haven't used vbox in over a decade, but it used to be that after every new kernel was installed into a VM, the guest additions needed to be reinstalled to relink to the new kernel.

  3. #3
    Join Date
    Jan 2024
    Beans
    2

    Re: Mouse stopped working on Ubuntu VM

    Quote Originally Posted by TheFu View Post
    Reinstall the Guest Additions.
    Thanks for the reply. I've just tried that using the following commands:

    sudo apt-get update
    sudo apt-get install virtualbox-guest-x11

    and restarted the virtual machine but the issue still occurs. Anything else I can try to fix it?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •