Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: nvidia 390 driver on 23.04/23.10

  1. #1
    Join Date
    Dec 2023
    Beans
    9

    nvidia 390 driver on 23.04/23.10

    The debian team throws away the 390 driver from debian stable and advised to install it from sid repository. Therefore ubuntu 23 haven't got 390 driver in it's repositories too, only 525 like a debian stable. Trying to install 390 package leads to black screen. So I ask ubuntu team to add 390 package in the ubuntu 23 repository. Otherwise, the simplest way to install 390 driver on ubuntu is to delete him, and then install debian 12.

    links:
    https://wiki.debian.org/NvidiaGraphi...s#Installation
    https://bugs.launchpad.net/ubuntu/+s...y/+bug/2046098
    https://packages.ubuntu.com/search?k...ll&section=all

  2. #2
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    14,213
    Distro
    Xubuntu 22.04 Jammy Jellyfish

    Re: nvidia 390 driver on 23.04/23.10

    dltech ; Hey --

    May I suggest that you are a bit short on research ?

    Our trusted PPA still maintains the Nvidia 390 driver up to 23.04 release:
    https://launchpad.net/~graphics-driv...ive/ubuntu/ppa

    Cheers
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubuntu'n !

  3. #3
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    13,668
    Distro
    Ubuntu

    Re: nvidia 390 driver on 23.04/23.10

    The debian team throws away the 390 driver from debian stable and advised to install it from sid repository. Therefore ubuntu 23 haven't got 390 driver in it's repositories too, only 525 like a debian stable.
    What Debian does with those drivers is unrelated to what Ubuntu has done with those drivers.
    The drivers aren't from Debian anyway.
    That said, Ubuntu removed them for having reached EOL upstream: https://bugs.launchpad.net/ubuntu/+s...0/+bug/2035189

    You mentioned in your bug report that Ubuntu ships the 340 driver but that's not true.
    They ship a package called nvidia-340 but it's only a transitional package that installs the open source nouveau driver.

    What to do? what to do?

    You might have to look into this https://github.com/MeowIce/nvidia-legacy
    Says it's patched up to the latest kernels.
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  4. #4
    Join Date
    Dec 2023
    Beans
    9

    Re: nvidia 390 driver on 23.04/23.10

    Quote Originally Posted by Bashing-om View Post
    Our trusted PPA still maintains the Nvidia 390 driver up to 23.04 release:
    Sorry, forgot that trying to install driver from ppa caused to error while kernel modules building.
    Code:
    Настраивается пакет nvidia-dkms-390 (390.157-0ubuntu7) …
    update-initramfs: deferring update (trigger activated)
    Loading new nvidia-390.157 DKMS files...
    Building for 6.5.0-14-generic
    Building for architecture x86_64
    Building initial module for 6.5.0-14-generic
    ERROR: Cannot create report: [Errno 17] File exists: '/var/crash/nvidia-dkms-390.0.crash'
    Error! Bad return status for module build on kernel: 6.5.0-14-generic (x86_64)
    Consult /var/lib/dkms/nvidia/390.157/build/make.log for more information.
    dpkg: ошибка при обработке пакета nvidia-dkms-390 (--configure): подпроцесс из пакета nvidia-dkms-390 установлен сценарий post-installation возвратил код ошибки 10
    You might have to look into this https://github.com/MeowIce/nvidia-legacy
    They uses semi-working git-lfs, I can't download installer, because of authentication error.

    As I understood there is a problem in building of nvidia module for new 6.5 kernel? Build log.
    Last edited by dltech; December 16th, 2023 at 12:59 PM.

  5. #5
    Join Date
    Jun 2007
    Beans
    14,808

    Re: nvidia 390 driver on 23.04/23.10

    Quote Originally Posted by deadflowr View Post
    You might have to look into this https://github.com/MeowIce/nvidia-legacy
    Says it's patched up to the latest kernels.
    They only kept up with nvidia 340 branch. For nvidia 390, they still have an old upstream version 350.151 and only have patches for kernel 5.18.

  6. #6
    Join Date
    Jun 2007
    Beans
    14,808

    Re: nvidia 390 driver on 23.04/23.10

    https://bugs.launchpad.net/ubuntu/+s...0/+bug/2028165
    Okay, so there is a version that works with 6.5 kernel in Ubuntu 23.10 in the mantic-proposed repository. Remember to disable the proposed repo after you install the nvidia packages. You probably don't want to install everything in there..

  7. #7
    Join Date
    Dec 2023
    Beans
    9

    Re: nvidia 390 driver on 23.04/23.10

    Where I could find this hidden package? There isn't any nvidia-driver-390=390.157-0ubuntu8 in mantic-proposed and in graphics-drivers/ppa. Only nvidia-driver-390=390.157-0ubuntu7. Why this new package is not visible on repository web page? I even could not download it manually.

    upd: I manually downloaded archives from https://launchpad.net/ubuntu/+source...0.157-0ubuntu8 . Manually unpacked them, manually installed them, using commands:
    Code:
    sudo apt-src build nvidia-graphics-drivers-390
    sudo apt install ./*.deb
    It works! but I do not know, how to make it automatically.
    Last edited by dltech; December 17th, 2023 at 10:16 AM.

  8. #8
    Join Date
    Dec 2023
    Beans
    9

    Re: nvidia 390 driver on 23.04/23.10

    Driver nvidia-driver-390=390.157-0ubuntu8 installs successfully, but with blackscreen after reload. xorg.conf, generated by nvidia-xconfig looks adequate. Where is an error?
    In Xorg log I found "malloc(): unaligned tcache chunk detected".
    Last edited by dltech; December 17th, 2023 at 03:27 PM.

  9. #9
    Join Date
    Nov 2008
    Location
    Boston MetroWest
    Beans
    16,326

    Re: nvidia 390 driver on 23.04/23.10

    I have a pretty old NVIDIA card

    Code:
    01:00.0 VGA compatible controller: NVIDIA Corporation GP108 [GeForce GT 1030] (rev a1)
    It runs fine with driver 535.129.03 which was installed by default. Why would you want to use the 390-series driver?
    If you ask for help, do not abandon your request. Please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users

  10. #10
    Join Date
    Dec 2023
    Beans
    9

    Re: nvidia 390 driver on 23.04/23.10

    Quote Originally Posted by SeijiSensei View Post
    Why would you want to use the 390-series driver?
    Black screen.



    My xorg log. I do not found here something strangeXorg.txt. But in lightdm x log it ends with "malloc(): unaligned tcache chunk detected" message, and ligthtdm writes that "Process 1435 terminated with signal 11. XServer 0: X server stopped".
    Sorry, new fixed driver crashes with segfault.
    Last edited by dltech; December 17th, 2023 at 05:34 PM.

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •