I have troubles to use my secondary display via an USB-C hub from HP: https://support.hp.com/in-en/drivers...-dock/17859030

It was working fine until last Thursday but sudently it is impossible to get the monitor working through the USB-C port.
It is working perfectly via the HDMI port but as I need two displays.
And other hub functionalities are working fine (RJ45 conection, other USB inputs, ...)

My laptop is an HP Zbook Studio G5

And my graphical card returns following information when I execute:
sudo lshw -class display

       description: VGA compatible controller
       product: GP107GLM [Quadro P1000 Mobile]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:152 memory:e8000000-e8ffffff memory:a0000000-afffffff memory:b0000000-b1ffffff ioport:4000(size=128) memory:e9080000-e90fffff
       product: EFI VGA
       physical id: 2
       logical name: /dev/fb0
       capabilities: fb
       configuration: depth=32 resolution=1920,1080
The driver I have is nvidia-driver-535.

Do you have any idea how I could solve this issue? I tried many things I found on various forums but all solutions failed...

I also reinstalled the complete os (ubuntu 22.04) to make sure it is not an issue with my installation, still not working...

Thank you by advance.