Results 1 to 2 of 2

Thread: Changed default boot option, can't get to boot Ubuntu back.

  1. #1
    Join Date
    Jun 2021
    Beans
    1

    Question Changed default boot option, can't get to boot Ubuntu back.

    Hello fellow ubuntu users,
    I edited my grub config to boot Windows as the default boot option, then realized that the grub menu was set as "hidden" in the config. I get no boot menu. I updated the grub config and set it to "menu". However, I now can't get update-grub to work.
    I tried chroot'ing from a live usb stick, ran the following commands:
    Code:
    sudo mount /dev/sdb2 /mnt
    
    sudo mount --bind /dev /mnt/dev
    sudo mount --bind /sys /mnt/sys
    sudo mount --bind /proc /mnt/proc
    
    sudo mount /dev/sdb1 /mnt/boot
    sudo chroot /mnt/
    I was unable to succeed, as update grub-update threw an error, indicating the grub config wasn't found.
    Also, /mnt/boot only contained following directories:
    /mnt/boot/EFI/EFI/windows
    ubuntu
    grub

    Any ideas?

  2. #2
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: Changed default boot option, can't get to boot Ubuntu back.

    When you chroot, you have to include the ESP.
    UEFI chroot, must include ESP - efi system partition
    http://askubuntu.com/questions/53578...er/57380#57380
    chroot with UEFI, LVM, encryption on NVMe drive
    https://ubuntuforums.org/showthread....8#post13602088

    If you have a typo in /etc/default/grub or in 40_custom, it does not update grub and creates /boot/grub/grub.cfg.new so you can try to find typo.
    UEFI boot install & repair info - Regularly Updated :
    https://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •