Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23

Thread: Cannot launch into Kubuntu 23.10 with a brand new install

  1. #11
    Join Date
    Nov 2023
    Beans
    7

    Re: Cannot launch into Kubuntu 23.10 with a brand new install

    Thanks for posting that! I wound up selecting the Nouveau driver in the Additional Drivers tab, then switching back to the recommended NVIDIA driver, and then I reset my system. After I did all of that, I was able to launch my system normally again! I guess that the graphics driver wasn't set up properly during the install process.

    Code:
    $ inxi -GxxzGraphics:
      Device-1: Intel Raptor Lake-S GT1 [UHD Graphics 770] vendor: Micro-Star MSI
        driver: i915 v: kernel arch: Gen-13 ports: active: none empty: DP-1, DP-2,
        HDMI-A-1, HDMI-A-2, HDMI-A-3, HDMI-A-4 bus-ID: 00:02.0 chip-ID: 8086:a780
      Device-2: NVIDIA AD103 [GeForce RTX 4080] vendor: ZOTAC driver: nvidia
        v: 535.129.03 arch: Lovelace pcie: speed: 2.5 GT/s lanes: 16 ports:
        active: none off: DP-3 empty: DP-4,DP-5,HDMI-A-5 bus-ID: 01:00.0
        chip-ID: 10de:2704
      Device-3: Logitech HD Webcam C525 driver: snd-usb-audio,uvcvideo type: USB
        rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 1-5.1:7 chip-ID: 046d:0826
      Display: x11 server: X.Org v: 1.21.1.7 with: Xwayland v: 23.2.0
        compositor: kwin_x11 driver: X: loaded: modesetting,nvidia
        unloaded: fbdev,nouveau,vesa dri: iris gpu: nvidia,nvidia-nvswitch
        display-ID: :0 screens: 1
      Screen-1: 0 s-res: 2560x1440 s-dpi: 108
      Monitor-1: DP-3 mapped: DP-0 note: disabled model: Dell G2724D
        res: 2560x1440 dpi: 109 diag: 684mm (26.9")
      API: OpenGL v: 4.6.0 NVIDIA 535.129.03 renderer: NVIDIA GeForce RTX
        4080/PCIe/SSE2 direct-render: Yes

  2. #12
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Cannot launch into Kubuntu 23.10 with a brand new install

    Code:
    Display: x11 server: X.Org v: 1.21.1.7 with: Xwayland v: 23.2.0
        compositor: kwin_x11 driver: X: loaded: modesetting,nvidia
    I still think you need to
    a) switch from Wayland to Xorg as the display driver
    b) use the nomemset kernel boot parameter so nvidia's driver is first in the list.


    There shouldn't be any mention of Xwayland in that output.

  3. #13
    Join Date
    Nov 2023
    Beans
    7

    Re: Cannot launch into Kubuntu 23.10 with a brand new install

    I just tried doing both of those things you mentioned, but the output of inxi -Gxxz was the exact same. The odd thing is that I always selected "Desktop Session: Plasma (X11)" from the login screen. The output stayed the same when I switched to Wayland and then back to X11 before running the command again. Also, if I try checking with echo $XDG_SESSION_TYPE, it returns x11.

  4. #14
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Cannot launch into Kubuntu 23.10 with a brand new install

    I don't have 23.10 on real hardware nor do I use KDE. Perhaps things have changed in newer releases.

    Hopefully, someone else can help.

  5. #15
    Join Date
    Mar 2010
    Location
    USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Cannot launch into Kubuntu 23.10 with a brand new install

    For Kubuntu 23.10,
    Code:
    apt list plasma-workspace-wayland --installed
    If that is not there, install it...

    Then do this to fix a Scaling rendering bug with KDE Plasma, for 23.10:
    Code:
    sudoedit /usr/share/xdg-desktop-portal/kde-portals.conf
    Add this line at the end
    Code:
    org.freedesktop.impl.portal.Settings=kde;gtk;
    Reboot to pick up that change...

    At the SDDM Graphical login panel... Look at the bottom left of the screen, where it says "Desktop Session". Choose "Plasma X11". Enter your password and login.

    "Concurrent coexistence of Windows, Linux and UNIX..." || Ubuntu user # 33563, Linux user # 533637
    Sticky: Graphics Resolution | UbuntuForums 'system-info' Script | Posting Guidelines | Code Tags

  6. #16
    Join Date
    Jun 2007
    Beans
    14,800

    Re: Cannot launch into Kubuntu 23.10 with a brand new install

    Quote Originally Posted by TheFu View Post
    There shouldn't be any mention of Xwayland in that output.
    No, that's just how inxi works nowadays. If the xwayland package is installed, it reports the version, even if Wayland isn't being used. It doesn't make sense to me either..

    use the nomemset kernel boot parameter so nvidia's driver is first in the list.
    If you're referring to 'nomodeset', that is not a good idea. That will disable any accelerated graphics kernel modules/drivers from loading. It is okay for the 'modesetting' (aka GLAMOR) X driver to be present/loaded on a system with an Intel GPU. That is what Intel GPU's use for 2D acceleration.
    If OP is really worried about the Intel GPU interfering and wants to disable it, that can be done in the BIOS: https://www.technewstoday.com/msi-integrated-graphics/

    EDIT: Actually, I'm confused about whether the OP is still having any issues. "I was able to launch my system normally again!" sounds like problem solved to me.
    Last edited by Yellow Pasque; November 19th, 2023 at 09:16 PM.

  7. #17
    Join Date
    Nov 2023
    Beans
    7

    Re: Cannot launch into Kubuntu 23.10 with a brand new install

    Sorry if I wasn't clear about it before, but my issue was resolved after switching between the Nouveau and Nvidia drivers in safe mode. Should I also ignore editing kde-portals.conf if inxi always reports Wayland in it's output?

  8. #18
    Join Date
    Mar 2010
    Location
    USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Cannot launch into Kubuntu 23.10 with a brand new install

    Code:
    printenv | grep 'XDG_SESSION_TYPE'
    That will tell you whether Wayland or X11 is running. At this point you could mark the thread as "Solved". It probably doesn't matter which graphics engine is running, as now you are doing well. You know how to see what it running, and how to change it now, if you do need to.

    I would still do the edit to /usr/share/xdg-desktop-portal/kde-portals.conf... That corrects a bug that affected the font scaling, that isn't backported to Kubuntu 23.10 yet. It will hit the updates eventually.
    Last edited by MAFoElffen; November 21st, 2023 at 12:33 AM.

    "Concurrent coexistence of Windows, Linux and UNIX..." || Ubuntu user # 33563, Linux user # 533637
    Sticky: Graphics Resolution | UbuntuForums 'system-info' Script | Posting Guidelines | Code Tags

  9. #19
    Join Date
    Jun 2007
    Beans
    14,800

    Re: Cannot launch into Kubuntu 23.10 with a brand new install

    We already know OP is running X.
    Code:
    Display: x11 server: X.Org v: 1.21.1.7 with: Xwayland v: 23.2.0
        compositor: kwin_x11

  10. #20
    Join Date
    Mar 2010
    Location
    Squidbilly-Land
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Cannot launch into Kubuntu 23.10 with a brand new install

    Quote Originally Posted by MAFoElffen View Post
    Code:
    printevn | grep 'XDG_SESSION_TYPE'
    That's just painful and printevn doesn't exist. Shorter is:

    Code:
    echo $XDG_SESSION_TYPE
    So,
    Code:
    $ echo $XDG_SESSION_TYPE
    tty
    Code:
    $ echo $XDG_SESSION_TYPE
    x11
    is what I see.

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •